Bug Hunting Session
Bug 83614 - EDITING: Option to disable search results in Replace All
Summary: EDITING: Option to disable search results in Replace All
Status: RESOLVED DUPLICATE of bug 104849
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2014-09-08 15:22 UTC by tmacalp
Modified: 2016-12-23 15:55 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tmacalp 2014-09-08 15:22:53 UTC
I would like to have the ability to disable "Search Results" when performing a Replace-All in Calc.  This would return it to the pre-LibreOffice 4.2.x implementation.

In LibreOffice 4.2.X, Calc implemented showing the “Search Results” dialog for Find-All and Replace-All functions.  It now pops up a dialog with a list of all cells that were found and/or modified.

I do like the “Search Results” window and think it is quite useful for Find-All, since you actually are looking for results in that function.  Unfortunately, dismissing this dialog adds an extra step to my workflow and hampers productivity when performing many Replacements.  Even with Replacements, I can see how it might appear helpful to have a list of all things that have been replaced, but its utility simply isn't worth the inefficiency.

I think it would be a good option to include in the “Other Options” section of the Find and Replace dialog, as long as the setting is sticky.  If not there, I don't know where it should live.  It could possibly even live under the expert config page, as long as I have a way of setting it.

Also, I'm aware that Writer and other components pop-up a similar dialog showing how many items were replaced, which makes them just as inefficient.  But Calc is used much more frequently for heavy data manipulation, typically involving lots of replacements.
Comment 1 andis.lazdins 2014-09-26 15:52:07 UTC
Really bad new feature if several thousands of records should be replaced. Libreoffice usually crashes or it takes endless time to complete the operation. I guess this search results window is the reason.
Comment 2 andis.lazdins 2014-09-26 15:52:36 UTC
Valid also for 4.2.6
Comment 3 Urmas 2014-10-09 01:25:27 UTC
That is a bug. No one asked for that 'feature', so it should be turned OFF by default.
Comment 4 rik 2014-10-29 19:26:58 UTC
I concur that this is a very painful 'feature'.  

When am I trying to 'Replace All' with the 'Current selection only' option, the 'Search Results' dialog box appears.  Not only does this display a dialog box that obscures the spreadsheet which I have to move (as closing it just reopens it after the next 'Replace All' function), it unselects the previously selected columns forcing me to constantly reselect them before every 'Replace All' call.

In this particular case I have about 60 'Replace All' operations to run against two of seven columns in this spreadsheet.  This bug means that I am forced to:

Select the two columns
Enter the Search and Replace strings
Check the 'Entire cells' and 'Current selection only' check boxes
'Replace All'
Move the useless 'Search Results' dialog box
Update Search and Replace strings
_RESELECT_THE_TWO_COLUMNS_
'Replace All'
Update Search and Replace strings
_RESELECT_THE_TWO_COLUMNS_
'Replace All'
etc.

Previously all I needed to do was update the Search and Replace strings and keep pressing 'Replace All'.

Perhaps this is an inadvertent result of fixing this:
  Bug 79011 - EDITING: find all/replace all, results window does not open 

A simple check box option in the "Find & Replace" dialog box to show 'Search Results' with the default option set under the Preferences should take care if this issue.
Comment 5 tmacalp 2015-01-14 17:46:24 UTC
(In reply to rik from comment #4)

> When am I trying to 'Replace All' with the 'Current selection only' option,
> the 'Search Results' dialog box appears.  Not only does this display a
> dialog box that obscures the spreadsheet which I have to move (as closing it
> just reopens it after the next 'Replace All' function), it unselects the
> previously selected columns forcing me to constantly reselect them before
> every 'Replace All' call.
> 
> ...
> 
> Previously all I needed to do was update the Search and Replace strings and
> keep pressing 'Replace All'.

While I think it'd be very helpful if LibreOffice retained the original selection after a Replace All, I don't believe it ever behaved that way.  I tested this with OpenOffice 3.2.1 and LibreOffice 4.1.3.2 and both of those versions also lost the original selection after performing a "Replace All" call.  I think it'd be a worthy enhancement request, but I don't believe it's related to this bug.

> A simple check box option in the "Find & Replace" dialog box to show 'Search
> Results' with the default option set under the Preferences should take care
> if this issue.

I think a check box would be the most elegant solution.

While I would still like to have the option to disable Search Results while using Replace All, I did find an easy work-around for handling multiple Replace All operations.  Instead of dismissing the Search Results window each time, just leave it to the side.  From that point on, the Find & Replace dialog won't lose focus and seems to behave as it used to.  

If you really don't want to deal with it, you can minimize the Search Results window.  After that, the Search Results will never show up again.  In fact, it can be very difficult to get the results dialog to show up again.  It doesn't show up in my KDE taskbar, but I can bring it up by alt-tab'ing until it's selected.
Comment 6 QA Administrators 2016-01-17 20:03:03 UTC Comment hidden (obsolete)
Comment 7 tmacalp 2016-01-29 15:59:46 UTC
This bug still affects 5.1.0.1.
Comment 8 Cor Nouws 2016-12-21 20:40:26 UTC
I think this is valid as an enhancement request.
Maybe even easyHack little more interesting..?
Comment 10 andis.lazdins 2016-12-22 05:31:10 UTC
Thank you for good news! I got feeling that in 5.1.x and 5.2.x up to now, the dialogue is not showing results for certain range, but when it goes for some 10 thousands, it tries to show the result window. 
I can only replace up to about 10000 records, when it is more LO crashes during the operation. When I'll have more time, I'll try to find limiting number.
Comment 11 Cor Nouws 2016-12-23 15:55:49 UTC
looking at the useful comments / pointers in bug 104849, lets close this one as duplicate..

*** This bug has been marked as a duplicate of bug 104849 ***