Bug Hunting Session
Bug 83623 - Can't paste multiple rows as data inside the table
Summary: Can't paste multiple rows as data inside the table
Status: RESOLVED DUPLICATE of bug 37223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2014-09-08 18:20 UTC by sunweb
Modified: 2019-01-21 11:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sunweb 2014-09-08 18:20:34 UTC
Problem description: 
Can't paste multi row/columns data inside the table.

Steps to reproduce:
1. Open Calc(Writer, Kate, gedit or any other writer)
2. Fill in the data into 3 rows(for example):
  1a
  2b
  3c
3. Select the data and copy it
4. Open Writer and create a table in it 1x3 (for example)
5. Select all 3 rows and try to paste previously copied data inside the table

Current behavior:
It doesn't matter how you paste, non of the special paste method works.

Expected behavior:
Pastes selected data in respective rows the same way it was copied.
Operating System: All
Version: 4.2.6.2 release
Comment 1 Jean-Baptiste Faure 2014-09-13 21:26:21 UTC
Workaround if your data are text only: don't create the table first, instead use menu Table > Convert > Text to Table...

Best regards. JBF
Comment 2 sunweb 2014-09-14 07:47:06 UTC
Thats not workaround. Table already exist in odt file i need to paste additional data inside of it.
There is a script that does just that but that is a hacky method and works only if you need to paste data from table to table(and not as simple as it should be Ctrl+C -> Ctrl+V, also slow down alot on large data) not from text to table.
It should work just as simple as in MicrosoftOffice, copy and paste thats all.
Comment 3 Robinson Tryon (qubit) 2014-12-22 03:52:20 UTC
(In reply to sunweb from comment #2)
> Thats not workaround. Table already exist in odt file i need to paste
> additional data inside of it.

OK

> It should work just as simple as in MicrosoftOffice, copy and paste thats
> all.

Sounds plausible.

Status -> NEW

Handing this one over to UX so they may weigh-in.
Comment 4 sunweb 2014-12-22 07:57:21 UTC
Wow, thanks!
Comment 5 Heiko Tietze 2016-08-05 10:51:56 UTC
The text to table conversion is the intended workflow in LibreOffice. But as far as I remember Microsoft takes a selection into consideration. So when you have three lines and you select three rows, paste fills in these lines into the rows. LibO however duplicates the text in this case, which is not always wanted. 

Would it be possible to automatically convert text when there is a selection?
Comment 6 Roman Kuznetsov 2018-08-09 08:04:28 UTC
Seems like duplicate of bug 37223

*** This bug has been marked as a duplicate of bug 37223 ***