Bug Hunting Session
Bug 83652 - EDITING After sort , column not in sort modified
Summary: EDITING After sort , column not in sort modified
Status: RESOLVED DUPLICATE of bug 81633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-09 08:37 UTC by Jean Vermeulen
Modified: 2014-10-09 20:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file as described in bug description (14.75 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-09 20:23 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean Vermeulen 2014-09-09 08:37:45 UTC
Create a spreadsheet with 3 column
Column one used for sort purpose
    fill 5 row with A,C,E,G and I
Column 2 content numbers
    fill with 1,2,3,4,5
Column 3 formula : Sum (column 3 previous row,column 2 own row)
    first row filled with 1 , then =SUM(C1+B2),(C2+B3)......
Now add row 6 with values : B 6 ,column C becomes  = C5+B6
Now sort area A1:B6 en see the result , formula in column C are changed 
   e.g. : C2 was =C1+B2, it becomes =C1+B3 and so on
So results are not more accurates
Open Office work ok (version 4.1.1)
So switched temporarly to openoffice
Comment 1 ign_christian 2014-09-09 09:00:02 UTC
Hi.. That behavior is by design (changed by fixing of Bug 81309) since LO 4.3.1 and 4.2.7. You can temporarily use LO 4.3.0.4 or 4.2.6.3 to avoid this behavior.

But this behavior is configurable by Bug 81633 fixing, currently available in master (4.4 daily build).

*** This bug has been marked as a duplicate of bug 81633 ***
Comment 2 Jean-Baptiste Faure 2014-10-09 20:23:07 UTC
Created attachment 107630 [details]
test file as described in bug description

Note: in this case the configuration option in LO 4.4 does not allow _today_ to keep the standard behavior of versions ≤ 4.2.6

Added a test file for further tests.

Best regards. JBF