Bug 83687 - FORMULAEDITOR: math symbols in formula editor replaced by wingdings font-like symbols
Summary: FORMULAEDITOR: math symbols in formula editor replaced by wingdings font-like...
Status: RESOLVED DUPLICATE of bug 76239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-09-09 20:24 UTC by Sylvain André
Modified: 2015-12-15 10:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
here is a writer odt document with a short formula and a screenshot of how it looks on my system. (78.18 KB, application/vnd.oasis.opendocument.text)
2014-09-09 20:24 UTC, Sylvain André
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sylvain André 2014-09-09 20:24:16 UTC
Created attachment 106008 [details]
here is a writer odt document with a short formula and a screenshot of how it looks on my system.

Problem description: 
Opening an old documents including formulas or starting a new one, formulas can't be read as math symbols are replaced by strange characters : a floppy for =, a letter for + ...

Edited or created documents can be read normally on 4.1.4.2 on another computer.

Steps to reproduce:
After upgrading from 4.2.5 (on which I did not try formula editor)

1. open new "writer" document
2. insert, object, formula
3. try to write in the formula editor, either directly or through the mouse control panel.

Operating System: Windows 7
Version: 4.3.1.2 release
Last worked in: 4.1.4.2 release
Comment 1 Sylvain André 2014-09-09 20:41:40 UTC
I found a workaround as it seems that no OpenSymbol font was installed on my system. Downloaded a random OpenSymbol.ttf file and it seems to be working.

It's still a bug since it seems that the font was not in the package I downloaded yesterday.

Sylvain
Comment 2 Julien Nabet 2014-09-10 21:07:02 UTC
Maxim: I'm quite sure you having read a comment from you on another bugtracker. The problem is I don't remember which one :( Any idea?
Meanwhile, I put fdo#46159 in See Also since identical symptoms.
Comment 3 Maxim Monastirsky 2014-09-11 08:23:15 UTC
(In reply to comment #1)
> Downloaded a random OpenSymbol.ttf file
That's IMHO a bad idea. This font could differ between releases, and also the file name should be "opens___.ttf" so future installers could replace it properly. The best way to obtain this font is to download it directly from the git repository at http://cgit.freedesktop.org/libreoffice/core/tree/extras/source/truetype/symbol/opens___.ttf. You need to select your version from the dropdown that located at the top right corner, and then click the link named "plain". It's also possible to extract it from the msi file. You can do it using 7Zip, or using the administrative mode of window installer - "msiexec /a downloaded_package.msi" (replace "downloaded_package.msi" with the actual name of the installer).

> it seems that the font was not in the package I downloaded yesterday.
The font is in the package, but sometimes it won't retain in the system after an upgrade, for some unknown reason.

*** This bug has been marked as a duplicate of bug 76239 ***
Comment 4 Sylvain André 2014-09-11 14:40:05 UTC
Thanks for your help, I stand corrected - and so does my system now I downloaded and installed a legit opens___.ttf font.
Comment 5 Robinson Tryon (qubit) 2015-12-15 10:58:00 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]