Bug 83709 - UNDO: Crash after undoing cell moving
Summary: UNDO: Crash after undoing cell moving
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: Other All
: highest critical
Assignee: Not Assigned
Whiteboard: (target:4.4.0) (target:4.3.0) (target...
Keywords: haveBacktrace, regression
Depends on:
Reported: 2014-09-10 11:40 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-09-12 13:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

linux backtrace (15.65 KB, text/plain)
2014-09-10 11:40 UTC, Yousuf Philips (jay) (retired)
sample file (61.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-11 12:41 UTC, Yousuf Philips (jay) (retired)

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-09-10 11:40:48 UTC
Created attachment 106053 [details]
linux backtrace

1) In cell A1, type a few letters
2) Using the mouse, drag cell the cell to another location
3) Press undo
4) LibO Crash

Tested in 4.2.6 and master. Regression as it doesnt happen in 4.1.6.
Comment 1 Terrence Enger 2014-09-10 13:19:59 UTC

Just a couple of questions:
(1) In the backtrace I see class names starting Sc... .  Did your
    crash really happen in Writer?
(2) How do you drag a cell with the mouse?  All I can accomplish is to
    extend the selection, in both Writer and Calc.

You know what to do with bug status.

Comment 2 Yousuf Philips (jay) (retired) 2014-09-10 22:37:00 UTC
Hi Terry,

Thats my mistake, its calc. In order to drag a cell, select the cells you want to drag, and then the next time you click on the selected cells, you will be able to drag it.
Comment 3 ign_christian 2014-09-11 06:45:15 UTC
Hi Jay.. I can't reproduce crash with LO and portable under Win7 x86

Have you tried resetting user profile?
Comment 4 ign_christian 2014-09-11 06:46:36 UTC
(In reply to comment #3)
> ... portable ...
Comment 5 Yousuf Philips (jay) (retired) 2014-09-11 12:38:49 UTC
Though libO crashing due to the profile is still a bug, i reset it just for the fun of it and it still crashes. So it seems it wasnt as straight forward as i thought it was with my steps mentioned in the description, so i'll upload the file it happened to me in.
Comment 6 Yousuf Philips (jay) (retired) 2014-09-11 12:41:28 UTC
Created attachment 106130 [details]
sample file

1) open file
2) drag A137 which has the text .uno:InsertSound to another cell
3) undo
4) crash
Comment 7 ign_christian 2014-09-11 13:53:53 UTC
Thanks for the test file Jay. Confirm reproducible with LO - Ubuntu 12.04 x86

Possibly same root cause with Bug 82042 since cell L117 contains a SUM function with range.
Comment 8 Terrence Enger 2014-09-11 14:03:17 UTC
I think I have a possible reason for varying results!

With master commit f74a633, fetched 2014-08-23, configured:
    --enable-option-checking=fatal --enable-dbgutil --enable-crashdump
    --without-system-postgresql --without-myspell-dicts
    --with-extra-buildid --without-doxygen
built on debian wheezy 64-bit, I see the following various results:

(a) running on debian-wheezy, in which ldd identifies itself as ldd
    (Debian EGLIBC 2.13-38+deb7u4) 2.13, the program segfaults in 

                , ScBroadcastAreaEntry
                , ScBroadcastAreaHash
                , ScBroadcastAreaEqual
            >::begin (this=0x0).

      - You did notice the NULL `this` pointer, didn't you?
      - Jay's attached backtrace shows a different segfault.

(b) running in a chroot environment to debain-sid, in which ldd
    identifies itself as ldd (Debian GLIBC 2.19-10) 2.19, I see no

The bibisect versions of LibreOffice do not run in debian-wheezy.  I
shall look for a partition with an intermediate version of ubuntu
which will run the bibisect-43all versions.

Just for completeness, here is how to drag a cell:

(*) Click in the cell and hold the mouse button down.  There is little
    visible result.

(*) Drag the mouse to another cell and continue to hold the mouse
    button down.  The program shades a rectangle of cells as selected.

(*) Drag the mous back to the original cell.  The program highlights
    just the original cell as selected.

(*) Release the mouse button.  The original cell is still selected.

(*) Click in the original cell and drag it where you want it to be.
Comment 9 Kohei Yoshida 2014-09-11 21:38:29 UTC
Can someone check if this commit


has fixed this crasher?
Comment 10 Terrence Enger 2014-09-11 22:06:27 UTC
In the daily dbgutil bibisect, the crash disappears between the
versions of 2014-09-02 and 2094-09-03.  So, I can readily believe that
is that commit that fixed it.

Please ignore my earlier comment about different versions of system

Comment 11 Kohei Yoshida 2014-09-12 11:42:07 UTC
Terry, thanks for checking.  The same commit has been backported to both 4.2 and 4.3 branches.  So, the next release of the respective branch should have the fix.
Comment 12 Julien Nabet 2014-09-12 13:10:09 UTC
Let's add the targets from fdo#79441 (as indicated in the commit quoteed comment 17)