Download it now!
Bug 83789 - The color used by the font color button resets after destruction
Summary: The color used by the font color button resets after destruction
Status: RESOLVED DUPLICATE of bug 113433
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-12 06:54 UTC by Maxime THEPAULT
Modified: 2017-10-30 20:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime THEPAULT 2014-09-12 06:54:45 UTC
Hi,

With LibreOffice Writer 4.3.1.2, when I change color of a word (exemple : blue) it keep it in memory few seconds or minutes.

But often (with the same document I keep opened) if I click again on "a" button to change another word, the color choosen was lost and it apply another automatic color (red / brown).

With LibreOffice 4.2.x I never had that bug, and the color I choosen (blue) stayed for hours without problem.

Please, can you help me ?

Thank you
Comment 1 Maxime THEPAULT 2014-09-12 06:56:42 UTC
I have news :

I found it revert to another color when I copy / paste an image from another LibreOffice Writer document.

I don't understand because before I never seen that bug.
Comment 2 Maxime THEPAULT 2014-09-12 07:01:06 UTC
News again :

When I insert any image (from a file by example) I have the bug too...
Comment 3 Jacques Guilleron 2014-09-12 09:59:02 UTC
Hi Maxime,

I don't reproduce using LO 4.3.1.2 &Windows 7 Home Premium. 
Did you try to rename your profile? 
https://wiki.documentfoundation.org/FR/FAQ/Generale/110
Sometimes, that solves those issues.

regards,

Jacques
Comment 4 Maxim Monastirsky 2014-09-12 14:09:58 UTC
It's a change made in [1] to make sure that the shown color is also the one that's actually used (see Bug 61868, Bug 71413). The solution was to reset the used color according to the one that's shown on the button. Preferably should be fixed completely by a global solution as part of Bug 72991, but I'll try to fix this particular case in the meanwhile.

[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=584b415924bba22db23a4258062e54973de0ed7c
Comment 5 Maxime THEPAULT 2014-09-12 15:48:57 UTC
If I understand, you will try to fix that ?

Thank you ;)
Comment 6 mahfiaz 2016-08-04 17:20:18 UTC
This still happens in 5.2.0.4 (tested by inserting an image using the menu).
Comment 7 QA Administrators 2017-09-01 11:16:13 UTC Comment hidden (obsolete)
Comment 8 Maxim Monastirsky 2017-10-24 08:35:18 UTC

*** This bug has been marked as a duplicate of bug 72991 ***
Comment 9 Maxim Monastirsky 2017-10-30 20:26:34 UTC

*** This bug has been marked as a duplicate of bug 113433 ***