Download it now!
Bug 83791 - SUMIF() not work with a string with parenthesis as criteria
Summary: SUMIF() not work with a string with parenthesis as criteria
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-12 07:54 UTC by Paijo
Modified: 2015-01-19 12:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of sumif() bug ignore "condition with (parenthesis)" (110.12 KB, image/png)
2014-09-12 07:54 UTC, Paijo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paijo 2014-09-12 07:54:08 UTC
Created attachment 106168 [details]
Screenshot of sumif() bug ignore "condition with (parenthesis)"

SUMIF() function ignores string with parenthesis as criteria.

Step to reproduce:
1. Create a table.
2. Put some name for condition. End each name with parenthesis.
3. Entry sumif() function at other cell to calculate.

Sampel screenshot will help you to reproduce the bug.
Comment 1 ign_christian 2014-09-12 14:37:27 UTC
Hai Paijo..

I can confirm that behavior since LO 3.3.0.4 to 4.3.1.2, also with AOO 4.1.1 under Ubuntu 12.04 x86. Seems inherited from OOO.

But according to m.a.riosv's comment in Bug 77343, disabling "Enable regular expressions in formulas" solves the issue. And I can confirm that.

Don't know if it's a bug or not, let someone decide.

*) Reset importance to normal, not qualified as a critical bug I think
Comment 2 m.a.riosv 2014-09-12 23:32:30 UTC
Your question is answer in ask:

http://ask.libreoffice.org/en/question/39725/sumif-not-work-as-expected/

This is not a bug, please if you are not agree reopen it.