Download it now!
Bug 83863 - update frequency of chart is not right
Summary: update frequency of chart is not right
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 81107
  Show dependency treegraph
 
Reported: 2014-09-15 03:12 UTC by xukai
Modified: 2015-04-09 16:05 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
verify the value of datastream rate (793.63 KB, application/octet-stream)
2014-09-15 03:22 UTC, xukai
Details
update frequency of chart is not right (2.55 MB, application/octet-stream)
2014-09-15 03:34 UTC, xukai
Details
The interval time of each data update and the output content of each data update. (187.45 KB, application/x-7z-compressed)
2014-09-15 09:04 UTC, xukai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xukai 2014-09-15 03:12:58 UTC
set the interval value of data stream update to be 2 second, then verify its value is real 2 second in the sheet. But the update frequency of chart and datastream are not synchronized , sometimes the update will be executed twice after 2 sencond.
Comment 1 xukai 2014-09-15 03:22:23 UTC
Created attachment 106292 [details]
verify the value of datastream rate
Comment 2 xukai 2014-09-15 03:34:11 UTC
Created attachment 106293 [details]
update frequency of chart is not right
Comment 3 xukai 2014-09-15 03:56:25 UTC
Sometimes chart will continuely update twice, this will interrupt the scroll rate execution. The dither effect is caused by the scroll rate interruption.
> Created attachment 106293 [details]
> update frequency of chart is not right
Comment 4 xukai 2014-09-15 09:04:56 UTC
Created attachment 106304 [details]
The interval time of each data update and the output content of each data update.

From the attachment we can find that: the interval time of update data is not right, and the content of data update is redundant.
Comment 5 Kohei Yoshida 2014-09-25 15:29:26 UTC
The solution to Bug 83745 (and the necessary changes in the macro code) should fix this problem as well.