Bug Hunting Session
Bug 83875 - SLIDESHOW: Shape diamond transition is not working.
Summary: SLIDESHOW: Shape diamond transition is not working.
Status: RESOLVED DUPLICATE of bug 97195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.5.0 target:4.4.0.0.beta3
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2014-09-15 09:54 UTC by Sushil Shinde
Modified: 2016-07-27 08:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Contains slide with shape diamond transition effect. (10.34 KB, application/vnd.oasis.opendocument.presentation)
2014-09-15 09:54 UTC, Sushil Shinde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sushil Shinde 2014-09-15 09:54:47 UTC
Created attachment 106311 [details]
Contains slide with shape diamond transition effect.

Problem description: 
If transition type 'shape diamond' is applied to slide then it is missing from slide show.

Steps to reproduce:
1. create presentation on latest master.
2. Apply shape diamond transition to slide.
3. Start slide show.

Current behavior:
Transition is type none in slide show.
Expected behavior:
Shape diamond effect should be displayed in slide show (Like circle of plus shape transition)

              
Operating System: Ubuntu
Version: 4.4.0.0.alpha0+ Master
Comment 1 ign_christian 2014-09-15 14:52:31 UTC
Seems a regression. Works as expected with LO 4.2.6.3 and 4.3.2.1 - Ubuntu 12.04
Comment 2 Jorendc 2014-09-22 09:22:19 UTC
Repro, Mac OSX 10.9 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: 5b8ea53ac7cc8843ada7a1e02edea1b522f0ef0a
TinderBox: MacOSX-10.9-x86_64@53, Branch:master, Time: 2014-09-21_10:59:37
Comment 3 Matthew Francis 2014-12-10 12:06:19 UTC
Attempted to bibisect this, but could not reproduce on Linux.
I can however reproduce on a recent master build on OSX. It could be that this only occurs with accelerated OpenGL - running the diamond transition gives the following debugging output:

warn:vcl.opengl:8487:1:vcl/source/opengl/OpenGLHelper.cxx:361: GL Error #1286(invalid framebuffer operation) in File /Users/asbel/Development/LibreOffice/core/slideshow/source/engine/OGLTrans/generic/OGLTrans_TransitionerImpl.cxx at line: 393
warn:vcl.opengl:8487:1:vcl/source/opengl/OpenGLHelper.cxx:361: GL Error #1286(invalid framebuffer operation) in File /Users/asbel/Development/LibreOffice/core/slideshow/source/engine/OGLTrans/generic/OGLTrans_TransitionImpl.cxx at line: 177
warn:vcl.opengl:8487:1:vcl/source/opengl/OpenGLHelper.cxx:361: GL Error #1286(invalid framebuffer operation) in File /Users/asbel/Development/LibreOffice/core/slideshow/source/engine/OGLTrans/generic/OGLTrans_TransitionImpl.cxx at line: 273
warn:vcl.opengl:8487:1:vcl/source/opengl/OpenGLHelper.cxx:361: GL Error #1286(invalid framebuffer operation) in File /Users/asbel/Development/LibreOffice/core/slideshow/source/engine/OGLTrans/generic/OGLTrans_TransitionImpl.cxx at line: 273
Comment 4 Markus Mohrhard 2014-12-10 12:35:01 UTC
Did you use an own build or a released build?
Comment 5 Matthew Francis 2014-12-10 12:54:09 UTC
Failed reproduction on Linux used the bibisect trees.

Successful reproduction on OSX used my own build of master from a few days ago
Comment 6 Markus Mohrhard 2014-12-10 16:09:08 UTC
Please don't mix different platforms when it comes to OpenGl problems.

The OSX one is most likely a different one.
Comment 7 Commit Notification 2014-12-10 16:14:25 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3fb0320e1e6fcc8007fc6f334aad91163b6ff83d

fix packaging of OpenGL shaders, related fdo#83875

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-12-10 16:14:33 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3d87a8b0384cf35f7f5d9b7a20b9345eeaaea35&h=libreoffice-4-4

fix packaging of OpenGL shaders, related fdo#83875

It will be available in 4.4.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Matthew Francis 2014-12-10 16:57:08 UTC
As any remaining OSX bug could not in any case be bibisected, removing Whiteboard:bibisectRequest and setting notBibisectable
Comment 10 Robinson Tryon (qubit) 2015-12-14 05:43:06 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]
Comment 11 Caolán McNamara 2016-07-27 08:16:02 UTC

*** This bug has been marked as a duplicate of bug 97195 ***