Download it now!
Bug 83995 - CRASH - when attempting to open remote mysql table using mysql native or jdbc connector with connection timeout
Summary: CRASH - when attempting to open remote mysql table using mysql native or jdbc...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-17 13:34 UTC by Alex Thurgood
Modified: 2017-09-26 14:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
apple generated trace on hang force kill (482.68 KB, text/plain)
2014-09-17 13:34 UTC, Alex Thurgood
Details
crash trace (78.48 KB, text/plain)
2014-09-17 13:54 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-09-17 13:34:20 UTC
Created attachment 106430 [details]
apple generated trace on hang force kill

OSX 10.9.4
Latest master build (today 17/09)

Mysql connector extension built using :

export MARIADBCONFIG="/Volumes/HD1/Shared/Repos/LO/packages/mysql-connector-c-6.1.5-osx10.7-x86_64/bin/mysql_config" 

--enable-ext-mariadb-connector
--with-system-mariadb
--enable-bundle-mariadb

The extension builds, and is registered with LibreOfficeDev.app during build.
I can connect to a remote mysql instance on same LAN, and can open tables for editing.

If I try and open a view stored on server, LO hangs.

I can execute the view from the same remote connection via the cli.

Trace enclosed.
Comment 1 Alex Thurgood 2014-09-17 13:50:00 UTC
Further investigation reveals that view can be seen, the real problem lies in LO's inability to recover from a dropped connection, e.g. battery power saving on OSX.

Even when the remote host is awakened, LO is unable to recover the dropped connection and starts to consume huge amounts of memory.

While it is debatable whether LO should try and force a reload of the db context, it shouldn't bomb on the user IMO, even if it does show a timeout message.
Comment 2 Alex Thurgood 2014-09-17 13:54:14 UTC
Created attachment 106431 [details]
crash trace
Comment 3 Alex Thurgood 2014-09-17 13:55:46 UTC
changed title again to reflect further findings - any attempted table access causes crash after connection error message
Comment 4 Alex Thurgood 2015-01-05 07:38:37 UTC
Also confirmed on Linux by Heinrich Stollinger on the user mailing list with LO 4352.

Changing platform to ALL
Comment 5 Alex Thurgood 2015-01-05 07:40:26 UTC
Adapted title to reflect behaviour on all platforms
Comment 6 QA Administrators 2016-01-17 20:04:04 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2016-01-19 14:02:12 UTC
Still occurs on

Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale : fr-FR (fr.UTF-8)

OSX 10.11.2
Comment 8 QA Administrators 2017-03-06 14:19:47 UTC Comment hidden (obsolete)
Comment 9 Alex Thurgood 2017-06-27 10:28:55 UTC
Testing blocked by bug 107579
Comment 10 Alex Thurgood 2017-09-15 13:52:14 UTC
Still reproducible with

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

Also reproducible irrespective of the connector - the same problem occurs with the MySQLJDBC connector

Changing title to reflect finding
Comment 11 Julien Nabet 2017-09-24 11:42:19 UTC
Alex: according to the bt, it should be fixed with https://cgit.freedesktop.org/libreoffice/core/commit/?id=0297d9cc3b3fb990956cc2f8021a645d3c4fb86f

0   libdbulo.dylib                	0x000000011faf039c dbaui::SbaTableQueryBrowser::OnExpandEntry(SvTreeListEntry*) + 76
1   libdbulo.dylib                	0x000000011fafbc09 dbaui::DBTreeListBox::RequestingChildren(SvTreeListEntry*) + 41
2   libsvtlo.dylib                	0x000000010ba65ebf SvTreeListBox::Expand(SvTreeListEntry*) + 47
3   libsvtlo.dylib                	0x000000010ba4da78 SvImpLBox::MakeVisible(SvTreeListEntry*, bool) + 200
4   libdbulo.dylib                	0x000000011faf1118 dbaui::SbaTableQueryBrowser::implSelect(rtl::OUString const&, rtl::OUString const&, int, bool, utl::SharedUNOComponent<com::sun::star::sdbc::XConnection, utl::DisposableComponent> const&, bool) + 248

Don't hesitate to reopen this tracker if you still reproduce this with a build including the quoted commit.

*** This bug has been marked as a duplicate of bug 112423 ***
Comment 12 Alex Thurgood 2017-09-26 14:45:27 UTC
Version: 6.0.0.0.alpha0+
Build ID: 80d135922d5a5d0fd0d7178935653870cecf58ea
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group


Fixed for me with the above build and co-built connector extension.
Comment 13 Alex Thurgood 2017-09-26 14:49:28 UTC
I now get the correct error message displayed after a while :

MySQL server has gone away