Bug 84012 - FORMATTING: Partially missing text in shrink-to-fit cells
Summary: FORMATTING: Partially missing text in shrink-to-fit cells
Status: RESOLVED DUPLICATE of bug 82377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.5.0 target:4.4.2
Keywords: bibisected, bisected, regression
: 92066 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-17 19:22 UTC by Jim Avera
Modified: 2015-12-17 08:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot showing truncated text rendering (55.44 KB, image/png)
2014-09-17 19:22 UTC, Jim Avera
Details
Demo spreadsheet (12.48 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2014-09-17 19:23 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2014-09-17 19:22:37 UTC
Created attachment 106454 [details]
Screen shot showing truncated text rendering

Problem description: Cells with format item "Shrink to fit cell size" checked sometimes render only part of the text, chopping off half or more of the string.

Steps to reproduce:
1. Open attached demo spreadsheet.  
2. Select cell A1 which contains "Blah blah (blah, blah)"

Current behavior: Only "Blah bla" appears in cell A1, although the correct string appears in the formula-entry bar at the top.

Expected behavior: Entire string will be rendered and visible.

Please see attached screen-shot.  Thank you.

              
Operating System: Ubuntu
Version: 4.3.0.4 release
Comment 1 Jim Avera 2014-09-17 19:23:39 UTC
Created attachment 106455 [details]
Demo spreadsheet
Comment 2 Jim Avera 2014-09-17 19:30:46 UTC
Regression.   Bug does not appear with 4.1.3.2
Comment 3 Jacques Guilleron 2014-09-17 21:54:30 UTC
Hi Jim,

I reproduce with LO 4.3.2.1
Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3
& Windows 7 Home Premium.
The last version where this worked is for me LO 4.2.1.1, but I have no version up to LO 4.2.5.1. There, the text is reduced (size and length), but too much and  doesn't fit to cell size.

I set status to NEW.

regards,

Jacques
Comment 4 Albrecht Müller 2014-09-22 19:05:13 UTC
Reproduced with Version 4.2.6.3 on Windows 7 (64 Bit)
Comment 5 Xisco Faulí 2014-11-04 16:38:15 UTC
Change whiteboard from 'bibisectRequest' to 'bibisected':

0acca754077bf74469c3e1a3c7eabbc3da795266 is the first bad commit
commit 0acca754077bf74469c3e1a3c7eabbc3da795266
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 12:04:53 2014 +0000

    source-hash-5e651d4084df7662b56ea980934c0428ba31b062
    
    commit 5e651d4084df7662b56ea980934c0428ba31b062
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Apr 15 21:08:13 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Wed Apr 16 11:23:13 2014 +0100
    
        coverity#1202948 Uninitialized pointer field
    
        Change-Id: I2764b1f9c3d50cf7ff7bd2c552a3dec93509b245

:100644 100644 42123dfbed90154f94f2f1dc8eacf21ed9bf155e 0d2db29f9ae8626eca4aa470157737cc2fffcde0 M	autogen.log
:100644 100644 0c1402c4f181927b2de7b580b596a19c454ff44b 76dfad2a19c6025ab1ff32510e73930f97ae063f M	ccache.log
:100644 100644 3c2e4c5380217c309eb8ca87b2e009760a2e4e9c c60fabab11f976674ac5611f37cba9ef49405589 M	commitmsg
:100644 100644 3b4121c32f82a582e7375c90656c26d59b1d9e61 645384f6ca01eb832351e51b21a3e68e798177f0 M	make.log
:040000 040000 e411e8188872ccf6a50816da7de0ce184071ca16 c66ac4ae3cd31ba3fa723f1ef8376310723747ec M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# good: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect good df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect bad 741197a13a361480f59eeb3bd1401f984f49f1c0
# skip: [60da347518798811f7adbfbf1eb07d59cd9f08bf] source-hash-28fc951233a58fb4d8515ed4380140aaee0afd32
git bisect skip 60da347518798811f7adbfbf1eb07d59cd9f08bf
# bad: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
git bisect bad 0acca754077bf74469c3e1a3c7eabbc3da795266
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# first bad commit: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
Comment 6 Michel Rudelle 2014-12-10 13:28:43 UTC
Hi, I change the version because I found the issue with 4.2.6.3 on Vista-32b (but not with 4.1.6.2).
Also present on 4.3.2.2.
I notice that the issue never appears if Text alignment is "center".
Best regards
Comment 7 Jim Avera 2014-12-19 04:30:08 UTC
Text is still truncated in 4.4.0.0.beta2 (Linux 64bit)
Comment 8 Matthew Francis 2014-12-30 15:41:42 UTC
Couldn't source bisect this because builds in the bibisect range are mysteriously non-functional

However, from reading the commit messages, the below looks like an extremely likely suspect:

commit 087a79db1272858f107656c5ca3c6efb45680986
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Tue Apr 15 20:47:37 2014 -0400

    fdo#75665: Truncate string when clipped on screen.
    
    This improves performance of text layouting by HarfBuzz for very long strings.
    HarfBuzz's layout algorithm appears to be more expensive than ICU's.
    
    Change-Id: Ic9738b7b8f0f1a29c51c83b147763118939b90ef
Comment 9 Matthew Francis 2015-01-01 11:06:28 UTC

*** This bug has been marked as a duplicate of bug 82377 ***
Comment 10 Commit Notification 2015-03-05 08:27:13 UTC
Henry Castro committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4acffa65b58c8bd359215345dca2c61e2c5ceba5

Resolves tdf#84012 FORMATTING: Partially missing text in shrink-to-fit cells

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-03-05 12:01:24 UTC
Henry Castro committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce8aba4da2a287c2b51d1d34a290284b2f754dc2&h=libreoffice-4-4

Resolves tdf#84012 FORMATTING: Partially missing text in shrink-to-fit cells

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Alex Thurgood 2015-06-15 09:16:03 UTC
*** Bug 92066 has been marked as a duplicate of this bug. ***
Comment 13 Robinson Tryon (qubit) 2015-12-17 08:35:49 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]