Bug Hunting Session
Bug 84099 - Calc can't handle very high rows
Summary: Calc can't handle very high rows
Status: RESOLVED DUPLICATE of bug 34689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-UX Calc-Cells
  Show dependency treegraph
 
Reported: 2014-09-19 15:23 UTC by kolAflash
Modified: 2018-08-28 22:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kolAflash 2014-09-19 15:23:27 UTC
If a row becomes very high, different problems appear.


To Test, create a small column (5 cm) in Calc and copy this whole text to into one field.

https://en.wikisource.org/wiki/Lorem_ipsum

After that Calc becomes really slow.

You also can't look at the lower (sometimes also upper) end of the row by scrolling.

If you print this, the lower end of the field won't be printed at all. Instead it should be put on the next page.
Comment 1 kolAflash 2014-09-19 16:16:56 UTC
Correction
----------

Use this text

https://la.wikisource.org/wiki/Lorem_ipsum


And you have to set:

right click field
=> Format Cells...
=> Alignment
=> Wrap text automatically
Comment 2 A (Andy) 2014-09-20 10:34:33 UTC
reproducible with LO 4.3.1.2 (Win 8.1)

Due to the fact that the text is very long you can't verify this on a normal screen size by zooming out.  You will need to print it for instance as a pdf and then you can recognize that not all the text is shown.  This is also a similar problem with Excel, but it would be great if you would not have with LO the same problem as with Excel.  I experience this quite often when I insert a longer text.
Comment 3 tommy27 2016-04-16 07:28:23 UTC Comment hidden (obsolete)
Comment 4 kolAflash 2016-04-18 11:57:33 UTC
Problem is still there in LibreOffice 5.1.2.2

Can't view lower parts of the row when scrolling.

Printing doesn't print the whole text.

LibreOffice also gets very slow for a moment if you click the cell with the long text.
Comment 5 QA Administrators 2017-05-22 13:26:19 UTC Comment hidden (obsolete)
Comment 6 kolAflash 2017-05-27 13:57:25 UTC
Partly fixed in 5.3.3.2.

LibreOffice doesn't become slow anymore.

But it's still impossible to view the lower end of the cell by scrolling.
Comment 7 Thomas Lendo 2017-05-28 10:29:00 UTC
I also confirm that handling rows which are higher than the canvas view is immature. Text that is longer can't be handled by the user.

Adding it to the Calc UX tracking bug.

@kolAflash: due to the 1 bug report for 1 issue rule, please add another bug for the printing bug and link to this bug in the See Also field.
Comment 8 kolAflash 2017-06-24 12:32:16 UTC
(In reply to Thomas Lendo from comment #7)
> I also confirm that handling rows which are higher than the canvas view is
> immature. Text that is longer can't be handled by the user.

Just reproduced with 5.4.0.0-beta2.


> [...]
> @kolAflash: due to the 1 bug report for 1 issue rule, please add another bug
> for the printing bug and link to this bug in the See Also field.

Here it is: https://bugs.documentfoundation.org/show_bug.cgi?id=108730

I also added an example file to that bug report, which can be used for this bug report too.
Comment 9 Buovjaga 2017-06-25 05:27:42 UTC
kolAflash: it is suspected we have a duplicate as bug 108560.
Could you test with version 4.2, to see, if the problem is not yet in it? https://downloadarchive.documentfoundation.org/libreoffice/old/
https://wiki.documentfoundation.org/Installing_in_parallel
Comment 10 kolAflash 2017-06-27 18:17:33 UTC
(In reply to Buovjaga from comment #9)
> kolAflash: it is suspected we have a duplicate as bug 108560.
> Could you test with version 4.2, to see, if the problem is not yet in it?
> https://downloadarchive.documentfoundation.org/libreoffice/old/
> https://wiki.documentfoundation.org/Installing_in_parallel

Tested with LibreOffice-4.2.0.0-beta2 on openSUSE 42.2.

https://downloadarchive.documentfoundation.org/libreoffice/old/4.2.0.0.beta2/rpm/x86_64/LibreOfficeDev_4.2.0.0.beta2_Linux_x86-64_rpm.tar.gz

Bug is already there!
Comment 11 QA Administrators 2018-08-28 02:42:05 UTC Comment hidden (obsolete)
Comment 12 Nate Graham 2018-08-28 22:03:49 UTC

*** This bug has been marked as a duplicate of bug 34689 ***