Download it now!
Bug 84123 - FILEOPEN: Regression - Impress objects not displayed in slideshow view
Summary: FILEOPEN: Regression - Impress objects not displayed in slideshow view
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks:
 
Reported: 2014-09-20 19:01 UTC by Luke
Modified: 2015-12-17 05:56 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparision of normal vs slideshow views (330.25 KB, image/png)
2014-09-20 19:01 UTC, Luke
Details
stripped-down slide with only a rectangle (1.17 MB, application/vnd.oasis.opendocument.presentation)
2014-09-20 20:55 UTC, Luke
Details
Normal View - LO v4.3.2.2 (216.22 KB, image/png)
2014-12-11 03:32 UTC, Robinson Tryon (qubit)
Details
Normal View - v4.4.0.0.alpha0 (master) build-id: dea4a3b9d7 (25.13 KB, image/png)
2014-12-11 03:45 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-09-20 19:01:22 UTC
Created attachment 106579 [details]
Comparision of normal vs slideshow views

Jan's fix for Bug 819614 uncovered two move hidden bugs. Bug 75209 and this one, where the grey gradient bar is not rendered in the slideshow view mode. It's an insidious bug, as the objects will show in the normal view.

Steps to reproduce:
1. Open attachment 106028 [details] document in Impress
2. Note the gray box behind the pictures
3. Start the slideshow. 

Expect results:
Gray object sows in both views.

Actual results:
Version: 4.3.1.2 - Grey Gradient Rectangle: shown
Version: 4.4 - Grey Gradient: missing
Comment 1 Luke 2014-09-20 20:55:18 UTC
Created attachment 106587 [details]
stripped-down slide with only a rectangle
Comment 2 Jacques Guilleron 2014-09-20 22:58:56 UTC
Hi Luke,

I confirm gray gradient rectangle is visible in:
LO 4.3.2.1 Build ID: f9b3ad49d92181b0a1fe7e76f785a2c2cd0847d3
an not visible in:
LO 4.4.0.0.alpha0+ Build ID: 5aeb852efcabdd51545d5d41c92f4bf3cef1d663
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-08_07:01:57 
under Windows 7 Home Premium.

Add a border to the rectangle make it again visible.

regards,

Jacques
Comment 3 Robinson Tryon (qubit) 2014-12-10 14:29:07 UTC
(In reply to Luke from comment #1)
> Created attachment 106587 [details]
> stripped-down slide with only a rectangle

I believe I'm following the repro steps as provided. I'm just confirming that there's a gradient rectangle in the given slide, as it appears in the comparison image, right?

Testing with Ubuntu 14.04 x86_64:

LO Version: 4.4.0.0.alpha0+ - BAD - Has two separate skinny vertical gradient rects.
  Build ID: fc49c052dbdbb5ab3b0a02a13143705f769b9662
  TinderBox: Linux-rpm_deb-x86_64@46-TDF, 
  Branch:master, 
  Time: 2014-06-17_23:43:2

LO 4.4.0.0.beta2 - GOOD - Gradient rectangle is visible
LO Version: 4.5.0.0.alpha0+ - GOOD
  (Build ID: df62a2c81bef2bcd96a5f14802e41815f0bdc2da
   TinderBox: Linux-rpm_deb-x86_64@46-TDF, 
   Branch:master,
   Time: 2014-12-09_22:40:23
   Locale: en_US)

Luke: Is this one fixed?
Comment 4 Luke 2014-12-11 01:00:09 UTC
@qubit 
Yes, there is a gradient rectangle that goes from White to dark gray in the lower left-hand side. You can select it and move it around in normal mode. Note the white area where the gradient starts in normal view. When you go to the slideshow mode, the rectangle is not rendered like attachment 106579 [details] .

I tested with a build from today, Build ID: 629a705c127661111c54e14035b55850e36c2167, and the slideshow mode is still not rendering the rectangle under Win 7. Are you testing in slideshow mode? If so, maybe this is a Windows only bug now.
Comment 5 Robinson Tryon (qubit) 2014-12-11 03:17:19 UTC
(In reply to Luke from comment #4)
> When you go to
> the slideshow mode, the rectangle is not rendered like attachment 106579 [details]

Ah, okay -- all clear to me now :-)

CONFIRMED with same LO Version I tested above: 4.5.0.0.alpha0+ (Build ID: df62a2)
Comment 6 Robinson Tryon (qubit) 2014-12-11 03:32:38 UTC
Created attachment 110704 [details]
Normal View - LO v4.3.2.2
Comment 7 Robinson Tryon (qubit) 2014-12-11 03:45:04 UTC
Created attachment 110706 [details]
Normal View - v4.4.0.0.alpha0 (master) build-id: dea4a3b9d7
Comment 8 Robinson Tryon (qubit) 2014-12-11 03:58:15 UTC
(In reply to Luke from comment #0)
> Steps to reproduce:
> 1. Open attachment 106028 [details] document in Impress
> 2. Note the gray box behind the pictures
> 3. Start the slideshow. 

(Testing on Ubuntu 14.04 x86-64 again)

The gradient looks correct in both normal and slideshow views in LO 4.3.2.2 (attachment 110704 [details]). It looks correct in slideshow view in LO Version: 4.4.0.0.alpha0+ (Build ID: dea4a3b9d7182700abeb4dc756a24a9e8dea8474), but looks like two separate vertical rectangles in normal view (attachment 110706 [details])

Bibisect4.4 results:

ff15922762c1dd77fd03b07438ce3311d646fea3 is the first bad commit
commit ff15922762c1dd77fd03b07438ce3311d646fea3
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sat Oct 18 03:07:55 2014 +0000

    source-hash-6c4ce5f351f7acf2086f5bf2b67ef15ffcda0c51
    
    commit 6c4ce5f351f7acf2086f5bf2b67ef15ffcda0c51
    Author:     weigao <weigao@multicorewareinc.com>
    AuthorDate: Mon Jun 16 23:08:00 2014 -0700
    Commit:     Markus Mohrhard <markus.mohrhard@googlemail.com>
    CommitDate: Tue Jun 17 07:43:58 2014 +0200
    
        modify the default view angle
    
        Change-Id: Ic7c901108a290a9d9c5a8564b6eefa7ed32a9e1f

# bad: [4a3091e95fa263d3e2dd81e56e83996f0bb12287] source-hash-2b5b04e1e62914bf0902dfd7943cdc44499c47a6
# good: [812c4a492375ac47b3557fbb32f5637fc89d60d9] source-hash-dea4a3b9d7182700abeb4dc756a24a9e8dea8474
git bisect start 'latest' 'oldest'
# good: [5d0dfb8e62ae61a240f8313c594d4560e7c8e048] source-hash-0c6cd530de13f80795881f61064f1bf1dcc4ea81
git bisect good 5d0dfb8e62ae61a240f8313c594d4560e7c8e048
# bad: [7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5] source-hash-f93ce4f7eb90093d0ea3115d0a1c614612676dbd
git bisect bad 7dfacd0b8bd828331d74c0f79de6e8924bc4e6a5
# bad: [1a63057f6378db7c6b8af1171b7b140f7583f246] source-hash-59f84b4a2c082382767f12e0c7a06a3f0b52e721
git bisect bad 1a63057f6378db7c6b8af1171b7b140f7583f246
# bad: [3787e4f82e47eaf4fa454afdca671272e50f875b] source-hash-0e09134a4a4cbb0639fc586c560c6fb2765487be
git bisect bad 3787e4f82e47eaf4fa454afdca671272e50f875b
# good: [5b2c61f6b34f03146c2d03da03a7b7f546ce56b8] source-hash-abf842e4b125b9f863ea4c2af17ad6ac7d82b15e
git bisect good 5b2c61f6b34f03146c2d03da03a7b7f546ce56b8
# good: [c42f09491446a9544fdb0dd0ebb600cb4f99258b] source-hash-5deaac4ff9956c80ad16dc14c9085d91b5eb0aba
git bisect good c42f09491446a9544fdb0dd0ebb600cb4f99258b
# good: [02774bdf6e058579ff2938e775e8fc1abdc34ea3] source-hash-77c3c53cff8c2b8af535c2cb0236314434ba8c45
git bisect good 02774bdf6e058579ff2938e775e8fc1abdc34ea3
# bad: [cd3bfe2dea561ebf4d88d876f0aaee89e9a62555] source-hash-5b2df0c09c63cc06c9158dba1b9e161fc799ba16
git bisect bad cd3bfe2dea561ebf4d88d876f0aaee89e9a62555
# bad: [ff15922762c1dd77fd03b07438ce3311d646fea3] source-hash-6c4ce5f351f7acf2086f5bf2b67ef15ffcda0c51
git bisect bad ff15922762c1dd77fd03b07438ce3311d646fea3
# first bad commit: [ff15922762c1dd77fd03b07438ce3311d646fea3] source-hash-6c4ce5f351f7acf2086f5bf2b67ef15ffcda0c51
Comment 9 Luke 2014-12-14 19:05:38 UTC
Miklos,
I have manually bisected this regression down to 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d602133d627c1837eb64895855c2a7ed0144de6

svx: fix VML export of rectangles imported from drawingML

The commit before that, 71aa91ab7e16be70ed9abd0959f8f18d35439acc was GOOD. Could you please look into why gradient boxes are not displaying in slideshow mode now? Note the regression that caused the smooth gradient to be stripped in norm view has been fixed in recent builds. 

Thanks for everything!
Comment 10 Luke 2015-01-08 19:55:07 UTC
Someone resolved this issue recently. Great job team!

Verified fixed in:
Version: 4.5.0.0.alpha0+
Build ID: 9da59f23a0b100454bdc4c663db82a61f1d7ec30
Comment 11 Luke 2015-01-12 19:31:00 UTC
Strange interplay of bugs/fixes here. I bisected the fix down to:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2883ca86f747eb62d1fe9e9b8d115c689e3abd7

So the source of the bug was actually:
commit	bb5c7d6a79309236d4f19bb2498f2e850f735a2f
fdo#38844 Reduce XOR clipping for gradients

Miklos' patch probably just triggered it, but was not been the root cause.
Comment 12 Robinson Tryon (qubit) 2015-12-17 05:56:22 UTC
Migrating Whiteboard tags to Keywords: (bibisected, filter:pptx)
[NinjaEdit]