Bug 84194 - Other: Double clicking embedded PDF in Writer opens file in Writer, not in OS' PDF reader
Summary: Other: Double clicking embedded PDF in Writer opens file in Writer, not in OS...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2014-09-22 17:18 UTC by Miguel
Modified: 2020-10-10 19:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx document with an embedded PDF (183.46 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-09-22 17:18 UTC, Miguel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel 2014-09-22 17:18:47 UTC
Created attachment 106685 [details]
docx document with an embedded PDF

A regression seems to exist when dealing with .docx files with embedded PDF objects.

Steps to reproduce:
1. Open the attached file
2. Double click the PDF

Current behavior:
In 4.3.1.2 - A file with an odd name (xxxx.tmp) is opened in Writer


Expected behavior:
The Operating system's PDF reader should open the file.

The issue was confirmed on:
- 4.3.1 on win8.1 x64
- 4.3.1.2 on Ubuntu 14.04 x64 

The expected behaviour is observed in:
- 4.1.x on windows
- 3.x on Ubuntu 12.04 x64 
              
Operating System: Ubuntu
Version: 4.3.1.2 release
Last worked in: 4.1.3.2 release
Comment 1 Dennis Roczek 2014-09-22 19:10:28 UTC
/me was user confirming under win8.1 64bit. I don't have any older versions installed to test...
Comment 2 Miguel 2014-09-26 10:34:25 UTC
Just tried in 4.3.2.2 and a different (but still wrong) behaviour is experienced - clicking on the object does not seem to open any application at all, so it is impossible to open the embedded object.
Comment 3 leeksoup 2015-07-30 00:58:40 UTC
Tried in Version: 4.4.4.3
Build ID: 4.4.4.3-6.fc22 (Fedora)

The problem is still happening that it does not open the embedded document at all.

However, it does create a temporary file under a directory 
/tmp/lu*

By renaming the .tmp file there to .pdf, I can sometimes open it.

In some cases, the embedded document is damaged. I will try to add a test case for this.
Comment 4 Robinson Tryon (qubit) 2015-12-09 18:29:08 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-11-08 07:35:15 UTC Comment hidden (obsolete)
Comment 6 Dennis Roczek 2017-11-11 13:30:53 UTC
Either I'm dump (Saturday "morning") or the PDF in the attached document doesn't opened any more.

@x1sco/buovjaga: can you try it, please?
Comment 7 Buovjaga 2017-11-11 15:14:14 UTC
(In reply to Dennis Roczek from comment #6)
> Either I'm dump (Saturday "morning") or the PDF in the attached document
> doesn't opened any more.
> 
> @x1sco/buovjaga: can you try it, please?

Actually, I cannot reproduce the bug: the PDF opens in Okular on Linux and Acrobat on Windows!

Version: 6.0.0.0.alpha1+ (x64)
Build ID: 4058d85963e371be657f531d8f30e31381a9ccab
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-11-05_22:51:05
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: 1aba1955f161cc112dab80b6b3e78ec7761616fc
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 10th 2017
Comment 8 QA Administrators 2018-11-12 03:40:51 UTC Comment hidden (obsolete)
Comment 9 Thomas Lendo 2020-10-10 19:18:24 UTC
Cannot reproduce this bug with
Version: 7.1.0.0.alpha0+
Build ID: 7aaa9ef2e5edaf468f116449776433e98fb1a2f3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-10-09_22:58:32
Calc: threaded


As this wasn't reproduced since 6.0, I'll close this bug as WORKSFORME.
If you still see this problem, bug opener, please reopen as NEW and tell us all information about LibreOffice and OS.