Bug Hunting Session
Bug 84196 - Other: Document unsaved status appears oblivious to undo
Summary: Other: Document unsaved status appears oblivious to undo
Status: RESOLVED DUPLICATE of bug 69972
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-22 19:15 UTC by pb
Modified: 2014-09-23 03:10 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pb 2014-09-22 19:15:44 UTC
Problem description: 

Steps to reproduce:
1. enter data into doc
2. observe status has changed to 'needs saving'
3. do 'undo' with ctrl-z.
4. observe status stays at 'needs saving'
5. more undos go back even beyond last saved state

Current behavior:
as above

Expected behavior:
after undoing to last saved state, 'needs saving' status should change to 'does not need saving'

I note that there are issues relative to document content vs. view state.  IMHO, a 'needs saving' indicator should first and foremost cater to the naive user, who will assume it relates to document content, not which sheet he viewed last, e.g.  If you really want to reflect view state, make a separate indicator.
              
Operating System: Windows 7
Version: 4.2.6.2 release
Comment 1 ign_christian 2014-09-23 03:10:59 UTC
Hi.. It's an old issue. Lets join the previously reported bug.

*** This bug has been marked as a duplicate of bug 69972 ***