Bug 84247 - Password protected document content is visible in LibreOffice Start Center
Summary: Password protected document content is visible in LibreOffice Start Center
Status: RESOLVED DUPLICATE of bug 80755
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-23 14:35 UTC by Stamatis
Modified: 2014-09-23 19:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Start Center displays content from Password Protected documents (542.39 KB, image/png)
2014-09-23 14:35 UTC, Stamatis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stamatis 2014-09-23 14:35:47 UTC
Created attachment 106743 [details]
LibreOffice Start Center displays content from Password Protected documents

In LibreOffice Start Center, if a document with password protection has previously been processed, part of its content will be displayed in a "preview manner" as if it was unprotected.

I believe this behaviour is erratic and should a document is password protected, no content should be visible in any case.

I have attached a PNG showing this behavour.
Comment 1 Stamatis 2014-09-23 14:52:55 UTC
Comment on attachment 106743 [details]
LibreOffice Start Center displays content from Password Protected documents

http://iconix.info/images/PassProtectLibreOfficeIssue.png
Comment 2 Stamatis 2014-09-23 14:55:45 UTC
Comment on attachment 106743 [details]
LibreOffice Start Center displays content from Password Protected documents

http://iconix.info/images/PassProtectLibreOfficeIssue.png
Comment 3 Jean-Baptiste Faure 2014-09-23 15:07:45 UTC
Problem already tracked in bug 80755.
Problem fixed in version 4.3.2. Please try the RC2 : https://www.libreoffice.org/download/pre-releases/

Best regards. JBF

*** This bug has been marked as a duplicate of bug 80755 ***
Comment 4 Stamatis 2014-09-23 15:32:07 UTC
Thanks for the attention / resolution. I must have missed the existing bug report (bug 80755), I apologise.

Regards, Stamatis
Comment 5 Adolfo Jayme 2014-09-23 19:55:30 UTC
Don’t worry, this bug was very popular and Bugzilla doesn’t display fixed bugs by default in searches.

The bug is fixed in that LibreOffice won’t create or update thumbnails for password-protected files, be sure to manually remove any existing thumbnail in your sensitive documents (open the document in an archive manager, as if it were a .zip, and delete the image).