Bug 84283 - PDF: Export to PDF with footnotes in tables crash
Summary: PDF: Export to PDF with footnotes in tables crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: high major
Assignee: Julien Nabet
URL:
Whiteboard: BSA target:4.4.0 target:4.3.3
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2014-09-24 14:59 UTC by Bob Miller
Modified: 2014-09-26 08:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file that causes crash (35.50 KB, application/msword)
2014-09-24 14:59 UTC, Bob Miller
Details
console bt (11.00 KB, text/plain)
2014-09-24 19:03 UTC, Julien Nabet
Details
pdf generated with the patch (69.54 KB, application/pdf)
2014-09-24 19:35 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Miller 2014-09-24 14:59:30 UTC
Created attachment 106793 [details]
Example file that causes crash

Problem description: 
If a doc or docx file with a footnote in just the right place is exported to pdf it causes LibreOffice to crash.

Just the right place seems to be in a table cell near a page boundary where the existence of the footnote causes the cell to move to another page.
  
Steps to reproduce:
1. Open attached document
2. File -> Export to pdf
3. Export

Current behavior:
LibreOffice crashes

Expected behavior:
I get a pdf and LibreOffice does not crash.
Operating System: All
Version: 4.2.4.2 release
Comment 1 Julien Nabet 2014-09-24 19:03:28 UTC
Created attachment 106809 [details]
console bt

On pc Debian x86-64 with master sources updated yesterday, I could reproduce the problem.
Comment 2 Julien Nabet 2014-09-24 19:35:05 UTC
I proposed a patch here:
https://gerrit.libreoffice.org/#/c/11634/

With this no crash, export includes footnotes. Now I don't know if it's the good way to fix it so prefered asking review.
Comment 3 Julien Nabet 2014-09-24 19:35:26 UTC
Created attachment 106812 [details]
pdf generated with the patch
Comment 4 Commit Notification 2014-09-25 12:26:05 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86af599c81dc695400b0cc999f559bcf9070e8b9

Resolves fdo#84283: Export to PDF with footnotes in tables crash



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-09-26 08:15:42 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c67942a3158d4ace3753985dab5b9a934b8185a7&h=libreoffice-4-3

Resolves fdo#84283: Export to PDF with footnotes in tables crash


It will be available in LibreOffice 4.3.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2014-09-26 08:57:26 UTC
So fixed now (from next LO version 4.3.3)