Bug 84284 - EDITING - database objects in embedded hsqldb file refuse to load
Summary: EDITING - database objects in embedded hsqldb file refuse to load
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest blocker
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.4.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-09-24 15:00 UTC by Alex Thurgood
Modified: 2014-09-26 15:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test database from documentation project (402.83 KB, application/vnd.oasis.opendocument.base)
2014-09-24 15:00 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-09-24 15:00:58 UTC
Created attachment 106794 [details]
test database from documentation project

Try opening a form from the attached ODB file.

Enable macros.

Click on Tables :
Error message :
The connection to the data source "Beispiel_Bilder_einbinden" could not be established.
SQL Status: S1000
Error code: -40

General error: java.lang.UnsatisfiedLinkError: com.sun.star.sdbcx.comp.hsqldb.StorageFileAccess.isStreamElement(Ljava/lang/String;Ljava/lang/String;)Z


No tables are displayed in list window

Try to load a form.
Double-click on any form.

The same error message is displayed.

Regression over production release 4.3.1.2
Comment 1 Alex Thurgood 2014-09-24 15:03:06 UTC
This is with a recognised Java 1.8.0_05 on OSX
Comment 2 Alex Thurgood 2014-09-24 15:11:11 UTC
Just in case it was a macro problem, I also tested after disabling macros, same result - no load of any db object and same error message.
Comment 3 Alex Thurgood 2014-09-24 17:20:51 UTC
The same problem is present on another machine with Java 1.7.0_67
Comment 4 Alex Thurgood 2014-09-24 17:27:14 UTC
CDonfirming also daily :


Version: 4.4.0.0.alpha0+
Build ID: 5045400eb3ae5622d18e9a9b1b928d4ecc78bbf2
TinderBox: MacOSX-10.9-x86_64@53, Branch:master, Time: 2014-09-24_11:42:05
Comment 5 Julien Nabet 2014-09-24 17:31:42 UTC
For the record, on pc Debian x86-64 with master sources updated yesterday or with 4.3.1 LO Debian package, I don't reproduce this.
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.2) (7u65-2.5.2-4)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
Comment 6 Alex Thurgood 2014-09-24 18:05:13 UTC
Thanks Julien. Mac specific Java environment bug ?
Comment 7 Alex Thurgood 2014-09-24 18:06:11 UTC
@Stephan : any idea ?
Comment 8 Julien Nabet 2014-09-24 18:10:51 UTC
Quite weird, on MacOs 10.9.4 with LO 4.3.1 (French UI), I don't reproduce this.
I can see the tables and open the first forms. (LO warns about macros disabled because I let the by default setting)
java version "1.8.0_11"
Java(TM) SE Runtime Environment (build 1.8.0_11-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.11-b03, mixed mode)

Did you try to launch LO from console to see if there could be some console logs?
Comment 9 Julien Nabet 2014-09-24 18:12:23 UTC
I know you could reproduce this on 2 machines but: 
- Did you try with a brand new LO profile?
- Do you reproduce this with a brand new file?
Comment 10 Julien Nabet 2014-09-24 18:16:51 UTC
Alex: your daily build is x86-64, your LO 4.3.1 package too?
Also, do you confirm you use Java 64 bits and not 32 bits? (you didn't install other Java versions these days?)
Comment 11 Stephan Bergmann 2014-09-25 08:00:29 UTC
com.sun.star.sdbcx.comp.hsqldb.StorageFileAccess.isStreamElement(java.lang.String,java.lang.String) is a native method; if this issue is Mac-only, I guess it is related to the recent changes to the LibreOffice.app tree layout, and the .jar no longer finds the .jnilib.
Comment 12 Commit Notification 2014-09-25 18:40:46 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13da98f99f0d696a5e2b489600a4eeb0ad832e6c

fdo#84284: Adapt jar Class-Path to new Mac OS X LibreOffice.app layout



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Julien Nabet 2014-09-25 20:36:25 UTC
Alex: just by curiosity, what's your precise MacOs version on your 2 machines?
Indeed, I don't understand why I couldn't reproduce this.
Of course it's just a detail, the important thing is it's solved now thanks to Stephan :-)
Comment 14 Alex Thurgood 2014-09-25 20:46:03 UTC
Julien, I'm on 10.9.5 on both machines.
Comment 15 Alex Thurgood 2014-09-25 20:48:38 UTC
Note that I said that LO 4312 worked fine, it was just 440 alpha that showed the problem. Will start new build tomorrow to test whether bug fix ok
Comment 16 Julien Nabet 2014-09-25 21:08:16 UTC
Alex: oups! I had read a little too faster!
Ok then :-)
Comment 17 Stephan Bergmann 2014-09-26 06:49:18 UTC
(In reply to comment #15)
> Will start new build tomorrow to test whether bug fix ok

(Make sure to do either a clean build or at least "make connectivity.clean" first.  IIUC, the change to the Jar_sdbc_hsqldb.mk wouldn't necessarily be picked up by an incremental make.)
Comment 18 Alex Thurgood 2014-09-26 15:46:13 UTC
verified with master own build today, thanks