Download it now!
Bug 84432 - FILESAVE: cursor jump in dialog box (kubuntu)
Summary: FILESAVE: cursor jump in dialog box (kubuntu)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-28 19:56 UTC by celtic
Modified: 2015-11-05 17:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots and comments (121.22 KB, application/pdf)
2015-02-04 17:37 UTC, celtic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description celtic 2014-09-28 19:56:26 UTC
Problem description: 

have option to automatically place the cursor in the middle of the dialog box. In +/- 75% of the of time cursor jump again in the middle of dialog box

Steps to reproduce:
1. set up : do not use dialog box of LO ; place cursor in the middle of dialog box
2. change something in the document
3. quit the document, the cursor jump in the middle of the dialog box
4, click ok to save

Current behavior:
+/- 75% the cursor of times the cursor jump again in the middle of the box, click ok again and it's ok

I never understood why sometimes (75%) the cursor jump again in the middle of the dialog box and 25% it's ok on the 1st click

on a windows 7 machine I never saw that,
it's only on my kubuntu machine



Expected behavior:
on the 1st click on the ok, save the file and close the dialog box.
              
Operating System: Ubuntu
Version: 4.2.6.2 release
Comment 1 celtic 2014-10-15 16:38:44 UTC
the problem occurs with several dialog boxes, may be all, didn't all test.
Comment 2 Daniel Pastushchak 2014-12-12 18:05:13 UTC
Could not reproduce.  I'm using Ubuntu 14.10 with KDE(4.14.1) and LibreOfficeDev Version: 4.5.0.0.alpha0+
Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-10_22:53:28
Comment 3 celtic 2014-12-13 07:37:25 UTC
the problem still exists and affects all dialog boxes in L.O..
following the normal updates, i'm now with kubuntu 14,04 LTS, kde 4.13.3, libre office 4.2.7.2.
i'm currently not able to test that with new versions. if i found a machine with sufficient ram, i will try in a virtual machine.
Comment 4 celtic 2014-12-14 10:22:28 UTC
did a short test with xubuntu 14.04 LTS, L.O. 4.2.7 :

the problem don't exist.
Comment 5 celtic 2015-01-18 17:19:33 UTC
with Kubuntu 14.10, KDE 4.14.1, L.O. 4.3.3.2
problem still here
Comment 6 Buovjaga 2015-01-21 06:52:02 UTC
Did this:
1. wrote stuff in Writer
2. opened Find & replace dialog box
3. wrote more stuff to the document
4. closed the document & saved

I did not experience anything out of the ordinary.

celtic: I feel your reproduction steps are unclear. Could you elaborate and attach a screenshot of the problem?

Kubuntu 14.10 64-bit, LibO Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 7 celtic 2015-02-04 17:37:24 UTC
Created attachment 113130 [details]
screenshots and comments

i'm going to attach a file with sreenshots but it is not easy to show the problem the the cursor (or mouse)

kubuntu 14.10, kde 4.14, LO 4.3.3.2
Comment 8 Buovjaga 2015-02-05 11:03:31 UTC
Thanks for the information.

For some reason, the automatic mouse position does not work at all for me, but maybe it's because I'm using a VM for Kubuntu.
Comment 9 tommy27 2015-10-04 13:39:33 UTC
@Celtic
please retest with LibO 4.4.5.2 and tell if issue is still there.

status NEEDINFO
Comment 10 celtic 2015-10-04 19:31:23 UTC
because i'm not expert to change version outside the normal update cycle of the distro, please give me time to test with a more recent version.

Just for information the problem still exists : kubuntu 15.04, KDE 5.3.2, LibreOffice 4.4.2.

With KDE 5, i see something new. The problem is linked with a non automatic selection of the pop up. When the pop up is not automatically selected, doing a clic on the pop up, then the cursor jump in the middle of the pop up.

I will soon follow the kubuntu update to 15.10 with LibreOffice 5.x, if i have right information. Hope it's ok for you instead LO 4.4.5.
Comment 11 Buovjaga 2015-10-04 19:37:04 UTC
(In reply to celtic from comment #10)
> because i'm not expert to change version outside the normal update cycle of
> the distro, please give me time to test with a more recent version.
> 
> Just for information the problem still exists : kubuntu 15.04, KDE 5.3.2,
> LibreOffice 4.4.2.
> 
> With KDE 5, i see something new. The problem is linked with a non automatic
> selection of the pop up. When the pop up is not automatically selected,
> doing a clic on the pop up, then the cursor jump in the middle of the pop up.
> 
> I will soon follow the kubuntu update to 15.10 with LibreOffice 5.x, if i
> have right information. Hope it's ok for you instead LO 4.4.5.

Sure, 5.x would be more interesting. Some KDE Plasma 5 -related bugs were fixed in LibreOffice 5.
Comment 12 celtic 2015-11-05 17:31:49 UTC
some news :
the pc run now with Kubuntu 15.10, KDE 5.4.2, LibreOffice 5.0.2.
 since this update, I never saw the bug again. ' seems to be fixed.
Comment 13 Buovjaga 2015-11-05 17:39:10 UTC
Thanks. Let's set to WFM. It can always be changed back to unconfirmed, if the bug appears again.