Download it now!
Bug 84463 - EDITING: Wish: make clear which objects are moved in alignment operations
Summary: EDITING: Wish: make clear which objects are moved in alignment operations
Status: RESOLVED DUPLICATE of bug 72118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-29 13:26 UTC by sergio.callegari
Modified: 2014-12-14 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2014-09-29 13:26:02 UTC
Problem description:

This involves both draw and impress.  Suppose that you have two graphical objects A and B, that you select both and that you ask Libreoffice to align them. Which object is moved to align it with the other?

In many cases you would like to be able to assure that one of the objects stays fixed as a reference for the alignment. For instance, B may have been carefully placed on grid, while A is not on grid. In this case, aligning, you would like A to move, not B.

Current behavior:

The current behavior, to the best of my knowledge, is that the object that is moved depends on the internal representation that LibO has of the drawing, which is often inscrutable by the user. The user ends up trying, and should the result not be the correct one correct it later.

In some cases, this may result cumbersome.

Desired behavior:

The user has some way to influence which object is used as the reference fixed one for the alignment. For instance, given that the objects need to be selected for the alignment, it would be great to use the object that has been selected first as the reference.

Operating System: All
Version: 4.1.0.4 release
Comment 1 Jake See 2014-11-14 03:25:54 UTC
I second this enhancement. It will make the alignment scheme consistent with other major applications MS Office, Visual Studio etc. Either the first or the last shape/object should be used as the reference.
Comment 2 raal 2014-12-10 11:25:53 UTC
You can lock position of object -  is it sufficient?
https://help.libreoffice.org/Common/Protecting_Content_in#Protecting_Drawing_Objects_and_Form_Objects
Comment 3 sergio.callegari 2014-12-14 10:51:18 UTC
It is clear that the issue can be worked around.

For instance, if you have some objects to align, you can
1) Select the one that should not move, lock the position;
2) Select all the objects, do the alignment;
3) Select the one that should not move, unlock the position
(this is needed, otherwise you cannot move the objects as a group preserving the alignment)

or (often more more easily) you can note down the positions of the objects and manually align them by writing down the position they should take.

The point is that all this is rather impractical and having a command that decides in a totally unpredictable way what it will do is highly frustrating to new users. The show of a new user trying to align stuff on a presentation, ending up moving the wrong objects, retrying, getting again the same result, retrying, eventually ending up visually aligning things by hand is something not to lose.

If you are curious about the impact of this issue, find odp presentations on the net and just look at the amount of slides where there are objects that look approximately aligned, but in fact are not.
Comment 4 raal 2014-12-14 14:19:30 UTC
Setting as dup of bug 72118

*** This bug has been marked as a duplicate of bug 72118 ***