Download it now!
Bug 84510 - Spellcheck ignores disabled "check upper-case" and "check special regions" for Zotero references
Summary: Spellcheck ignores disabled "check upper-case" and "check special regions" fo...
Status: CLOSED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-30 13:48 UTC by sonajaqufe
Modified: 2020-07-22 14:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LO spell-checks Zotero author name field (106.30 KB, image/png)
2015-08-07 16:31 UTC, sonajaqufe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sonajaqufe 2014-09-30 13:48:08 UTC
Set-up: LibreOffice 4.3.2.2 Writer with LO interation plugin v3.5.9 and Zotero 4.0.22 plugin in Firefox
https://download.zotero.org/extension/zotero-4.0.22.xpi
https://download.zotero.org/integration/Zotero-LibreOffice-Plugin-3.5.9.xpi

Problem: References that include author names in the body text are checked for spelling, despite "check upper-case" and "check special regions" being disabled under Options > Language Settings > Writing Aids. This makes it necessary to either add names to a dictionary, or ignore them => unnecessary click-fest in both cases. Even if Zotero references aren't "special regions", the upper-case setting should kick in.
Comment 1 Susan Cragin 2015-08-07 14:22:05 UTC
I am unable to reproduce this with the latest version of Zotero and LibreOffice. Please upgrade, re-test, and then post a link that leads to a web site that produces a Zotero link where this happens.

So for example:

http://www.amazon.com/English-Composition-Grammar-Complete-Course/dp/0153117362/ref=sr_1_3?s=books&ie=UTF8&qid=1438957266&sr=1-3&keywords=english+composition

Thank you.
Comment 2 sonajaqufe 2015-08-07 16:31:14 UTC
Created attachment 117752 [details]
LO spell-checks Zotero author name field

Please see the attached screenshot. I tested both LO 4.3.5 and 5.0.0. Firefox was now 39.0.3 with Zotero 4.0.28.
Comment 3 sonajaqufe 2015-08-07 16:34:07 UTC
(In reply to Susan Cragin from comment #1)
> I am unable to reproduce this with the latest version of Zotero and
> LibreOffice. Please upgrade, re-test, and then post a link that leads to a
> web site that produces a Zotero link where this happens.

I don't understand what this might have to do with websites or other items that can be imported into Zotero. The author's name should IMHO simply not be spell-checked, esp. not if the 2 Writing Aids I mentioned are disabled.

I know it's probably a strange edge case :-)
Comment 4 Xisco Faulí 2016-09-10 15:02:22 UTC Comment hidden (obsolete)
Comment 5 sonajaqufe 2016-09-10 18:58:53 UTC
I have provided info, but the status has probably not been changed then. Currently, I no longer work on Windows and can't provide more info, sorry. So from my point of view, either it can be reproduced, or it can be closed.
Comment 6 Buovjaga 2016-09-30 19:30:29 UTC
Ok, closing.
Comment 7 john 2020-07-22 12:57:44 UTC
We provide every one of our clients with detailed monthly reports including traffic analysis, keyword rankings and even what device visitors to your site have used.

Your monthly report from your account manager, allows you to view the most popular pages people visit and the route they take while using the website. The search phrases they used to discover your website and where they are based are also information we can provide.

read more information :

https://www.inventive9.com