Bug 84621 - FILEOPEN: Read-Error. Format error discovered in the file in sub-document content.xml at 2,35766(row,col).
Summary: FILEOPEN: Read-Error. Format error discovered in the file in sub-document con...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-03 07:50 UTC by Bob Reckhow
Modified: 2015-04-14 21:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
This is the file that gave the error message above, and that needs to be repaired. (81.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-03 07:50 UTC, Bob Reckhow
Details
Corrected file (68.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-03 16:18 UTC, Jens S
Details
Version of net roster spread sheet that fails to open with format error. (451.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-03 04:21 UTC, Bill Rainey
Details
repaired document (460.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-03 21:19 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Reckhow 2014-10-03 07:50:01 UTC
Created attachment 107247 [details]
This is the file that gave the error message above, and that needs to be repaired.

I created a spreadsheet (file attached), edited, printed, and saved it, and quit LibreOffice. When I tried to open the file to make further changes, the following error panel appeared:

LibreOffice 4.2.6.3
Read-Error. Format error discovered in the file in sub-document content.xml at 2,35766(row,col).

I need to repair this file, so I can continue to edit it, or at least to be able to print more copies of it. I had invested many hours in creating it, and have no backups.

Thanks,
Bob Reckhow
Edmonton, Alberta, Canada
Bob@Reckhow.com
Comment 1 MM 2014-10-03 13:05:01 UTC
Unfortunately this sometimes seems to happen from time to time.
Also see https://bugs.freedesktop.org/show_bug.cgi?id=80499 and https://bugs.freedesktop.org/show_bug.cgi?id=83836

The last one (83836) also has some instructions on how to fix it (hopefully).
Comment 2 Jens S 2014-10-03 16:18:17 UTC
Created attachment 107275 [details]
Corrected file

I had to delete a lot of direct formatting
Comment 3 Julien Nabet 2014-10-03 20:09:23 UTC
Good job Jen S! Indeed, I can open the corrected file.

Bob: I think you should give a try to 4.3.2 but above all make backups at least of your most important files :-)

Anyway, let's put this one to WFM since we don't know how to reproduce this and Jen S fixed the corrupted file.
Comment 4 Bill Rainey 2014-12-03 04:21:18 UTC
Created attachment 110385 [details]
Version of net roster spread sheet that fails to open with format error.

This error has occurred with a rather larger (column wise - from A1 to AEV145). I have version prior that I can still open in addition to the version that failed on open with the error:

Format error discovered in the file in sub-document content.xml at 2,775796(row,col).

I will attach the version that fails to open.
Comment 5 Bill Rainey 2014-12-03 04:27:34 UTC
Sorry for leaving out useful details:
This was with the 4.2.7.2 of LibreOffice on an Ubuntu 14.04 system. I noticed the comments (in bug id 83836) about trying with 4.3.2 version.
This ODS version of the spreadsheet is my source for the spreadsheet.
I'm still looking at 83836 to see what other suggestions are there to address this.
Comment 6 Maxim Monastirsky 2014-12-03 09:42:19 UTC
I believe this is fixed in Bug 85496 for 4.2.8/4.3.5.
Comment 7 Bill Rainey 2014-12-03 13:03:28 UTC
Okay - tried with Version: 4.3.4.1
Build ID: 430m0(Build:1)

and failed.

Error Dialog:
Read-Error.
Format error discovered in the file in sub-document content.xml at 2,775796(row,col).

Will try with 4.3.5.
Comment 8 Julien Nabet 2014-12-03 13:16:13 UTC
The file might be corrupted because of a bug in a previous LO version.
If this is the case, I don't think that even the latest stable can't fix it.
It must be repaired manually by unzipping the ods file and fixing content.xml

I can try to find some time tonight after my day time job if you don't succeed in doing it.
Comment 9 Julien Nabet 2014-12-03 20:46:10 UTC
Sorry Bill, even when fixing problems in content.xml with xmllint, it fails.
Comment 10 Maxim Monastirsky 2014-12-03 21:19:32 UTC
Created attachment 110424 [details]
repaired document

@Bill: Attached a repaired version of your spreadsheet.
Comment 11 Bob Reckhow 2014-12-03 22:28:13 UTC
I am the Bob Reckhow (Bob@Reckhow.com) who raised this bug in the first place. That was a very long time ago. I have long since found ways around the problem and have forgotten about it. I don't want any more emails about it, and I cannot figure out how to change my preferences to stop those emails. Would someone who knows how to do this please do that for me? I am not even sure after looking, if I could find a way to unsubscribe from this service altogether. If it takes this long from when I encounter a problem until someone actually looks at it, I won't be submitting any bug reports in the future.
Comment 12 Bob Reckhow 2014-12-03 22:46:20 UTC
I have unchecked all of my email preferences, but what I really want to do is close out my bugs.freedesktop.org bugzilla account. I searched all through "Help" and could not find a way to do that. Would someone either please do that for me, or send me an email, directly to Bob@Reckhow.com telling me how I can do that myself? Since I have turned off email from my account, I may not see it if you just post another comment to this bug. Thanks.
Comment 13 Bill Rainey 2014-12-07 20:44:44 UTC
Comment on attachment 110424 [details]
repaired document

Thanks. Any particular approach you used to fix this. I was starting to play with xmllint and tidy to inspect the content.xml but had not yet gotten to the heart of the problem. What should have I been looking for ?

Appreciate what details you can provide and thanks again for the repaired file.