Bug Hunting Session
Bug 84630 - Linked graphics getting lost – %3FrequestedName
Summary: Linked graphics getting lost – %3FrequestedName
Status: RESOLVED DUPLICATE of bug 80849
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-03 11:28 UTC by forum
Modified: 2015-04-14 21:01 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Page 1 shows a wrongly attached graphic, page 2 a right one (43.94 KB, application/vnd.oasis.opendocument.presentation)
2014-10-03 11:28 UTC, forum
Details

Note You need to log in before you can comment on or make changes to this bug.
Description forum 2014-10-03 11:28:39 UTC
Created attachment 107258 [details]
Page 1 shows a wrongly attached graphic, page 2 a right one

I have created a presentation in which I use lots of linked graphics. After saving and reopening some (but not all) graphics are not displayed any more. The lost graphics are marked with red text like this:

[FilePath]/graphicName.jpg%3FrequestedName=graphicName

This bug has already been reported (but not solved?) in a German LibreOffice forum: http://www.libreoffice-forum.de/viewtopic.php?f=7&t=13729

I have tried to unzip the odp-file, changedh the Content.xml by erasing all %3FrequestedName=graphicName, rezipped the file and it was working ... unfortunately only for a few days since the problem persisted. The same happens if I update the links via Bearbeiten/Verknüpfungen (I don't know exactly the English translation for that menu item: maybe Edit/Hyperlinks? ...): after saving they are lost again (but not all).

Does anyone have an idea why there is a string %3FrequestedName=graphicName getting added to the end of some xlink:href entries? Why is it happen randomly? I hope this bug is getting solved soon since it's very embarrassing to open a presentation with some linked graphics lost in front of an audience.

Best regards.
Comment 1 ign_christian 2014-10-03 15:04:47 UTC
Hello.. Please see Bug 80849, perhaps a duplicate?
Comment 2 forum 2014-10-03 16:06:18 UTC
It seems to be a duplicate. I just upgradet to 4.3.2.2, updated all links, saved and reopened the file. It seems it is working now: cool :-)!

*** This bug has been marked as a duplicate of bug 80849 ***