Bug 84636 - : Sorting 180 records crashes in 4.3.1.2
Summary: : Sorting 180 records crashes in 4.3.1.2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-03 15:32 UTC by Hazel Smith
Modified: 2017-02-28 01:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample to make sort crash (156.79 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-11-03 20:13 UTC, Lutz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hazel Smith 2014-10-03 15:32:41 UTC
Even if I simplify this file by deleting other sheets in the workbook and saving it as .ods (it was .xls), it still crashes if I try to sort.

I can't easily send the file as it is a list of members and under data protection legislation.
Comment 1 ign_christian 2014-10-03 15:41:10 UTC
Hi Hazel.. 

Please do this to remove confidential data:
https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission

And please provide steps to reproduce the problem. 

Then change status back to UNCONFIRMED after all required provided here.
Comment 2 Hazel Smith 2014-10-03 16:17:31 UTC
Sanitising the file as suggested was enough to stop the bug ...
Comment 3 Julien Nabet 2014-10-04 09:26:47 UTC
Hazel: what about if you just remove the private/confidential part? Would it be possible you attach the resulting file?
If you really can't, you can try to retrieve an useful backtrace by following this link:
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace
Comment 4 raal 2014-10-04 11:55:33 UTC
Hello Hazel,
try to install LO 4.3.2, for example bug 80874 is resolved in this version.
Comment 5 Lutz 2014-11-03 20:06:54 UTC
Crashes for me as well occasionally, sometimes only on 2nd sort. The attached file, sorting selection to column L with 300 rows makes it crash
Comment 6 Lutz 2014-11-03 20:13:16 UTC
Created attachment 108858 [details]
sample to make sort crash

I noticed, sort is a lot more stable with this file when loaded from disk rather than directly from an email attachment when the file lives in /tmp rather in some folder owned by me
Comment 7 Jean-Baptiste Faure 2014-11-12 06:03:17 UTC
(In reply to Lutz from comment #6)
> Created attachment 108858 [details]
> sample to make sort crash
> 
> I noticed, sort is a lot more stable with this file when loaded from disk
> rather than directly from an email attachment when the file lives in /tmp
> rather in some folder owned by me

How do you proceed to sort your file? Which cell range? Which sort key?

Best regards. JBF
Comment 8 Lutz 2014-11-12 06:34:08 UTC
In the sample file, I tried to sort cell range a1:L300 (or so, number of rows pretty variable and sorted column L ascending. Also crashed with other columns or directions, sometimes only the second time.

I noticed, it crashed a LOT more frequently when I opened the file directly from my emil client. If I save it first and open the saved copy, it's more stable. Maybe it's related to the fact that in the former case the temporay file sits in /tmp rather than in $HOME/tmp and in /tmp I am an "other" instead of the owner. permissions on /tmp are all good, though, rwx for ugo.

Maybe to reproduce one needs to email the file as attachment and then open from an email client.
Comment 9 Julien Nabet 2015-04-05 21:33:00 UTC
Any update with last stable LO version 4.4.2? (+ brand new profile, see https://wiki.documentfoundation.org/UserProfile#Windows)

Also, if still reproducible, would it be possible to retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)

Meanwhile, let's lower importance since it's not reproducible each time + Windows only.
Comment 10 Alex Thurgood 2015-09-02 05:02:58 UTC
*** Bug 93356 has been marked as a duplicate of this bug. ***
Comment 11 Alex Thurgood 2015-09-02 05:04:36 UTC
Confirmed duplicates with other OSes, raising priority and importance.
Comment 12 QA Administrators 2016-09-20 10:28:38 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-02-28 01:34:56 UTC
I can no longer reproduce the crash in

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

Closing as RESOLVED WORKSFORME

Feel free to move it back to NEW if you can still reproduce the issue on your side.