Bug Hunting Session
Bug 84642 - UI improvement: Google Drive default settings
Summary: UI improvement: Google Drive default settings
Status: RESOLVED DUPLICATE of bug 86703
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Ahmad
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 86699
  Show dependency treegraph
 
Reported: 2014-10-03 23:11 UTC by Luke
Modified: 2019-08-11 15:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
open online button on tools and the main page of LO (43.41 KB, image/jpeg)
2015-03-18 02:07 UTC, Ahmad
Details
Here is the dialogue which should appeared when the user choose open online -- (74.90 KB, image/jpeg)
2015-03-18 02:11 UTC, Ahmad
Details
This is another idea about what must appear when user click on Open Online Buton (53.52 KB, image/jpeg)
2015-03-18 02:15 UTC, Ahmad
Details
here is the Box which will appear when the user's data accepted (77.72 KB, image/jpeg)
2015-03-18 02:17 UTC, Ahmad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-10-03 23:11:31 UTC
Currently there is a lengthy list of steps that need to be followed to enable Google Drive access. Most of this steps consist of drop downs that contain only one setting that works for Google Drive or pressing refresh buttons. 

I propose that when the user changes "server type" to "Google Drive", this will trigger LO 
1) Fill in binding URL to https://www.googleapis.com/drive/v2 (already done)
2) Refresh 
3) Set Repository to "Google Drive"
4) Set the path to / (is this a good idea?)


The list of steps can be found here:
http://ask.libreoffice.org/en/question/30926/connect-libreoffice-42-with-google-drive/
Comment 1 Yousuf Philips (jay) (retired) 2014-10-04 02:18:44 UTC
I think that once Google Drive is set, the username and password dialog should automatically open up.
Comment 2 Luke 2014-10-04 02:29:27 UTC
So after this UI improvement, the steps would be

a) User clicks on "server" button
b) Type -> CMIS
c) Server -> Google Drive
<here the new logic kicks in, filling everything in>
d) OK
<here the authentication dialog pops up with username copied from login>
Comment 3 Robinson Tryon (qubit) 2014-12-22 07:44:35 UTC
UX: One for you
Comment 4 Ahmad 2015-03-18 02:07:24 UTC
Created attachment 114160 [details]
open online button on tools and the main page of LO
Comment 5 Ahmad 2015-03-18 02:11:27 UTC
Created attachment 114161 [details]
Here is the dialogue which should appeared when the user choose open online --

there are another servers but this is initial mock-up and i need your feedback about this, I made photo from windows and the others from linux to show you every thing.
Comment 6 Ahmad 2015-03-18 02:15:08 UTC
Created attachment 114162 [details]
This is another idea about what must appear when user click on Open Online Buton
Comment 7 Ahmad 2015-03-18 02:17:08 UTC
Created attachment 114163 [details]
here is the Box which will appear when the user's data accepted

It's need some edits sure
Comment 8 Ahmad 2015-03-18 02:19:47 UTC
Hi Luke & Jay, I am interested in this idea which also at GSoC, I need your help and you feedback about this mock-ups.
Comment 9 Ahmad 2015-03-18 02:21:36 UTC
I made one of these mock-ups on windows and the other on Linux to show you every thing
Comment 10 Yousuf Philips (jay) (retired) 2015-03-18 02:29:20 UTC
Hi Ahmad,

Glad to have you on board. The design team have worked on a suitable mockup and it can be found at ( https://docs.google.com/document/d/191XV116O7TQr5qzdou8JO1vNh5xXJtRujv8r07_SONE/edit?usp=sharing ).
Comment 11 Luke 2015-03-27 08:13:10 UTC
Ahmad,
I like the idea of adding an “Open Online” to the start center, especially if Bug 77590 is implemented.  

For attachment 114161 [details], your “Add Place” or “Add Online Storage” wizard is covered in detail by Bug 86703. I’m not sure about putting the wizard inside of the start center like you’ve shown in attachment 114162 [details] . It may not even be possible. Caolan and Jan are the experts on that.[1][2] 

Once we’ve nailed the wizard UI, it might be possible to use the start center to select from the added online stores and browse them, like MSO 2013. 


[1] http://caolanm.blogspot.ie/2013/01/converting-libreoffice-dialogs-to.html
[2] http://holesovsky.blogspot.com/2014/02/story-of-new-start-center-in.html
Comment 12 Yousuf Philips (jay) (retired) 2015-03-27 08:23:33 UTC
Closing this in favour of bug 86703, so all discussion can happen in one bug report.

*** This bug has been marked as a duplicate of bug 86703 ***
Comment 13 Hayato Kawajiri 2019-08-11 15:10:53 UTC
(In reply to Luke from comment #11)
> Ahmad,
> I like the idea of adding an “Open Online” to the start center, especially
> if Bug 77590 is implemented.  
> 
> For attachment 114161 [details], your “Add Place” or “Add Online Storage”
> wizard is covered in detail by Bug 86703. I’m not sure about putting the
> wizard inside of the start center like you’ve shown in attachment 114162 [details]
> [details] . It may not even be possible. Caolan and Jan are the experts on
> that.[1][2] 
> 
> Once we’ve nailed the wizard UI, it might be possible to use the start
> center to select from the added online stores and browse them, like MSO
> 2013. 
> 
> 
> [1] https://rottenhayato.com/ja/video/8440757373671592463/
> [2] http://holesovsky.blogspot.com/2014/02/story-of-new-start-center-in.html

sure, its work!