Bug 86703 - Easy access to online document storage services like Google Drive
Summary: Easy access to online document storage services like Google Drive
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Szymon Kłos
QA Contact:
URL:
Whiteboard:
Keywords:
: 84642 86699 (view as bug list)
Depends on: 84646
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-25 14:10 UTC by Yousuf Philips (jay)
Modified: 2016-03-04 10:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
dialog mockup (11.74 KB, image/png)
2014-11-25 14:10 UTC, Yousuf Philips (jay)
Details
mockup (177.41 KB, image/png)
2015-03-18 02:22 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-25 14:10:16 UTC
Created attachment 110001 [details]
dialog mockup

By default, LibO uses the operating system's dialogs, which means that most users will have no means of knowing that LO can connect to CMIS services like Google Drive. So in order to make this possible, i'd like to suggest an uno command be created called OpenCloud.

When executed, the command opens a simple dialog which has a drop down list of connectible services and username and password fields. When the user presses OK, the CMIS service is created in the favourites section of LO's custom/modal dialog, if not already available, and then automatically selected, so that the user can begin browsing their files.
Comment 1 Joel Madero 2014-11-25 16:00:27 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.2.2 release
Platform: Ubuntu Linux 14.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement

Note: This only confirms that it is a valid enhancement request and in no way guarantees that the enhancement will be implemented. Enhancements are completed by volunteers who implement it if they themselves want to. That being said we provide no guarantee or ETA.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
Feel free to come say hi to QA at http://webchat.freenode.net/?channels=libreoffice-qa

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free.

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Yousuf Philips (jay) 2015-03-18 02:22:11 UTC
Created attachment 114164 [details]
mockup

The design team has come up with a proposal for the revamping of how LibreOffice interacts with remote files.

Details of the proposal can be found in this google doc ( https://docs.google.com/document/d/191XV116O7TQr5qzdou8JO1vNh5xXJtRujv8r07_SONE/edit?usp=sharing ).
Comment 3 Heiko Tietze 2015-03-25 19:02:22 UTC
Double check as well the comments from the blog poost http://user-prompt.com/libreoffice-design-session-cmis-improvement/
Comment 4 Yousuf Philips (jay) 2015-03-27 08:15:09 UTC
*** Bug 86699 has been marked as a duplicate of this bug. ***
Comment 5 Yousuf Philips (jay) 2015-03-27 08:23:33 UTC
*** Bug 84642 has been marked as a duplicate of this bug. ***
Comment 6 Luke 2015-08-30 00:43:23 UTC
Adding eszka who is currently working on this issue.
Comment 7 Yousuf Philips (jay) 2016-02-17 13:08:57 UTC
So this was done as a GSoC 2015 and added in 5.1.

I had been doing heavy testing of the dialog during the GSoC in the link below for the student to fix, but unfortunately not all the bugs were fixed.

https://docs.google.com/document/d/1mZe2w_ErCY9vWkUEsB8x9T9Hq-w3rn3BqmkT5GL3Z0M/edit?usp=sharing
Comment 8 Szymon Kłos 2016-02-17 15:56:51 UTC
Currently I have some free time and I'm working on the icon view for the file control. It is almost done, I will commit it soon.
Comment 9 Yousuf Philips (jay) 2016-02-18 15:29:51 UTC
(In reply to Szymon Kłos from comment #8)
> Currently I have some free time and I'm working on the icon view for the
> file control. It is almost done, I will commit it soon.

Glad to still have you on board.
Comment 10 Yousuf Philips (jay) 2016-03-03 18:07:24 UTC
Would also be good to retain the resized window size, which was recently fixed in bug 96393 for the LO custom file picker.
Comment 11 Yousuf Philips (jay) 2016-03-03 20:15:16 UTC
Just as a reference, the patches for the new Remote File dialog are here - https://cgit.freedesktop.org/libreoffice/core/log/?h=feature/gsoc15-open-remote-files-dialog
Comment 12 Luke 2016-03-03 22:24:54 UTC
This is marked as "FIXED", but how do we test it with the latest builds? It's disabled on both my Windows and Linux builds. The only working Windows tinderbox is http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/

That also has the "Remote Files" -> "Add Service" options all greyed out.
Comment 13 Yousuf Philips (jay) 2016-03-04 03:07:08 UTC
(In reply to Luke from comment #12)
> This is marked as "FIXED", but how do we test it with the latest builds?

You have to use a release and not a daily build to test google drive as the daily builds dont put in the sauce needed to have it run.
Comment 14 Szymon Kłos 2016-03-04 09:11:11 UTC
(In reply to Yousuf (Jay) Philips from comment #10)
> Would also be good to retain the resized window size, which was recently
> fixed in bug 96393 for the LO custom file picker.

Storing the last window size (in the "Remote File" dialog) has already implemented. I did it during the GSoC.
Comment 15 Yousuf Philips (jay) 2016-03-04 10:32:48 UTC
(In reply to Szymon Kłos from comment #14)
> Storing the last window size (in the "Remote File" dialog) has already
> implemented. I did it during the GSoC.

I thought i remember you doing it as well, but it seems to be broken now, even the columns in the dialog arent working correctly (bug 98395), and i was testing google drive and its not connecting on linux and gives a 'The specified device is invalid' error dialog. I hope that people arent making changes to LO's internal file picker and that is causing regressions with the remote file dialog.