Bug Hunting Session
Bug 84754 - EDITING: calc breaks relative references during sort
Summary: EDITING: calc breaks relative references during sort
Status: RESOLVED DUPLICATE of bug 81633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-07 14:04 UTC by Norbert Scheibner
Modified: 2014-10-08 02:56 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Scheibner 2014-10-07 14:04:17 UTC
Tested on 4.3.2.
Following example:

| row A |      0 |
|     1 | =A2+B1 |
|     2 | =A3+B2 |
|     5 | =A4+B3 |
|     4 | =A5+B4 |

After sorting by "row A" it looks like (dont forget to mark "Contains row labels"):

| row A |      0 |
|     1 | =A2+B1 |
|     2 | =A3+B2 |
|     4 | =A4+B5 | <- this should be B3
|     5 | =A5+B3 | <- this should be B4

Any idea?
Comment 1 ign_christian 2014-10-07 14:42:51 UTC
Hi Norbert, please see Bug 81633 & related bugs. 

I guess this case should be the same regardless of "Contains row labels" option.
Comment 2 Norbert Scheibner 2014-10-07 14:55:35 UTC
ign_christian it seems U are right.

But if its true what I read in Bug 81633 that there will be no backport of the fix for 4.3 - I can find no nice words for this.

The conclusion should be to take the whole 4.3 series of the servers.
This is a major regression and a bug which can lead to silent corrupted tables.
This will nerve the users badly. U have to check really every spreadsheet U work with and sort lines!
Comment 3 ign_christian 2014-10-07 16:43:41 UTC
Hi again Norbert.. I can understand what you feel, but the changes was by purpose because of many users request (if you read the root bug report about internal sorting) so it's not a regression. 

I think you have 3 options at present if old behavior is important for you: 
- go for 4.4 (the behavior is configurable in that version, but remember it's still development phase)
- stick with 4.3.0.4
- stick with 4.2.6.3 (maybe it's prefered)

Just pick what option suits you best. And please mark this as duplicate to Bug 81633 if you agree both are the same case.
Comment 4 ign_christian 2014-10-07 16:47:47 UTC
Anyway please consider using parallel install to test new version: https://wiki.documentfoundation.org/Installing_in_parallel

So you won't get headache regarding unexpected changes in new version ;)
Comment 5 Norbert Scheibner 2014-10-07 17:05:05 UTC
I could name the bugs which let me use the latest of 4.3 series, but in short terms:

I am still just a user, not a beta tester!

and

I am not alone.
Comment 6 ign_christian 2014-10-08 02:56:38 UTC
> I could name the bugs which let me use the latest of 4.3 series, ...
Yup..there are always some options to choose what is best fit for us. 

> I am still just a user, not a beta tester!
Because of that there is another way for us as users to install in parallel. If you're using Windows, the easiest way is using portable app.

> I am not alone.
So lets close this thread and join the others.

*** This bug has been marked as a duplicate of bug 81633 ***