Bug 84797 - RTL: text string in "text frame" object is reversed when saving PDF document
Summary: RTL: text string in "text frame" object is reversed when saving PDF document
Status: RESOLVED DUPLICATE of bug 89471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2014-10-08 09:39 UTC by Jack
Modified: 2018-12-04 08:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF with RTL text in text frame. Text appears reversed, each save/open iteration reverses the text strings. (73.19 KB, application/pdf)
2014-10-08 09:39 UTC, Jack
Details
Simple PDF with RTL text in text frame object. (7.34 KB, application/pdf)
2014-10-08 19:34 UTC, Jack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2014-10-08 09:39:18 UTC
Created attachment 107546 [details]
PDF with RTL text in text frame. Text appears reversed, each save/open iteration reverses the text strings.

Open a PDF document that contains a text frame with RTL text. Note the order of the text string, for example "ABCDEFG". Save as PDF, and open the saved document. The order of the text string will be reversed, "GFEDCBA".

Sample PDF attached.
Comment 1 Joel Madero 2014-10-08 16:59:20 UTC
Please provide a much simpler document as it'll help developers focus on the real problem vs. all the extra unnecessary stuff.

Marking as NEEDINFO - once you provide a simpler document mark as UNCONFIRMED. Thanks
Comment 2 Jack 2014-10-08 19:34:03 UTC
Created attachment 107579 [details]
Simple PDF with RTL text in text frame object.

Simple PDF with a text frame containing the string "אבגדהוזחטי". When opened/saved as PDF, the string reverses to "יטחזוהדגבא". Each iteration of open/save alternates the string between forward/reverse.
Comment 3 Buovjaga 2014-11-14 20:06:22 UTC
Confirmed the flippage. Let's change to minor, referring to https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 4 Buovjaga 2015-01-09 14:18:22 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Jack 2016-03-25 13:15:47 UTC Comment hidden (off-topic)
Comment 6 Buovjaga 2016-03-25 13:21:16 UTC Comment hidden (off-topic)
Comment 7 Joel Madero 2016-03-25 14:58:09 UTC Comment hidden (off-topic)
Comment 8 Jack 2016-05-17 12:32:34 UTC Comment hidden (no-value)
Comment 9 QA Administrators 2017-05-22 13:40:56 UTC Comment hidden (obsolete)
Comment 10 Jack 2017-05-30 22:26:57 UTC
Present in 5.3.3
Comment 11 Omer Zak 2017-11-04 20:55:05 UTC
Still happens in:

Version: 5.4.2.2.0+
Build ID: 1:5.4.2-3~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)


Note: to see the bug you must export the file as PDF.
If you save using ODF Drawing format (.odg extension), the bug does not appear.
Comment 12 Eyal Rozenberg 2018-09-30 21:45:58 UTC
Bug still manifests with:

Version: 6.2.0.0.alpha0+
Build ID: ad6adb1bfadf49af3187a0bb3ceffbf355e9eed1
CPU threads: 4; OS: Linux 4.9; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-29_02:45:20
Locale: en-US (en_IL); Calc: threaded
Comment 13 Eyal Rozenberg 2018-12-03 21:03:00 UTC
Isn't this a duplicate of 89471?

The reversal is on open, so we save - without reversing - in the wrong format, right?
Comment 14 Buovjaga 2018-12-04 08:09:12 UTC
Right, might as well dupe to it.

*** This bug has been marked as a duplicate of bug 89471 ***