Download it now!
Bug 84819 - FILEOPEN: Can't read function from Excel contains column in defined range
Summary: FILEOPEN: Can't read function from Excel contains column in defined range
Status: RESOLVED DUPLICATE of bug 85063
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-09 04:17 UTC by SriJanani
Modified: 2014-10-17 02:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Formula reference formula (32.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-10-09 04:17 UTC, SriJanani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SriJanani 2014-10-09 04:17:19 UTC
Created attachment 107585 [details]
Formula reference formula

Wanted to report this issue since its becoming very big challenge for us with the files containing excel formula.I noticed if a reference is taken from other sheets then the file send to others its not working it shows REF or null value. Even hard recalculate does not help. Attaching the file help is appreciated.

Thank You,

Regards,
SriJanani
Comment 1 ign_christian 2014-10-09 14:37:42 UTC
I guess LO, also AOO, can't interpret =SUBTOTAL(109;Table5[epsac])

Seems a special function from Excel, but WPS Office 2014 can interpret the function.

109 function index has been reported in Bug 60477.

Table5[epsac] which is a column in defined range is another thing (can't find duplicate bug) and that should be the purpose of this report.

Perhaps an enhancement request?
Comment 2 ign_christian 2014-10-09 14:51:07 UTC
Tried updating summary to reflect the purpose of this bug report. Please correct if I'm wrong.

Set importance back to default (normal) until someone confirmed. XLSX import issue is not a critical bug I think..
Comment 3 SriJanani 2014-10-11 07:32:23 UTC
Hi,

I am sorry its related to the bug 84802. please ignore. So the conlusion is =SUBTOTAL(109;Table5[epsac]) function is not available with LO? is that right? also does Libre office support dynamic table?

Regards,
SriJanani
Comment 4 SriJanani 2014-10-16 05:37:12 UTC
I am still waiting for the update. Please clarify.

Thank You,

Regards,
SriJanani
Comment 5 ign_christian 2014-10-16 06:06:45 UTC
Hi again SriJanani.. Sorry for 'ignoring' you since I think I'm not the right guy to answer this, should be the one with proper knowledge.

Regarding dynamic table, should be ok with pivot table (even some bugs still exist). But if you meant with dynamic table is SUBTOTAL or function which has defined range that only points to spesific column (like what is shown in your file), seems that LO still can't interpret that.

If that function really important to you, as an Excel alternative, I saw WPS Office can support that.
Comment 6 ign_christian 2014-10-17 02:23:56 UTC
Hi SriJanani, we have better test case with similar issue in another bug and confirmed also by m.a.riosv. So let we mark this as a dupe.

@m.a.riosv, please modify summary if appropriate as you have better understanding about this issue than me. I just do housekeeping task :)

*** This bug has been marked as a duplicate of bug 85063 ***