Bug 84885 - Chart Wizard Dialogue cut off
Summary: Chart Wizard Dialogue cut off
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.4.0 target:4.3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-11 00:07 UTC by tolfeg
Modified: 2015-04-15 19:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Truncated dialogue (55.06 KB, image/jpeg)
2014-10-11 00:07 UTC, tolfeg
Details
Truncated dialogue (55.06 KB, image/jpeg)
2014-10-11 00:13 UTC, tolfeg
Details
Untruncated dialogue win7-4.2.6.2 (52.86 KB, image/jpeg)
2014-10-11 05:00 UTC, tolfeg
Details
Truncated Dialog under Win Aero (48.38 KB, image/jpeg)
2014-10-11 22:39 UTC, tolfeg
Details
Comparison of the two renderings under Classic (104.79 KB, image/jpeg)
2014-10-13 05:54 UTC, tolfeg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tolfeg 2014-10-11 00:07:45 UTC
Created attachment 107684 [details]
Truncated dialogue

Noticed the Data Label portion of the dialog in step3 - Data Series does not fit in the dialog. It is inconvenient that this cannot be changed in this dialogue, but it can be fixed later on.
Comment 1 tolfeg 2014-10-11 00:13:08 UTC
Created attachment 107685 [details]
Truncated dialogue
Comment 2 ign_christian 2014-10-11 02:32:29 UTC
Not repro with LO 4.3.2.2 - Ubuntu 12.04 x86

@tolfeg, regardless of this case maybe Windows only, is it always the case? Or spesific to particular chart / procedure?
Comment 3 tolfeg 2014-10-11 04:45:59 UTC
It doesn't occur under Windows for Ver 4.2.6.2, nor for Fedora 20 ver 4.2.6.
It also occurs under bar charts for Ver 4.3.2.2, Win 7.
It looks like someone increased the height of the multi-line Data Ranges select box. That doesn't make any sense because even for 3D charts it would only need 4 lines.. or am I missing something?
Comment 4 Adolfo Jayme 2014-10-11 04:49:11 UTC
(In reply to tolfeg from comment #3)
> It looks like someone increased the height of the multi-line Data Ranges
> select box. That doesn't make any sense because even for 3D charts it would
> only need 4 lines.. or am I missing something?

Surely that wasn’t intentional. The dialogs were converted to a new format that may have inadvertently caused this. Thank you for your report!
Comment 5 tolfeg 2014-10-11 05:00:25 UTC
Created attachment 107691 [details]
Untruncated dialogue win7-4.2.6.2

Looks like this was introduced in 4.3.
Comment 6 Julien Nabet 2014-10-11 12:29:10 UTC
Caolan/Chris: It seems Windows only bug (at least neither Ign-Christian nor me reproduce this on Linux). I thought you might be interested in this one since it seems more vcl/UI problem than a pure Calc problem.
Comment 7 ign_christian 2014-10-11 13:25:53 UTC
No repro with LO 4.3.2.2 portable under Win7 x86

Perhaps depends on particular screen resolution? Or a particular file?
Comment 8 Adolfo Jayme 2014-10-11 16:18:15 UTC
(In reply to ign_christian from comment #7)
> Perhaps depends on particular screen resolution? Or a particular file?

No, it depends whether you’re using the Classic or the Aero theme, of course.
Comment 9 tolfeg 2014-10-11 22:38:28 UTC
Not true. It is even worse under Aero.
I am running 23" Samsung monitor @ 1920x1080 @ Smaller-100%(default).
Am uploading an example under Aero.
Comment 10 tolfeg 2014-10-11 22:39:54 UTC
Created attachment 107725 [details]
Truncated Dialog under Win Aero
Comment 11 ign_christian 2014-10-12 01:16:10 UTC
(In reply to ign_christian from comment #7)
> No repro with LO 4.3.2.2 portable under Win7 x86
I'm using Aero, 13" laptop, 1366x768 resolution
Comment 12 tolfeg 2014-10-13 05:50:54 UTC
I have been able to produce both correct and incorrect rendering of the Chart Wizard (CW) dialog on the same machine using the same screen rendering.
It is very likely there is an 'undocumented feature' in Win7 rendering which this dialog has stumbled on. But I have a suggestion to avoid it.
This dialog is very similar to the Data Range (DR) dialog. However the DR dialog is sizable where the CW one is not. 
What is happening is that the Data Series box (in CW) is sometimes smaller allowing the height of the CW dialog box to shorten. This is what is clipping the dialog. The easy solution might be to make the CW dialog sizable like the DR one.
It seems some metric is loaded when LO starts which reads parameters from the theme. Then the Data Series text scroll box is sized from that metric. For Aero it takes 10 entries before it scrolls and 8 for Classic. Then the containing box is scaled from there. I have uploaded a side by side comparison. The error is not in the rendering, but in the parameters.
Comment 13 tolfeg 2014-10-13 05:54:19 UTC
Created attachment 107756 [details]
Comparison of the two renderings under Classic

The Data Series box is 8 lines high before it scrolls under the Classic metric while it is 10 under Aero!
Comment 14 tolfeg 2014-10-13 06:03:13 UTC
In a spreadsheet, create a two column data range like var-x,1,2,3; var-y,1,3,5. Select the range and create a chart; Insert, Object, Chart.... Choose chart type XY(Scatter), select points and Lines. Go to stage 3  by pressing Next twice.
Depending in which theme was in effect at the time LO was loaded, the rendering will be different. After that, you can change the theme and the appearance will change, but the rendering won't.

Right click on the desktop and select Personalize. (this is Control Panel, All Control Panel Items, Personalization.)
There is a central box labeled "Change the visuals and sounds on your computer. This is divided into 3 categories: My Themes, Aero Themes & Basic and High Contrast Themes.
The selected or highlighted theme is the current rendering theme. 
Windows 7 Basic, though it looks like a classic theme behaves like it is Aero.
If this is one of the Aero themes like Windows 7, then the CW dialog should be correct.
If one of the Classic or High Contrast themes then it will be truncated.
Change to the other class of themes. The rendering should be the same. Cancel the chart and close all instances of LO. You may even have to stop the Quick Start option in the tool box.
Then reload LO and bring up the test spreadsheet using the other class of theme. The rendering will change.
Comment 16 Libomark 2014-11-11 17:28:09 UTC
So this fix won't be available until 4.4?