Bug 84904 - Distribution icons look distorted
Summary: Distribution icons look distorted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Adolfo Jayme
URL:
Whiteboard: target:4.5.0 target:4.4.0
Keywords: bibisected, regression
: 86331 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-11 08:56 UTC by tommy27
Modified: 2015-12-17 08:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot 4.4.0.0+ vs. 4.3.2.2 (24.89 KB, image/png)
2014-10-11 08:56 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-10-11 08:56:06 UTC
Created attachment 107703 [details]
screenshot 4.4.0.0+ vs. 4.3.2.2

tested under Win7x64 with 4.4.0.0.alpha0+
Build ID: 9177329a425cf70b515d1f266132838894fe54c6
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-06_00:13:13

STEPS TO REPRODUCE
1- load attachment 51876 [details] in LibO Draw
2- shift+left-click on more than 3 images
3- click menu "Modify/Distribution"
4- Distribution dialog pops-up

see show the icons look distorted and compare with their normal look in LibO 4.3.2.2 in the attached screenshot.
Comment 1 Terrence Enger 2014-10-12 00:36:20 UTC
Working in the daily dbgutil bibisect repository, I see from `git
bisect bad`:

    4d7803322d0d9e2f069aae6b6230f2ee2811a843 is the first bad commit
    commit 4d7803322d0d9e2f069aae6b6230f2ee2811a843
    Author: Miklos Vajna <vmiklos@collabora.co.uk>
    Date:   Sat May 31 07:49:56 2014 +0200

        2014-05-31

    :100644 100644 5cdff4b72b87f3609a3fbf9790be7242381dfca7 a4f1c17df6de8b7664278e0a7e8c68d35947bc98 M	build-info.txt
    :040000 040000 a86ef32a79d207fc8acda0e5bc19593bf386ce0e 4c0a41d0c621376f97b3e63a32f5ef5f1517a7ff M	opt

and from `git bisect log`:

    # bad: [c93bc261b780c67e84015965e5e351e11586109a] 2014-06-01
    # good: [22c442bdba9ba11f9215d1e8c9af69a27bb11c6b] 2014-05-28
    git bisect start 'c93bc26' '22c442b'
    # good: [10c46444c867057c34d587fcda8b0efada6b894a] 2014-05-30
    git bisect good 10c46444c867057c34d587fcda8b0efada6b894a
    # bad: [4d7803322d0d9e2f069aae6b6230f2ee2811a843] 2014-05-31
    git bisect bad 4d7803322d0d9e2f069aae6b6230f2ee2811a843
    # first bad commit: [4d7803322d0d9e2f069aae6b6230f2ee2811a843] 2014-05-31
Comment 2 tommy27 2014-10-12 07:50:45 UTC
Can i set  status new?
Comment 3 Terrence Enger 2014-10-12 12:56:30 UTC
Confirming the bug.

I was hesitating because of my lack of confidence searching bugzilla
for potential duplicates.
Comment 4 Terrence Enger 2014-10-14 16:18:31 UTC
Further to results from daily dbgutil bibisect:

    test       date        commit   source hash
    ---------  ----------  -------  -----------
    last good  2014-05-30  10c4644  82e1456
    first bad  2014-05-31  4d78033  d2d2136
Comment 5 tommy27 2014-11-16 06:41:22 UTC
*** Bug 86331 has been marked as a duplicate of this bug. ***
Comment 6 tommy27 2014-11-16 06:43:39 UTC
still present in 4.4.0.0 alpha2 and on Linux as well

I copy this comment from duplicate Bug 86331

Jay Philips  2014-11-16 05:13:19 UTC 
Created attachment 109544 [details]
distribution dialog

After adding a few shapes, right click and select distribution. I'm assuming this might have been caused by the dialog being redraw during the dialog conversion phase. This doesnt happen in 4.3 daily.

Version: 4.4.0.0.alpha2+
Build ID: 19ad91f7bc7ca96c55e0ca3450608f616f87c4ed
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-13_23:17:38
Comment 7 Commit Notification 2014-11-24 10:49:36 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92a0793265c66d289828c0193097b14b7e7e2d0f

fdo#84904 Don’t stretch icons horizontally

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Maxim Monastirsky 2014-11-24 10:58:51 UTC
It was apparently a regression of http://cgit.freedesktop.org/libreoffice/core/commit/?id=eaa89db886ba49472e22d77cea957a08c1113cd0 which added the WB_SCALE bit to any .ui based image.
Comment 10 Robinson Tryon (qubit) 2015-12-17 08:37:08 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]