Bug 84935 - Intermittent crash on exit
Summary: Intermittent crash on exit
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Mac OS X (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-12 14:17 UTC by Matthew Francis
Modified: 2015-04-30 14:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
OSX backtrace (10.55 KB, text/plain)
2014-10-12 14:18 UTC, Matthew Francis
Details
Updated backtrace (9.07 KB, text/plain)
2014-10-23 15:59 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-10-12 14:17:21 UTC
Observed on OSX 10.9.5 / LibreOffice 4.4 master (d0d64225d853d01bf601b3738c26fd8ada41650e)

I can't reproduce this on Linux, so it may be OSX only.

Steps to reproduce:

1. Load the file from https://bugs.freedesktop.org/attachment.cgi?id=107674
2. Select the table on slide 3 (the whole table, by clicking on the border)
3. Cut
4. Exit (Cmd-Q)

Frequently, but not always, the attached crash will then occur.
Comment 1 Matthew Francis 2014-10-12 14:18:06 UTC
Created attachment 107740 [details]
OSX backtrace
Comment 2 Caolán McNamara 2014-10-13 12:01:32 UTC
Looks like a nasty EndListening during shutdown SfxBroadcaster::RemoveListener
Comment 3 Alex Thurgood 2014-10-13 16:26:50 UTC
Tried your steps 10 times with document in link, no crash on my master build

Version: 4.4.0.0.alpha0+
Build ID: 7dc6c9af4ba313f054331f5130470d83d875bc16

from yesterday

However, this behaviour is something I see frequently with dev builds at random intervals.
Comment 4 Alex Thurgood 2014-10-13 16:27:31 UTC
Confirming intermittent crash behaviour, but not with this document.
Comment 5 Matthew Francis 2014-10-23 15:59:30 UTC
Created attachment 108307 [details]
Updated backtrace

After commit a1fad26e045ff1fec0c63243e3516ef2da7f390d

Differs at frame 16
Comment 6 Michael Stahl (CIB) 2014-10-23 21:56:38 UTC
does this commit fix the second problem?
28adfcdcbc504db8d5014a8939aa5e834e5d43d0
Comment 7 Matthew Francis 2014-10-24 08:13:10 UTC
Yes, that seems to have done the trick

I notice there's another issue thereabouts that I seem to be able to cut (the content of) that table without marking the document changed, but that's something for another bug :)
Comment 8 Matthew Francis 2014-10-24 09:37:08 UTC
For reference, the above unrelated bug is bug 85398