Bug 84964 - Number Format: Currency does not follow System Preferences (OSX 10.9.5)
Summary: Number Format: Currency does not follow System Preferences (OSX 10.9.5)
Status: RESOLVED DUPLICATE of bug 80147
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All macOS (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 92799 (view as bug list)
Depends on:
Blocks: Number-Format
  Show dependency treegraph
 
Reported: 2014-10-13 10:44 UTC by David
Modified: 2017-11-10 20:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Top half shows cells formatted with Number Forma: Currency tool (resulting in pound sign and decimal point); bottom half shows System Preferences (showing euro and decimal comma) (93.17 KB, image/jpeg)
2014-10-13 10:44 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2014-10-13 10:44:54 UTC
Created attachment 107771 [details]
Top half shows cells formatted with Number Forma: Currency tool (resulting in pound sign and decimal point); bottom half shows System Preferences (showing euro and decimal comma)

Currency formatting shows incorrect currency format, not matching that specified in System Preferences>Language & Region setting.

Steps to reproduce:
1. Select cells filled with numeric data;
2. Select Number Format: Currency icon in toolbar
3. Cells formatted incorrectly.

Current behaviour: Cells formatted as GBP, showing pounds symbol and using point decimal separator.

Expected behaviour: Cells to be formatted with currency as specified in System Preferences.
Comment 1 Alex Thurgood 2014-10-13 16:37:12 UTC
@David : sorry, your jpg shows only the system locale setting and part of a sheet with what appears to be correct GBP number formatting - we'll need more info if we want to be able to try and reproduce

Please provide :

OSX version
LO version
Langpack and LO UI language if any
Comment 2 David 2014-10-13 17:14:43 UTC
OSX 10.9.5
LibreOffice 4.3.1.2 (in bug report); Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
Langpack: sorry, not aware of that
LO UI language: English
Comment 3 Buovjaga 2014-11-27 11:16:25 UTC
Back to UNCONFIRMED as info was provided.
Comment 4 Alex Thurgood 2014-11-30 11:31:20 UTC
@David : the langpack is the extra dmg file that you download and install separately if you want correct support for your language. The default LO download for an English browser is en-US, which might be why you are not getting the results you would like.

My suggestion - try downloading and installing a langpack that has Euro as its native currency format. Possibly, the en-GB langpack also does this correctly (I haven't tested).
Comment 5 Alex Thurgood 2014-11-30 12:01:00 UTC
resetting to needinfo
Comment 6 QA Administrators 2015-06-08 14:29:22 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2015-07-18 17:27:53 UTC Comment hidden (obsolete)
Comment 8 Alex Thurgood 2015-07-20 16:24:48 UTC
Also reported against OSX 10.9.5 in bug 92799 - confirming
Comment 9 Alex Thurgood 2015-07-20 16:25:08 UTC
*** Bug 92799 has been marked as a duplicate of this bug. ***
Comment 10 QA Administrators 2016-09-20 10:18:41 UTC Comment hidden (obsolete)
Comment 11 eisa01 2017-11-10 20:17:10 UTC
This is a duplicate, LibreOffice doesn't currently respect the regional/locale settings

*** This bug has been marked as a duplicate of bug 80147 ***