Bug Hunting Session
Bug 84972 - Font rendering in Charts issue on OSX
Summary: Font rendering in Charts issue on OSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2014-10-14 00:12 UTC by Frantisek Erben
Modified: 2016-11-06 18:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test.ods (43.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-14 00:12 UTC, Frantisek Erben
Details
Screenshot from LO 4.2.6.3 64bit (No bug appear) (30.29 KB, image/png)
2014-10-14 00:14 UTC, Frantisek Erben
Details
Screenshot from LO 4.3.2.2 64b (Bug: see text in red rectangle) (34.95 KB, image/png)
2014-10-14 00:15 UTC, Frantisek Erben
Details
Screenshot from LO 4.3.2.2 32b (Bug: see text in red rectangle) (30.19 KB, image/png)
2014-10-14 00:16 UTC, Frantisek Erben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek Erben 2014-10-14 00:12:49 UTC
Created attachment 107794 [details]
Test.ods

Open included ODS file on LI 4.3.2.2 and 4.2.6.3 (screenshots included).
Rendering of X-axis desctiptors strings are bad.

If you change format of used column to "Number" only bug disappear (dependency on Financial format – Czech or possible another).


Regression: YES – bug appear somewhere between 4.2 and 4.3

Bug appear on both OS X processor platforms Intel 32 and 64 bit.
Comment 1 Frantisek Erben 2014-10-14 00:14:45 UTC
Created attachment 107795 [details]
Screenshot from LO 4.2.6.3 64bit (No bug appear)
Comment 2 Frantisek Erben 2014-10-14 00:15:39 UTC
Created attachment 107796 [details]
Screenshot from LO 4.3.2.2 64b (Bug: see text in red rectangle)
Comment 3 Frantisek Erben 2014-10-14 00:16:02 UTC
Created attachment 107797 [details]
Screenshot from LO 4.3.2.2 32b (Bug: see text in red rectangle)
Comment 4 raal 2014-10-14 06:44:29 UTC
I can not confirm on 4.3.2, Win7.
Changing version to 4.3.2, first appear of bug.
Comment 5 Alex Thurgood 2014-10-14 13:52:09 UTC
Confirming on OSX 10.9.5, LO 4322
Comment 6 Alex Thurgood 2014-10-14 13:54:42 UTC
Bug not present in 4242
regression
Comment 7 Matthew Francis 2014-12-29 06:53:32 UTC
Adding Whiteboard:bibisectRequest. This may fall in the available bibisect range for OSX
(Note to check later: I have a feeling I've seen a duplicate for this somewhere)
Comment 8 Andras Timar 2015-06-04 19:52:08 UTC
I did not find the wrong commit neither in Bibisect_MacOSX10.6+_lo-4.2_to_lo-4.3.tar.bz2 nor in bibisect-macosx-64-5.0.tar. So probably it occurred between 4.3 and 4.4 and was backported to release branch. There is no bibisect repo for that range.

I CC you, Pierre-Eric, because a commit of yours is related. 

commit 162f11cdb94b415ff9d58674e94fb01a745a69eb
Author: Pierre-Eric Pelloux-Prayer <pelloux@gmail.com>
Date:   Thu Mar 12 22:37:54 2015 +0100

    vcl/text: fix duplicate text in fontwork tdf#81876

On the screenshots we see duplicated labels, one is written with the desired font, the other is written with a narrow font. After your patch unfortunately the normal font is gone, and only the narrow one is displayed. But when the rotation is set back to 0, the font changes back to normal.
Comment 9 Robinson Tryon (qubit) 2015-12-10 01:26:39 UTC Comment hidden (obsolete)
Comment 10 eisa01 2016-11-06 18:19:54 UTC
This works for me in 5.2.3.3, setting as resolved works for me

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 2; OS Version: Mac OS X 10.12; UI Render: default; 
Locale: en-US (en_NO.UTF-8); Calc: group