Bug 85002 - Application lower window border not visible after wizard form creation on OSX
Summary: Application lower window border not visible after wizard form creation on OSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86-64 (AMD64) macOS (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on: 87123
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-14 14:18 UTC by Alex Thurgood
Modified: 2015-12-17 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-10-14 14:18:25 UTC
1) Open an ODB file
2) Create a default form using wizard, click through all steps accepting defaults.
3) Form is opened, but record navigation toolbar not visible.
Comment 1 Alex Thurgood 2014-10-14 14:19:42 UTC
Tested on LO 4322 OSX 10.9.5
Comment 2 Alex Thurgood 2014-10-14 14:22:12 UTC
The only way to get the record navigation toolbar to appear is to minimize the window to the dock and then redisplay it.
Comment 3 Alex Thurgood 2014-10-14 14:24:44 UTC
Even closing the ODB, reopening it and the reopening form does not display navigation bar by default
Comment 4 Alex Thurgood 2014-10-14 14:33:35 UTC
This works however without problem on LO 3672, 4132, 4162.


Fails on 4233 and subsequent versions (4252, 4322, 440 alpha)
Comment 5 Alex Thurgood 2014-10-14 14:34:35 UTC
Tested on 2 different machines
Comment 6 Alex Thurgood 2014-10-14 14:41:36 UTC
Have changed title because in fact it is the whole of the bottom border of the form window that is not visible, including any controls located there.

This occurs even if document page zoom set to 100% by hand after re-expanding window from minimized state.
Comment 7 Alex Thurgood 2014-10-14 14:43:39 UTC
Thepage zoom attribute seems to be set during execution of the wizard and exceeds the coordinates of the screen.
Comment 8 Robert Großkopf 2014-10-14 17:42:41 UTC
Couldn't reproduce the bug under OpenSUSE 12.3 64bit rpm Linux. Have tested with LO 4.2.7.1
So might be a special Mac-bug.
Comment 9 Julien Nabet 2014-11-29 15:06:15 UTC
On MacOs 10.9.5, I don't reproduce with master 4.3.1 or with master sources updated some days ago.
Comment 10 Matthew Francis 2014-12-30 07:01:43 UTC
I couldn't reproduce this on OSX 10.10 with LO 4.3.4.1 or 4.4.0beta2 (although the bottom of the form window does jiggle around a lot initially, so there could be some race condition hiding there)

If it can be reproduced anywhere, the OSX bibisect repository could be used to narrow it down, so adding Whiteboard:bibisectRequest
Comment 11 retired 2014-12-30 11:09:33 UTC
Alex: could you please retest on 4.4? If it's fixed there and in latest 4.3 releases we might as well just put this worksforme.
Comment 12 Alex Thurgood 2014-12-31 10:50:32 UTC
Can't test on master 450 alpha as wizard actually fails to complete form creation at step 8
Comment 13 Alex Thurgood 2014-12-31 10:53:16 UTC
(In reply to Alex Thurgood from comment #12)
> Can't test on master 450 alpha as wizard actually fails to complete form
> creation at step 8

To be more precise, at step 8, the user is asked for a name for the form, or a default is suggested. The user se3es the Finish button highlighted, but clicking on this does nothing. The only other alternative is Back or Cancel.
Comment 14 Alex Thurgood 2014-12-31 10:54:33 UTC
(In reply to Alex Thurgood from comment #13)
> (In reply to Alex Thurgood from comment #12)
> > Can't test on master 450 alpha as wizard actually fails to complete form
> > creation at step 8
> 
> To be more precise, at step 8, the user is asked for a name for the form, or
> a default is suggested. The user se3es the Finish button highlighted, but
> clicking on this does nothing. The only other alternative is Back or Cancel.

This is a different bug. Opening new report.
Comment 15 Alex Thurgood 2014-12-31 11:44:49 UTC
bug 87123 is currently blocking me from testing this on master
Comment 16 Alex Thurgood 2014-12-31 11:59:40 UTC
Version: 4.3.3.1
Build ID: 7d55112667c8fcddb67bc3803796b46c93aa56b0

wfm, closing
Comment 17 Robinson Tryon (qubit) 2015-12-17 08:37:11 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]