Bug 85162 - FORMATTING: wrong page numbers (with not standard Word field) in particular .docx
Summary: FORMATTING: wrong page numbers (with not standard Word field) in particular ....
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Fields-Page-Number DOCX-Page
  Show dependency treegraph
 
Reported: 2014-10-17 23:38 UTC by Juha
Modified: 2018-06-28 06:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The problematic .docx (50.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-10-17 23:38 UTC, Juha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juha 2014-10-17 23:38:09 UTC
Created attachment 108013 [details]
The problematic .docx

LibreOffice shows page number 1 on EVERY page instead of showing the real page number.

Here is screenshot: http://imgbox.com/5FEXzJi4 (I circled the wrong number)

.docx file which is showing on screenshot also attached.
Comment 1 tommy27 2014-10-18 02:38:18 UTC
confirmed under Win7x64 using LibO 4.3.2.2 and 4.4.0.0.alpha0+
Build ID: 2d6dacc1c93bfd4a9086f8fde6b0edbfdeb573c9
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-13_23:44:09

edited summary notes and set status to NEW
Comment 2 Cor Nouws 2014-10-18 09:36:55 UTC
Hmm, this is not a normal page number field in Word, is it ??
Comment 3 Juha 2014-10-18 10:26:51 UTC
(In reply to Cor Nouws from comment #2)
> Hmm, this is not a normal page number field in Word, is it ??

Maybe not, but an alternative perhaps? Anyway, this bug still exist since LO shows it differently than MS Office.
Comment 4 QA Administrators 2015-12-20 16:08:00 UTC Comment hidden (obsolete)
Comment 5 Cor Nouws 2015-12-27 20:53:53 UTC
still in 5.2 master
Already a problem in 3.3.0
Comment 6 QA Administrators 2018-06-28 02:47:20 UTC Comment hidden (obsolete)
Comment 7 tommy27 2018-06-28 06:08:32 UTC
bug is gone in LibO 6.0.4.2 and 6.2.0.0 alpha

RESOLVED WORKSFORME