Download it now!
Bug 85226 - Calc doesn't render sheet on open
Summary: Calc doesn't render sheet on open
Status: RESOLVED DUPLICATE of bug 84854
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-10-20 09:27 UTC by Yousuf Philips (jay) (retired)
Modified: 2014-10-20 13:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Calc - Opening it from the start center (278.04 KB, image/png)
2014-10-20 09:27 UTC, Yousuf Philips (jay) (retired)
Details
Calc - Selecting Cells (172.75 KB, image/png)
2014-10-20 09:28 UTC, Yousuf Philips (jay) (retired)
Details
Calc - Scrolling with the mouse (251.37 KB, image/png)
2014-10-20 09:28 UTC, Yousuf Philips (jay) (retired)
Details
Calc - Scrolling in an existing doc (111.30 KB, image/png)
2014-10-20 09:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-20 09:27:11 UTC
Created attachment 108097 [details]
Calc - Opening it from the start center

When opening Calc from the start center, the sheet and grid is not rendered. I can still see portions of the start center screen. If i alt+tab twice, i see the background of the application i just alt+tabed from. If i select cells with the mouse, i can see the selected cells in gray overwriting the background. If i scroll with the mouse, i can see the cell number tooltips stay on the screen.

Version: 4.4.0.0.alpha0+
Build ID: c68642d535f2ebb7f1cd866ad19b1fd018e7cd6d
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-18_23:03:32

This regression has happened within the last month as it doesnt happen with Linux-rpm_deb-x86@45-TDF / 2014-09-16_19:38:50. This problem of the grid and cells not appearing doesnt happen when you open an existing document in calc, but scrolling up and down with the mouse shows fragments of things not being refreshed properly.
Comment 1 Yousuf Philips (jay) (retired) 2014-10-20 09:28:17 UTC
Created attachment 108098 [details]
Calc - Selecting Cells
Comment 2 Yousuf Philips (jay) (retired) 2014-10-20 09:28:43 UTC
Created attachment 108099 [details]
Calc - Scrolling with the mouse
Comment 3 Yousuf Philips (jay) (retired) 2014-10-20 09:36:20 UTC
Created attachment 108101 [details]
Calc - Scrolling in an existing doc

You can see that scrolling in an existing doc, small portions of the cell number tooltip on the right are still present.
Comment 4 Yousuf Philips (jay) (retired) 2014-10-20 09:43:15 UTC
Well i'm going through the available daily builds and it is fine in

Version: 4.4.0.0.alpha0+
Build ID: a8c9f6bc8580d5d4c68ded8a0119704de9e6c1a5
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-06_05:44:13

and broken in

Version: 4.4.0.0.alpha0+
Build ID: 53c836701e22b1babd3702b502facd76236df7ff
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-10_10:10:52

Also noticed that in the broken builds, i'm unable to draw objects from the drawing toolbar.
Comment 5 tommy27 2014-10-20 09:45:28 UTC
probably same root as Bug 84854
do you think it's a duplicate or a different issue?
Comment 6 Yousuf Philips (jay) (retired) 2014-10-20 09:54:16 UTC
Well this is as much regression testing that i can do with the daily builds. It is fine in

Version: 4.4.0.0.alpha0+
Build ID: ce5cc7afb0f1c99237d04e0c754527c725d8491c
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-06_19:35:48

and broken in

Version: 4.4.0.0.alpha0+
Build ID: 227ca23324fabd77abae1b7eb6186ba11d519fae
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-10-09_14:20:58

There were no 7th and 8th october builds unfortunately.
Comment 7 Yousuf Philips (jay) (retired) 2014-10-20 09:54:52 UTC
Yes looks like a duplicate of that one. Thanks tommy. Atleast i know its not limited to linux. :)

*** This bug has been marked as a duplicate of bug 84854 ***