Bug 85250 - embedded SVG disappears, replaced with "Read error"
Summary: embedded SVG disappears, replaced with "Read error"
Status: RESOLVED DUPLICATE of bug 82953
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 16:24 UTC by Milan Bouchet-Valat
Modified: 2014-10-21 07:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2014-10-20 16:24:06 UTC
I have an ODT document here in which a SVG image consistently disappears after a few seconds of moving it in the document. I gets replaced with a frame saying "Read error". I can send you the document by private e-mail.

I'm using LO 4.2.6.3 on Fedora 20.
Comment 1 Terrence Enger 2014-10-20 16:52:10 UTC
Milan,

Thank you for taking the time to help up improve LibreOffice.  If you
can do a couple of things, it will help us to go forward:

(1) Is the image embedded in you .odt file?  If on the other hand it
    is linked, is the file still at the linked-to location?  If this
    is the source of your problem, then I think the message "read
    error" is not a bug; LibreOffice might well give a more specific
    message, however.

(2) If point (1) still leaves you with a problem, then I
    (lo_bugs@iseries-guru.com) would like to receive the problem
    file(s).  I shall try to see if the problem is a recent
    regression.  I presume that you do not want to make the document
    available to the whole world; otherwise you can simply attach to
    the bug report.

(3) I notice that the original bug status is NEW.  Unless somebody
    else can make the problem happen, the right status is UNCONFIRMED.

When you answer, please set the bug status back to UNCONFIRMED.

Thanks,
Terry.
Comment 2 Milan Bouchet-Valat 2014-10-20 17:29:01 UTC
1) Yes, it's embedded.

2) I've just sent the document to you. Indeed, I don't want to make it public as it's a work in progress with tons of embarrassing things. :-)

To reproduce, take for example the figure at p. 12 (the one which is supposed to be figure 9, but appears one page before the caption, and which is over footnotes 5 and 6). Move it a bit here and there, and wait for the auto save to happen. Scroll the window, and that's it.

3) No idea how it ended as NEW...
Comment 3 tommy27 2014-10-20 19:28:19 UTC
take a look at Bug 82953
is this SVG issue related to auto-save as well?
Comment 4 Milan Bouchet-Valat 2014-10-20 20:35:53 UTC
Ah, right. I had not noticed at first that autosave was involved.

*** This bug has been marked as a duplicate of bug 82953 ***
Comment 5 Milan Bouchet-Valat 2014-10-20 21:22:34 UTC
BTW, have you tested it on a more recent version? If not, I'll 4.3.7 when it comes out.
Comment 6 tommy27 2014-10-20 23:26:55 UTC
bug is not even fixed in 4.3.x
it's unlikely it will be fixed in 4.2.7
Comment 7 Milan Bouchet-Valat 2014-10-21 07:40:48 UTC
OK, thanks. I got a little confused by all the linked bugs.