Bug 85325 - FILEOPEN: Opening copy of document in use doesn't get listed in recent documents/start center
Summary: FILEOPEN: Opening copy of document in use doesn't get listed in recent docume...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Recent-Document-List Start-Center
  Show dependency treegraph
 
Reported: 2014-10-22 11:06 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-07-07 02:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-22 11:06:34 UTC
If you open a document in use and you select 'Open Copy' from the dialog that appears, the file wont be added to the start center.

I consider this a regression as in 4.2, clicking the 'Open' button in the dialog still added it to the start center list.
Comment 1 Yousuf Philips (jay) (retired) 2014-10-22 11:38:18 UTC
Seems 4.3 also has 'Open' and not 'Open Copy'.
Comment 2 Buovjaga 2014-11-04 13:12:02 UTC
I confirm.
I opened document in 4.3, then the same as a copy in 4.4. Closed them both and 4.4 start center did not offer the document.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-04_00:06:27
Comment 3 tmacalp 2014-12-16 20:08:15 UTC
I don't believe this is a regression.  I don't think this ever worked.  Start center is really just displaying recent documents.  I tested opening a copy of a document in OpenOffice 3.2.1 and it did not create an entry in recent documents either.

I also tested it under 4.2.6 and it behaves the same way OOo 3.2.1 does.  When you open a document as copy, it does not show up under recent docs or the start page.  Maybe it was thought to be working because someone opened it as "read only" instead of "open copy" for a test?

Based on the above, I'm making a number of changes to the report, but please change back if I've been hasty!

1. The title should be changed to something tied to recent documents, which is the root cause. 

2. The version should be changed to "Inherited from OOo."

3. The whiteboard should be changed to "prebibisect."

4. It's not a "regression" as defined by LibreOffice QA, since it never did work properly.
Comment 4 Yousuf Philips (jay) (retired) 2014-12-17 08:20:35 UTC
Works fine in 4.4 and master now as they no longer have 'Open Copy' button and instead have an 'Open' button.

Version: 4.4.0.0.beta2+
Build ID: 95b7cf6cef5edc920adee62c18fd97668a9ed3a8
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-4, Time: 2014-12-11_23:36:38
Comment 5 tmacalp 2014-12-17 14:21:01 UTC
I just tested this under LO 4.4.0.0-beta2 and under the nightly master snapshot (master~2014-12-12_18.49.54_LibreOfficeDev_4.5.0.0.alpha0) using 32bit Fedora17. 

I still get the same "Document in Use" dialog with an "Open Copy" button when I try to open a document currently in use by another user.  It still presents me with buttons for opening read-only, as a copy, or to cancel.  Opening as a copy still does not add an entry for that file under either the start center or under recent documents.

I'm changing the status to reopened.
Comment 6 Yousuf Philips (jay) (retired) 2014-12-30 14:50:51 UTC
Returning it back to NEW. I see 'Open Copy' now in both 4.4 and 4.5. No idea how i saw 'Open' the last time.

Version: 4.4.0.0.beta2+
Build ID: 95b7cf6cef5edc920adee62c18fd97668a9ed3a8
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-4, Time: 2014-12-11_23:36:38

Version: 4.5.0.0.alpha0+
Build ID: e570cd7a293ceee175949dcc9656cdf776ae3c37
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-12-12_18:49:54
Comment 7 Yousuf Philips (jay) (retired) 2015-01-02 13:56:45 UTC
Dont know how, but i saw 'Open' in 4.4.

Version: 4.4.0.1.0+
Build ID: 4774b2f0e6a0e895d1e63256147eaff59efd0eda
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-4, Time: 2014-12-29_17:48:44
Comment 8 tmacalp 2015-01-02 14:10:57 UTC
I believe you were attempting to open the same file as the same user, but with a different version of LO.  

For example, if I have a file open as my user with LibreOffice 426 and I fire up a new instance of LibreOffice 4401 as the same user on the same file, it does present me with "Open Read-Only", "Open", and "Cancel".  This is what you must have been seeing.

If I open the file in LibreOffice 426 as my user and then attempt to open it as root using LibreOffice 4401, I get "Open Read-Only", "Open Copy", and "Cancel".

So LO appears to be making a distinction between different versions of LO and different users.
Comment 9 Yousuf Philips (jay) (retired) 2015-01-02 22:33:25 UTC
Well every time i open LO, it is always from the same user, so i dont know why i would ever see 'Open Copy' at all.
Comment 10 tommy27 2015-11-01 09:54:20 UTC
I can't reproduce this issue with LibO 5.0.3.1
@Jay
would you please give an update of this bug status?
Comment 11 Yousuf Philips (jay) (retired) 2015-11-01 14:46:50 UTC
'Open as Copy' still doesnt add it to the start center using tmacalp's instructions in comment 8.

Version: 5.1.0.0.alpha1+
Build ID: 048bc383f1d2c15f690364d0001045cdf7090f6f
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-28_00:39:39
Locale: en-US (en_US.UTF-8)
Comment 12 Robinson Tryon (qubit) 2015-12-14 05:40:02 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2016-09-14 14:48:31 UTC
Only regressions should use the keyword 'preBibisect'. Removing it...
Comment 14 QA Administrators 2018-07-07 02:39:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug