Bug Hunting Session
Bug 85337 - Sidebar: Impress Slide Transition TAB Content panel not navigable with keyboard
Summary: Sidebar: Impress Slide Transition TAB Content panel not navigable with keyboard
Status: RESOLVED DUPLICATE of bug 100898
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Sidebar-Accessibility Sidebar-Slide-Transition
  Show dependency treegraph
 
Reported: 2014-10-22 16:54 UTC by V Stuart Foote
Modified: 2016-10-24 12:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-10-22 16:54:03 UTC
-=nomenclature ref=- https://wiki.openoffice.org/wiki/File:SidebarNames.png

For use in Sidebar the Slide Transitions panel was converted to .UI with 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=16428c9600964a4945cf6fd0d938dea047d1248b

Unfortunately we can not enter the Sidebar Slide Transition Content panel from the Tab bar with keyboard only. An a11y and UX issue.

GUI is correct, as you can mouse click on Slide Transition tab and then on a slide transition--which launches a preview-- and returns focus to the content panel (see bug 84417).  And once in the content panel have the normal mix of .UI keyboard movement <tab>/<shift><tab> and <cursor U,D> to navigate the .UI GTKFrame, GTKBox, GTKList  elements correctly.  

Where there is a problem is that with keyboard only <F6> movement onto the Sidebar Tabs, and <cursor U,D> for selection of the Slide Transition tab to activate the content panel(s)--only the Title "Slide Transition" receives focus.

Can not then drop down from the title into the content panel(s) with keyboard movements--it should be done with a <Tab>.

Interesting that if already in the content panel, from mouse movement and click, <Esc> correctly exits the panel back to the title. But can not reenter panel with <Tab>.

Steps to reproduce:

1. Open Impress w/Sidebar view active
2. mouse click on "Slide Transition" Tab
3. click on a slide transition in the list "Apply to selected slides" for preview
4. <Esc> to exit content panel back to Title
5. a <Tab> should reenter and focus on the transitions list, but it goes some where else?
6. <Esc> returns focus to Slide Transition Title

Steps 1-4 of these STR can be done keyboard only by cycling with <F6> to the Sidebar Tab, and cursor <U,D> to the Slide Transition Tab and <Enter>

Similar behavior with the Custom Animation Tab conversion to .UI
http://cgit.freedesktop.org/libreoffice/core/commit/?id=14d05d3f0c4f41a74a7414258531912410060e5b
Comment 1 Buovjaga 2014-11-15 11:44:50 UTC
Reproduced.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 2 Robinson Tryon (qubit) 2015-12-10 03:37:43 UTC Comment hidden (obsolete)
Comment 3 Yousuf Philips (jay) (retired) 2016-10-23 22:16:12 UTC
@Stuart: This likely should be closed as bug 100898 is about the same issue but for all tabs/decks.
Comment 4 V Stuart Foote 2016-10-24 00:56:07 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> @Stuart: This likely should be closed as bug 100898 is about the same issue
> but for all tabs/decks.

Sure, reasonable to do so...

*** This bug has been marked as a duplicate of bug 100898 ***