Bug 85373 - UI: option to invert light/dark areas of the display
Summary: UI: option to invert light/dark areas of the display
Status: RESOLVED DUPLICATE of bug 118320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2014-10-23 16:35 UTC by johnson
Modified: 2020-09-30 13:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Here is a possible image of a reversed light/dark screen (40.98 KB, application/vnd.oasis.opendocument.text)
2014-10-25 16:21 UTC, johnson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description johnson 2014-10-23 16:35:26 UTC
Problem description: 

I would like to suggest that all libreoffice components (but especially Writer and Calc) include the option for the user to reverse the light/dark areas of the display.  That is, I would like to be able to have light text/menus on a dark background.  Graphics could be displayed as they are, with a narrow white border around them.  
This would significantly reduce eye strain, especially in low light environments.  And AFAIK it is a feature that macrosloth does not have!  

[Please note that this is not specific to the Version that I selected above - I had to select a version in order to be able to enter this text.] 



Current behavior: black text shown on white background 

Expected behavior:
white text on black background
Comment 1 tommy27 2014-10-23 19:00:22 UTC
please upload a mock-up picture of what you would like to obtain

take a screenshot of a Writer page and then play with any image editor you like to simulate how your enhancement option should look like

set status to NEEDINFO
Comment 2 johnson 2014-10-25 16:21:11 UTC
Created attachment 108407 [details]
Here is a possible image of a reversed light/dark screen

Here is an example of what a reversed dark/light screen could look like.  
I am certain that you could make it look at lot nicer than this though!
Comment 3 tommy27 2014-10-25 19:19:40 UTC
ok, now it's clear what you aim.
enhancement request, status NEW
Comment 4 Buovjaga 2020-09-21 17:36:52 UTC
johnson: this request looks to be the same as bug 98032. Do you agree?
Comment 5 Thomas Lendo QA 2020-09-21 19:56:40 UTC
Buovjaga: If it's not a dupe, please assign it to meta High-Contrast. Thanks!
Comment 6 johnson 2020-09-29 18:54:32 UTC
(In reply to Buovjaga from comment #4)
> johnson: this request looks to be the same as bug 98032. Do you agree?

I don't think so.  It appears that the other person is referring to high contrast, and I was referring to swapping dark and light for less eye strain, especially in low lighting conditions.  
Those are not the same.
Comment 7 Buovjaga 2020-09-29 19:22:14 UTC
(In reply to johnson from comment #6)
> (In reply to Buovjaga from comment #4)
> > johnson: this request looks to be the same as bug 98032. Do you agree?
> 
> I don't think so.  It appears that the other person is referring to high
> contrast, and I was referring to swapping dark and light for less eye
> strain, especially in low lighting conditions.  
> Those are not the same.

Well, the request in the other report was super close to your image sketch:
"Expected Results:  
I expect the (none-)page area to be black, the text to be yellow, page borders to be white (with high-contrast-#1 theme)."

The usefulness of this separate report should be evaluated by the UX team.
Comment 8 V Stuart Foote 2020-09-29 23:05:49 UTC
Linux os/DE VCL backends already provide the request--just not for Windows

The user interface would come from the WDM which unlike UWP has limited support for theming--hence no support currently for Windows 10 "darkmode".

Setting this dupe of bug 118320 as the mishandling of High Contrast bug 98032 is a different facet of the theme being passed from Windows os/DE.

*** This bug has been marked as a duplicate of bug 118320 ***
Comment 9 Heiko Tietze 2020-09-30 08:08:54 UTC
Tools > Options > Application Colors has a dropdown with "LibreOffice" default scheme. We could add another set with inverted colors.
Comment 10 V Stuart Foote 2020-09-30 13:25:25 UTC
(In reply to Heiko Tietze from comment #9)
> Tools > Options > Application Colors has a dropdown with "LibreOffice"
> default scheme. We could add another set with inverted colors.

Providing a second inverted application color "scheme" might cause additional issues. And, Application colors does not address all elements of the UI--notably missing are the listbox & text entry fields.

Better to work out how to handle UWP provided color theming as suggested bug 118320