Bug Hunting Session
Bug 85479 - EDITING; error in referencing cells in formulas when sorting source data
Summary: EDITING; error in referencing cells in formulas when sorting source data
Status: RESOLVED DUPLICATE of bug 81633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: x86 (IA32) All
: high blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-26 11:17 UTC by Antonio Scordia
Modified: 2014-10-26 14:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
simple table to show the issue (15.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-26 11:17 UTC, Antonio Scordia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Scordia 2014-10-26 11:17:57 UTC
Created attachment 108443 [details]
simple table to show the issue

Let's say we have a simple two-column table. The first contains a list of unsorted numbers; the second, in each cell, a formula that adds the contents of the cell above the second column with the contents of the adjacent cell of the first column (of course using relative references), thus showing the gradual increase of the values​​. If we select the contents of the first column and order it (without extending to the second column), the cell references in the first column moving as if they were absolute rather than relative, so the results of the formulas are incorrect. I am attaching a simple table to show the problem.
The issue is present in Linux and Windows both x86
Comment 1 Jean-Baptiste Faure 2014-10-26 14:15:43 UTC
Known problem, already tracked in bug 81633.
See bug 85215 too.

In the master (version 4.4.0.0.alpha1+) it works if you uncheck the configuration option "Update references when sorting range of cells" in Tools > Options > LibreOffice Calc > General _and_ select the column to be sorted without extending the selection to the next column containing summation formulas.
If you check this option, the values seem correct but the formulas have been modified.


Best regards. JBF

*** This bug has been marked as a duplicate of bug 81633 ***