Bug 85616 - Writer very slow with images imported from dxf
Summary: Writer very slow with images imported from dxf
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-10-29 19:28 UTC by antonio
Modified: 2016-08-25 22:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
images imported from DXF (30.96 KB, application/vnd.oasis.opendocument.text)
2014-10-29 19:28 UTC, antonio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description antonio 2014-10-29 19:28:25 UTC
Created attachment 108645 [details]
images imported from DXF

Writer 4.3.2 is very slow with images imported from DXF, this is not the case with the version 4.2.6 

I attach sample files
Comment 1 Alex Thurgood 2014-11-04 10:43:52 UTC
Confirming, regression

Even slower on master 440 alpha than 4331
Comment 2 Rostislav 'R.Yu.' Okulov 2014-12-29 13:01:23 UTC
git bisect log
git bisect start                                                                                                
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932                         
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00                                                                        
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e                          
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b                                                                                             
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb                                             
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574                                                                                            
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b                                              
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d                                                                                             
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681                                             
git bisect skip a043626b542eb8314218d7439534dce2fc325304                                                                                                            
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a                                                             
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6                                                                                                            
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a                                                             
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6                                                                                                            
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect good 1d4980621741d3050a5fe61b247c157d769988f2
# skip: [89110ca258fa7a15dfc546acfb39e76fc3eb2a44] source-hash-e450a2c506ac7cd4433b0f93fc750a89919bc03c
git bisect skip 89110ca258fa7a15dfc546acfb39e76fc3eb2a44
# good: [1cca92a409385d9288c28a54d5e3008e56728bc0] source-hash-7be7824bbbdeee6fa998b950e6046ab37fe690cb
git bisect good 1cca92a409385d9288c28a54d5e3008e56728bc0
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# good: [2a9ff869c5638dc5c3aa387d0fe55c3291c86288] source-hash-01b7e04172889cbc9e4ac404b105e18ddc062d6f
git bisect good 2a9ff869c5638dc5c3aa387d0fe55c3291c86288
# good: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect good 387dd1052972d27a3065a249b357e50e0a29829b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [09fe6d4400fefeaa099d0deb9b77c77992ab897b] source-hash-56364430108893afbcf5d2b51c5aaa37e393e7cc
git bisect good 09fe6d4400fefeaa099d0deb9b77c77992ab897b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [8aabf2aee6514311020b855a95a6e44bab3a5b0d] source-hash-0aa9ced531b8d85ad067c1d156a9708eea628d78
git bisect bad 8aabf2aee6514311020b855a95a6e44bab3a5b0d
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [11ac44b0fb233f1f98e2f083598f6720a04e457f] source-hash-3c01203ea657b9a3538f9956591b3d4da5fce6e7
git bisect good 11ac44b0fb233f1f98e2f083598f6720a04e457f
# first bad commit: [8aabf2aee6514311020b855a95a6e44bab3a5b0d] source-hash-0aa9ced531b8d85ad067c1d156a9708eea628d78

8aabf2aee6514311020b855a95a6e44bab3a5b0d is the first bad commit
commit 8aabf2aee6514311020b855a95a6e44bab3a5b0d
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Nov 27 09:32:23 2013 +0000

    source-hash-0aa9ced531b8d85ad067c1d156a9708eea628d78
    
    commit 0aa9ced531b8d85ad067c1d156a9708eea628d78
    Author:     Tor Lillqvist <tml@collabora.com>
    AuthorDate: Wed Nov 6 00:43:06 2013 +0200
    Commit:     Tor Lillqvist <tml@collabora.com>
    CommitDate: Wed Nov 6 00:44:28 2013 +0200
    
        It's types.rdb now, not udkapi.rdb any more
    
        Change-Id: If6e8c4862ec628eb4c052e0fd237f5aef89db8eb

:100644 100644 ce5cd8dc3c3a6fdc22ae8e4f63897ab07254eddb 867d2798c91ad285850e29c0e8d0f40548dff4fb M      ccache.log
:100644 100644 405359894d6958b64eb7f2beb6f8a48550779f95 e461af99260d551289a2dd1f188119438cf1fc19 M      commitmsg
:100644 100644 0c7b842ac949f66eaa350d1ac25b0d6ccc407841 ab6adaea7a96b5d6d10dda3f10504fd1f005cfcf M      make.log
:040000 040000 216184b3333359e5a1395b47d1551dd3b61d2f04 d765efa8f9bd443222a2a557954f9dd4997fd3e7 M      opt
Comment 3 Matthew Francis 2015-01-11 11:48:29 UTC
(* The symptoms are slightly different but this may be a duplicate of bug 86798 - they share a connection with images, but differ in that 86798 also has a problem with text selection)

The behaviour seems to have changed as of the below commit.

Adding Cc: to caolanm@redhat.com. Could you possibly take a look at this? Thanks


commit 2e5167528f7566dd9b000e50fc1610b7bf99132a
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Thu Oct 31 14:43:21 2013 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Tue Nov 5 15:24:18 2013 +0000

    Resolves: #i123500# unified Graphic processing to use GraphicPrimitive2D
    
    (cherry picked from commit f5d69b2b8b002ca6905496a9d9065ef76b5641d7)
Comment 4 antonio 2015-11-30 08:18:39 UTC
the problem also appears in the version 5.1 beta 1, nobody is responsible for this bug?
Comment 5 Robinson Tryon (qubit) 2015-12-13 11:11:06 UTC Comment hidden (obsolete)
Comment 6 Aron Budea 2016-08-25 12:41:37 UTC
I tested in Windows 7, v5.1.0 was slow, but v5.1.5 and v5.2.0 seem to be fine.
Please check again with those versions.
Comment 7 antonio 2016-08-25 14:14:27 UTC
Yes
It also works faster on Mac OS X 10.11 and LibreOffice 5.2.
But unfortunately in my case I can not use the version 5.2 casusa of another bug that prevents OSX to recognize java
Comment 8 Aron Budea 2016-08-25 22:50:32 UTC
How about v5.1.5?
Is the Java-related bug reported somewhere?