Bug 85654 - FILESAVE: Consolidate don't properly save 'Consolidation ranges' after closing.
Summary: FILESAVE: Consolidate don't properly save 'Consolidation ranges' after closing.
Status: RESOLVED DUPLICATE of bug 45862
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-30 15:14 UTC by Jens S
Modified: 2015-04-16 15:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple sheet with 3 sheets consolidated in the 4th. (26.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-30 15:14 UTC, Jens S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens S 2014-10-30 15:14:35 UTC
Created attachment 108695 [details]
Simple sheet with 3 sheets consolidated in the 4th.

As I have learned about consolidation - it is a method of summarizing more sheets with a similar structure. You can see the definition in Wikipedea. A pivot-table only takes one source-table, but consolidate can take several tables.
In the attached file there are 3 sheets with a Name-column and a Payed-column  - all summed up in 4. sheet. 
1. Select Data - Consolidate...
2. Select range A1:B20 in sheet 1 and Add this to consolidation range.
3. Do the same with sheet 2 and 3 and remember adding the range to the consolidation range
4. Copy the result to: Select A1 in sheet 4 
5. Mark both Row- and Column-labels.
It should look like this https://www.dropbox.com/s/h98a58ika7r6bnk/Sk%C3%A6rmbillede%202014-10-30%2013.17.57.png?dl=0
After creating the consolidated table, save the file and close.

Now open the file again and select Data - Consolidate. Only one of the sheets range are saved - the 2 other has disappeared. Like this https://www.dropbox.com/s/gexgg6e2mefi19l/Sk%C3%A6rmbillede%202014-10-30%2013.20.14.png?dl=0

More about this Consolidate: 
Number format in column 2 in sheet 4 is totally ignored?
If you use 'Link to source data' - empty cells in column 2/sheet 1 to 3 gives a empty cell in sheet 4. This should be updated in the consolidated table if you add some values in the source tables.
It would really be nice if you could select external sheets to consolidation ranges.

I use Windows 8.1 and tested with
LibreOffice 4.3.1.2 and 4.4.0
Apache OpenOffice 4.1.1
Comment 1 m.a.riosv 2014-10-31 00:05:27 UTC
Hi @Jens, thanks for reporting.

It's a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=45862, but unfortunately without solution for now.

What I have done is used matrix ranges to put all data in one sheet and use consolidate on it, but they are only three ranges in my case.

*** This bug has been marked as a duplicate of bug 45862 ***