Bug 85690 - Modification of X-Axis set Y-Axis Auto scaling from 0
Summary: Modification of X-Axis set Y-Axis Auto scaling from 0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 87067 95749 97267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-31 09:51 UTC by Mike Ratcliffe
Modified: 2016-01-22 09:17 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Ratcliffe 2014-10-31 09:51:17 UTC
STR:
1. Create a line chart with default settings.
2. Double-click the X-Axis.
3. In the Label tab set the text direction to 270 degrees.

The Y-Axis auto scaling will suddenly default to starting at zero or lower.
Comment 1 raal 2014-10-31 18:01:44 UTC
I can reproduce with Version: 4.4.0.0.alpha1+
Build ID: 04ea7b24ec1b5a027efa0b850f2bc3ac7116c52e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-10-25_08:38:01

I can reproduce with Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Unable to reproduce with LO 4.2.6.3, regression
Comment 2 raal 2014-11-02 06:17:56 UTC
git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# good: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect good c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect good c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# good: [30cde618212ecaf5725321372bd1b8339f8e2b9f] source-hash-137f872aa8e6e598e7c7ed1ffa4d21e580e22bdb
git bisect good 30cde618212ecaf5725321372bd1b8339f8e2b9f
# good: [306d62ec4b911895f08f2bb8efefebed7ac795f0] source-hash-735bd120c9ee2d9bb3514907936c27efb75d7282
git bisect good 306d62ec4b911895f08f2bb8efefebed7ac795f0
# skip: [18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf] source-hash-fe506f34f2dccb6562935fe4dfbc1fe6d609dec8
git bisect skip 18ee045c7e35e5ae98cffaafd56fb6fb37d7afcf
# bad: [2a3d9160aa946746b49f306e4f8cc5ddcd27d922] source-hash-cff891fc44adcca745bcaa9ae95483bd63aa05ae
git bisect bad 2a3d9160aa946746b49f306e4f8cc5ddcd27d922
# good: [4eb237e9340cbc4e207bf2321b99d090b0e928a3] source-hash-a85d10e0c1a0f79fc807007dbd49975f35f218fe
git bisect good 4eb237e9340cbc4e207bf2321b99d090b0e928a3
# first bad commit: [2a3d9160aa946746b49f306e4f8cc5ddcd27d922] source-hash-cff891fc44adcca745bcaa9ae95483bd63aa05ae

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=a85d10e0c1a0f79fc807007dbd49975f35f218fe..cff891fc44adcca745bcaa9ae95483bd63aa05ae
Comment 3 Matthew Francis 2015-01-18 14:25:54 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to sushilshinde@libreoffice.org; Could you possibly have a look at this? Thanks


commit a70dfc34a67e9fb240cc70853da0c49fa01c2e4f
Author: sushil_shinde <sushil.shinde@synerzip.com>
Date:   Mon Dec 9 12:27:40 2013 +0530

    fdo#72306 Axis names were lost after saving file on LO.
    
      While exporting chart "crosses" position values were
      not handled properly in chartexport.
      Fixed this issue by handling "autozero" value for c:crosses.
      Added unit test.
    
    Change-Id: I3489908d4c3d4b41a04debfecf95e65f373649ce
Comment 4 Sushil Shinde 2015-01-19 05:59:46 UTC
(In reply to Matthew Francis from comment #3)
> The behaviour seems to have changed as of the below commit.
> 
> Adding Cc: to sushilshinde@libreoffice.org; Could you possibly have a look
> at this? Thanks
> 
> 
> commit a70dfc34a67e9fb240cc70853da0c49fa01c2e4f
> Author: sushil_shinde <sushil.shinde@synerzip.com>
> Date:   Mon Dec 9 12:27:40 2013 +0530
> 
>     fdo#72306 Axis names were lost after saving file on LO.
>     
>       While exporting chart "crosses" position values were
>       not handled properly in chartexport.
>       Fixed this issue by handling "autozero" value for c:crosses.
>       Added unit test.
>     
>     Change-Id: I3489908d4c3d4b41a04debfecf95e65f373649ce

Okey.. I will check.
Comment 5 Markus Mohrhard 2015-02-23 21:29:24 UTC
(In reply to Matthew Francis from comment #3)
> The behaviour seems to have changed as of the below commit.
> 
> Adding Cc: to sushilshinde@libreoffice.org; Could you possibly have a look
> at this? Thanks
> 
> 
> commit a70dfc34a67e9fb240cc70853da0c49fa01c2e4f
> Author: sushil_shinde <sushil.shinde@synerzip.com>
> Date:   Mon Dec 9 12:27:40 2013 +0530
> 
>     fdo#72306 Axis names were lost after saving file on LO.
>     
>       While exporting chart "crosses" position values were
>       not handled properly in chartexport.
>       Fixed this issue by handling "autozero" value for c:crosses.
>       Added unit test.
>     
>     Change-Id: I3489908d4c3d4b41a04debfecf95e65f373649ce

There is an error on your side. That commit is a pure import/export commit and does not cause this issue.
Comment 6 Matthew Francis 2015-02-24 00:21:18 UTC
I will re-check
Comment 7 Robinson Tryon (qubit) 2015-12-13 11:11:05 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 8 Laurent BP 2016-01-02 17:23:26 UTC
*** Bug 95749 has been marked as a duplicate of this bug. ***
Comment 9 Laurent BP 2016-01-02 17:24:33 UTC
*** Bug 87067 has been marked as a duplicate of this bug. ***
Comment 10 Laurent BP 2016-01-02 18:29:21 UTC
NOT reproduce with LibO
- Version: 4.2.7.2
Build ID: 933c0aa564ec4f8883ed5732c866db48dca4dac5
- Version: 4.2.8.0.0+
Build ID: 970f4c775b47d09d26469f6cd304a19ad44731f7
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-10-24_04:33:09
- Version: 4.3.0.0.alpha0+
Build ID: 65e6d651ceef55f569521a4f4e609f7e5e88847b
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2013-12-18_23:26:17

Reproduce with
- Version: 4.3.0.0.alpha0+
Build ID: e625d00439f725b01f3818859e95e431e6173d57
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2014-01-03_00:43:24

It confirms previously bibisected range, but in this range, only 3 commits modified something in chart2
http://cgit.freedesktop.org/libreoffice/core/log/chart2/?qt=range&q=a85d10e0c1a0f79fc807007dbd49975f35f218fe..cff891fc44adcca745bcaa9ae95483bd63aa05ae
First and last deals only with qa, and second one adds only some properties...


Same behavior whatever modification of X axis is. See duplicate bug 95749 and bug 87067. I changed Summary.
Comment 11 Laurent BP 2016-01-20 11:42:08 UTC
Fixed with resolution of bug 96807
Comment 12 Laurent BP 2016-01-20 11:42:35 UTC
*** Bug 97267 has been marked as a duplicate of this bug. ***
Comment 13 Adolfo Jayme 2016-01-22 09:17:53 UTC
Closing per comment 11. Assuming it wasn’t done earlier due to lack of enough Bugzilla permissions…