Bug 97267 - Chart: Automatic scale minimum always at cero
Summary: Chart: Automatic scale minimum always at cero
Status: RESOLVED DUPLICATE of bug 85690
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-20 03:50 UTC by rodhos92
Modified: 2016-01-20 11:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of the problem (30.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-20 04:03 UTC, rodhos92
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rodhos92 2016-01-20 03:50:07 UTC
For a Chart in Calc: When the automatic scale is active the minimum value is always cero even if there is no data near cero making difficult to visualize the data and resulting on disabling the automatic scaling most of the times making the feature useless.

Steps to reproduce:

1. Plot some data without values near to cero.
2. Double click the Chart
3. Click one of the axis buttons on the top
4. Go to Scale tab.
5. Realise that the automatic scale is active and the value for the minimum is cero.

What do I spect: The data scale properly when the automatic scale is active.

What happens: The value for minimum is always cero.
Comment 1 rodhos92 2016-01-20 03:53:38 UTC
The Chart type must be XY(scatter).
Comment 2 rodhos92 2016-01-20 04:03:03 UTC
Ok, I realised it only happens if you previously marked "Reverse direction" for the other axis.
Comment 3 rodhos92 2016-01-20 04:03:59 UTC
Created attachment 122109 [details]
Example of the problem
Comment 4 Jean-Baptiste Faure 2016-01-20 08:40:18 UTC
It is a duplicate of bug 96807 which is fixed in the RC2 of LO 5.1.0 (currently in testing phase).

Best regards. JBF

*** This bug has been marked as a duplicate of bug 96807 ***
Comment 5 Laurent BP 2016-01-20 11:42:35 UTC
It is more precisely a duplicate of bug 85690 which deals with linear scale.

Both bug 96807 and bug 85690 are fixed with commit indicated in bug 96807

*** This bug has been marked as a duplicate of bug 85690 ***