Bug 85693 - TANGO: Save and save as icons
Summary: TANGO: Save and save as icons
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2014-10-31 10:15 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-05-18 22:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-31 10:15:47 UTC
In master, the save and save as icons have been changed from their previous blue color to purple.

https://redmine.documentfoundation.org/attachments/download/326/tango%20save%204_4%20vs%204_3.png

Unfortunately the new purple icons are not as clear as the old ones. I had asked libreoffice users on twitter and on the IRC and they all unanimously agree the same.

As i was informed that Mirek is the one who designed it, please advice a suitable course of action.
Comment 1 A (Andy) 2014-10-31 22:26:11 UTC
My Opinion:
The new purple icons seem to be a little bit more blurry.  I would agree with this, but it is perhaps not very severe.  But as Jay says, I would agree maybe  it can be improved a little bit more to be clearer?  
I suppose the blurry impression comes from the fact that in the purple icons the contrast is not that strong as in the blue ones.  For this you have to look at the border of the purple icon.  In the blue icon the color is getting darker to the border while in the purple icon it is getting brighter.  To see this you have to zoom into the attachment: e.g. open the link from the description in your Browser and then use the zoom function of the Browser.
Comment 2 A (Andy) 2014-10-31 22:30:20 UTC
@Jay: You already improved several icons/UI things, would you already have a proposal?  Do you want to suggest an improvement for discussion?
Comment 3 Yousuf Philips (jay) (retired) 2014-10-31 23:25:27 UTC
(In reply to A (Andy) from comment #2)
> @Jay: You already improved several icons/UI things, would you already have a
> proposal?  Do you want to suggest an improvement for discussion?

Well i had proposed that the old ones be brought back because the new ones arent as clear and they aren't from the original tango or gnome tango icon sets, which means that we would also need to create a 32x32 icon for the extra large icon set.

Adolfo didnt agree with this change in a commit i had made, so i opened this bug for the discussion to go on about it and get input from mirek about it.
Comment 4 Adolfo Jayme Barrientos 2014-11-01 08:55:36 UTC
(In reply to Jay Philips from comment #3)
> Well i had proposed that the old ones be brought back
> Adolfo didnt agree with this change in a commit i had made

For the record: I don’t believe on reversions as constructive contributions. It just frustrates people who tried to make improvements in the first place.

Also: I’m not colorblind, and I guess most of you aren’t as well, how can we evaluate this new color isn’t “as clear”? Or is that statement based just on the subtler contrast in the icon’s edges?

To get real user feedback we need to actually ship the new icon.

And I’m not saying the new icon is perfect and can’t be improved further, of course!
Comment 5 Yousuf Philips (jay) (retired) 2014-11-01 10:04:58 UTC
(In reply to Adolfo Jayme from comment #4)
> For the record: I don’t believe on reversions as constructive contributions.
> It just frustrates people who tried to make improvements in the first place.

Yes i was hasty with the change and i apologize to Mirek for not speaking to him first about the it and should have inquired who made the change.

> Also: I’m not colorblind, and I guess most of you aren’t as well, how can we
> evaluate this new color isn’t “as clear”? Or is that statement based just on
> the subtler contrast in the icon’s edges?

I believe the purple is to dark and doubt any floppy in our days was that color. There is also less clarity in the melt slider part because a gradient was used on its stroke rather than a solid color. Also the bottom part is blurry and you cant see a solid stroke color around the entire floppy, as can be found in the blue one.

> To get real user feedback we need to actually ship the new icon.

We do not need to ship the icon to get feedback. We have a design team and libreoffice users we can get feedback from before shipping.

> And I’m not saying the new icon is perfect and can’t be improved further, of
> course!

Well i would be best to replace something which is good with something that is better whenever its ready.
Comment 6 A (Andy) 2014-11-01 10:15:09 UTC
My View:
If I read your posts I suppose you had already some (for me unknown) discussions about this.  I as a normal user am very happy that there are more and more UI improvements, though maybe some of them are more incremental and I would like to see/assess them also in a broader strategy/context, but I like them and thank you both and the others for this/their work.  I saw that you both made several improvements for LO 4.4 and therefore, I am very much looking forward to see LO 4.4.  Mirek (as far as I know the new purple proposal is from him?) also made further nice improvements in the past and suggestions for further improvements, if I follow the Design/Whiteboard, where I hope to see some of them as final versions in LO in the future, if not already there.

The here mentioned old blue Save buttons could also have an improvement/refresh because for me they look a little bit old-fashioned.  The new purple colour version is interesting, but of course is also a matter of taste … some will like them, maybe some not … Of course you could also make a poll.  From my point of view one could give them a real try, but I personally would prefer if they could maybe improved a little bit to be a bit less blurry, if possible (@Adolfo: for me at the icon's edges, @Mirek: What do you think?, I have unfortunately no graphical design skills), because it would be sad if users would maybe only not like them, because maybe some of them view them as a little bit blurry, because I think they are an interesting new improvement proposal.  Therefore as Jay mentions, maybe we wait a little bit with the new Save buttons for further feedbacks?
@Jay and Mirek: Maybe you can discuss this a little bit more together and make a further joint proposal?

But as mentioned due to missing graphical skills I could not make any own proposals/contributions and can only comment it as a user.  Maybe, we will also get some further responses from other users what they think about this.
Comment 7 Tin Man 2014-11-01 11:37:37 UTC
Hi Jay,
The new icon is based on the floppy icon from Gnome, though tweaked a bit to distinguish it from the actual floppy icon: https://github.com/GNOME/gnome-icon-theme/blob/master/src/media-floppy.svg
I made the metal cover a bit darker in https://github.com/libodesign/icons/blob/master/saveexport.svg -- you're welcome to propose further changes if you'd like.

(As for the 32x32 icon set, as I said before, we don't need it and it would take too much effort to make and support.)

(In reply to Jay Philips from comment #0)
> In master, the save and save as icons have been changed from their previous
> blue color to purple.
> 
> https://redmine.documentfoundation.org/attachments/download/326/
> tango%20save%204_4%20vs%204_3.png
> 
> Unfortunately the new purple icons are not as clear as the old ones. I had
> asked libreoffice users on twitter and on the IRC and they all unanimously
> agree the same.
> 
> As i was informed that Mirek is the one who designed it, please advice a
> suitable course of action.
Comment 8 Yousuf Philips (jay) (retired) 2014-11-01 17:27:42 UTC
(In reply to Mirek2 from comment #7)
> Hi Jay,

Hi Mirek,

> The new icon is based on the floppy icon from Gnome, though tweaked a bit to
> distinguish it from the actual floppy icon:
> https://github.com/GNOME/gnome-icon-theme/blob/master/src/media-floppy.svg

Thanks for the info, as i thought you may have create it from scratch as i had looked through the gnome tango icons before and only looked at their save and save as icons.

Was there a reason why you didnt use the icon directly, as most of the gnome tango icons were taken as is, and the black floppy is quite nice and is an actual color of a real floppy. Also was there a reason for not keeping the original tango floppy, as i still find it clearer to see than the gnome black floppy.

> I made the metal cover a bit darker in
> https://github.com/libodesign/icons/blob/master/saveexport.svg -- you're
> welcome to propose further changes if you'd like.

Well i'd leave that to the real inkscape designers on the team, like Alex and Matthias, as i'm still an amateur. :D Hopefully you can give them suitable pointers to make it look better.
Comment 9 Yousuf Philips (jay) (retired) 2014-11-01 18:03:47 UTC
Hi Andy,

(In reply to A (Andy) from comment #6)
> My View:
> If I read your posts I suppose you had already some (for me unknown)
> discussions about this.  I as a normal user am very happy that there are
> more and more UI improvements, though maybe some of them are more
> incremental and I would like to see/assess them also in a broader
> strategy/context, but I like them and thank you both and the others for
> this/their work.  I saw that you both made several improvements for LO 4.4
> and therefore, I am very much looking forward to see LO 4.4.  Mirek (as far
> as I know the new purple proposal is from him?) also made further nice
> improvements in the past and suggestions for further improvements, if I
> follow the Design/Whiteboard, where I hope to see some of them as final
> versions in LO in the future, if not already there.

I'm delighted to have been able to use my skills to help make LO 4.4 better, though most of it will be limited to writer and impress.

> The here mentioned old blue Save buttons could also have an
> improvement/refresh because for me they look a little bit old-fashioned. 
> The new purple colour version is interesting, but of course is also a matter
> of taste … some will like them, maybe some not … Of course you could also
> make a poll.

I had run a poll asking users in the QA and design team as well as libreoffice users on twitter and unfortunately none of the 10 users preferred the new purple icons.

> From my point of view one could give them a real try, but I
> personally would prefer if they could maybe improved a little bit to be a
> bit less blurry, if possible (@Adolfo: for me at the icon's edges, @Mirek:
> What do you think?, I have unfortunately no graphical design skills),
> because it would be sad if users would maybe only not like them, because
> maybe some of them view them as a little bit blurry, because I think they
> are an interesting new improvement proposal.  Therefore as Jay mentions,
> maybe we wait a little bit with the new Save buttons for further feedbacks?
> @Jay and Mirek: Maybe you can discuss this a little bit more together and
> make a further joint proposal?

Presently, i'll leave it up to Mirek and the other inkscape designers to work on its improvement, as we do have two alternative choices to fall back on.

> But as mentioned due to missing graphical skills I could not make any own
> proposals/contributions and can only comment it as a user.  Maybe, we will
> also get some further responses from other users what they think about this.

I'll be discussing the issue further in next wednesday's design team meeting.
Comment 10 Tin Man 2014-11-01 18:23:26 UTC
(In reply to Jay Philips from comment #8)
> (In reply to Mirek2 from comment #7)
> > Hi Jay,
> 
> Hi Mirek,
> 
> > The new icon is based on the floppy icon from Gnome, though tweaked a bit to
> > distinguish it from the actual floppy icon:
> > https://github.com/GNOME/gnome-icon-theme/blob/master/src/media-floppy.svg
> 
> Thanks for the info, as i thought you may have create it from scratch as i
> had looked through the gnome tango icons before and only looked at their
> save and save as icons.
> 
> Was there a reason why you didnt use the icon directly, as most of the gnome
> tango icons were taken as is, and the black floppy is quite nice and is an
> actual color of a real floppy.

The intention was to have something that looks distinct from the Gnome floppy icon. A single icon should never be used for two completely different things.

> Also was there a reason for not keeping the
> original tango floppy, as i still find it clearer to see than the gnome
> black floppy.

It doesn't fit in with the new icon set (and it looks outdated).

> > I made the metal cover a bit darker in
> > https://github.com/libodesign/icons/blob/master/saveexport.svg -- you're
> > welcome to propose further changes if you'd like.
> 
> Well i'd leave that to the real inkscape designers on the team, like Alex
> and Matthias, as i'm still an amateur. :D Hopefully you can give them
> suitable pointers to make it look better.

I just asked Alex if he'll maintain it.
Comment 11 Yousuf Philips (jay) (retired) 2014-11-01 19:43:13 UTC
(In reply to Mirek2 from comment #10)
> > Was there a reason why you didnt use the icon directly, as most of the gnome
> > tango icons were taken as is, and the black floppy is quite nice and is an
> > actual color of a real floppy.
> 
> The intention was to have something that looks distinct from the Gnome
> floppy icon. A single icon should never be used for two completely different
> things.

So you mean that gnome is using it as a floppy icon, so we shouldnt use the same one as a save and save as icon. I dont see the problem in this as most of libreoffice's users are not gnome users and most computers these days dont have floppy drives, so most people wouldnt see a floppy icon in gnome as well.

> > Also was there a reason for not keeping the
> > original tango floppy, as i still find it clearer to see than the gnome
> > black floppy.
> 
> It doesn't fit in with the new icon set (and it looks outdated).

I think the blue fits in better than the purple if you see the icons in the standard and formatting toolbars. You have blue in quite a number of icons, while you have no purple in any. About it looking outdated, with icons at 16x16 and 24x24, users can barely see the level of detail being put into these svg icons which result in them looking blurry and unclear, so the simpler the design, the easier it is for users to see. This is one of the problems i see plaguing the gnome tango icons at such small icon sizes.

https://redmine.documentfoundation.org/attachments/download/325/tango%20formatting.png

> > Well i'd leave that to the real inkscape designers on the team, like Alex
> > and Matthias, as i'm still an amateur. :D Hopefully you can give them
> > suitable pointers to make it look better.
> 
> I just asked Alex if he'll maintain it.

Look forward to see what he comes up with.
Comment 12 Tin Man 2014-11-01 21:32:05 UTC
(In reply to Jay Philips from comment #11)
> (In reply to Mirek2 from comment #10)
> > > Was there a reason why you didnt use the icon directly, as most of the gnome
> > > tango icons were taken as is, and the black floppy is quite nice and is an
> > > actual color of a real floppy.
> > 
> > The intention was to have something that looks distinct from the Gnome
> > floppy icon. A single icon should never be used for two completely different
> > things.
> 
> So you mean that gnome is using it as a floppy icon, so we shouldnt use the
> same one as a save and save as icon. I dont see the problem in this as most
> of libreoffice's users are not gnome users and most computers these days
> dont have floppy drives, so most people wouldnt see a floppy icon in gnome
> as well.

Gnome icons are used well beyond Gnome, so not just Gnome users would be affected.

Even if floppy disks aren't generally used, it's simply good practice to not reuse the same icon for different meanings. You never know where the floppy icon might pop up -- e.g. it could be used as part of a generic "removable devices" icon, and there it really should be clear that it's meant to represent a floppy, that it's not an icon meaning "save to a device".

> > > Also was there a reason for not keeping the
> > > original tango floppy, as i still find it clearer to see than the gnome
> > > black floppy.
> > 
> > It doesn't fit in with the new icon set (and it looks outdated).
> 
> I think the blue fits in better than the purple if you see the icons in the
> standard and formatting toolbars. You have blue in quite a number of icons,
> while you have no purple in any.

We could make it blue.

The overuse of blue was why I chose purple, though. If we're going to have colored icons, it's useful to associate those colors with something -- that speeds the user up! Right now, black stands for text or lines, blue for selection, highlight, or shape, orange for transformations (moving, resizing, rotating, etc.), red for help or error, yellow for comments and highlighting, etc. Purple is underused, and it could be associated with saving.

> About it looking outdated, with icons at
> 16x16 and 24x24, users can barely see the level of detail being put into
> these svg icons which result in them looking blurry and unclear, so the
> simpler the design, the easier it is for users to see. This is one of the
> problems i see plaguing the gnome tango icons at such small icon sizes.
>
> https://redmine.documentfoundation.org/attachments/download/325/
> tango%20formatting.png
> 

These icons were designed for these icon sizes, and by people who had years of experience designing icons. (In fact, some of the very people who worked on the original base Tango set.) The level of detail is just right as far as Tango icons go -- that is, these icons have to work on both dark and light backgrounds, have the prescribed lighting and shadows, and so on, and that makes them a bit complex. That's why there's symbolic/Sifr.
Comment 13 Yousuf Philips (jay) (retired) 2014-11-02 00:42:36 UTC
(In reply to Mirek2 from comment #12)
> > So you mean that gnome is using it as a floppy icon, so we shouldnt use the
> > same one as a save and save as icon. I dont see the problem in this as most
> > of libreoffice's users are not gnome users and most computers these days
> > dont have floppy drives, so most people wouldnt see a floppy icon in gnome
> > as well.
> 
> Gnome icons are used well beyond Gnome, so not just Gnome users would be
> affected.

Please enlighten me, as i dont see Gnome icons used on Windows, OSX or Ubuntu. :D

> Even if floppy disks aren't generally used, it's simply good practice to not
> reuse the same icon for different meanings. You never know where the floppy
> icon might pop up -- e.g. it could be used as part of a generic "removable
> devices" icon, and there it really should be clear that it's meant to
> represent a floppy, that it's not an icon meaning "save to a device".

Yes it would be more practical to use all unique icons, but see the likelihood of the floppy icon appearing on a user's OS and LO's toolbar being very slim, that wouldnt warrant us having to change the icon. I see that as long as LO doesnt use the same icon twice to mean two different things, we use the icon to represent what we want in the app.

> > I think the blue fits in better than the purple if you see the icons in the
> > standard and formatting toolbars. You have blue in quite a number of icons,
> > while you have no purple in any.
> 
> We could make it blue.

Look forward to seeing what Alex whips up.

> The overuse of blue was why I chose purple, though. If we're going to have
> colored icons, it's useful to associate those colors with something -- that
> speeds the user up! Right now, black stands for text or lines, blue for
> selection, highlight, or shape, orange for transformations (moving,
> resizing, rotating, etc.), red for help or error, yellow for comments and
> highlighting, etc. Purple is underused, and it could be associated with
> saving.

Yes i can see how the unique purple color could be associated exclusively with saving, but as no purple floppy disks were created, having an object in a color it is never know to be colored in doesnt work that well.

> > About it looking outdated, with icons at
> > 16x16 and 24x24, users can barely see the level of detail being put into
> > these svg icons which result in them looking blurry and unclear, so the
> > simpler the design, the easier it is for users to see. This is one of the
> > problems i see plaguing the gnome tango icons at such small icon sizes.
> >
> > https://redmine.documentfoundation.org/attachments/download/325/
> > tango%20formatting.png
> > 
> 
> These icons were designed for these icon sizes, and by people who had years
> of experience designing icons. (In fact, some of the very people who worked
> on the original base Tango set.) The level of detail is just right as far as
> Tango icons go -- that is, these icons have to work on both dark and light
> backgrounds, have the prescribed lighting and shadows, and so on, and that
> makes them a bit complex. That's why there's symbolic/Sifr.

They had designed these icons at 5 different icon sizes knowing that users would be having various screen resolutions that these icons can be shown. But as LO only has 16x16 and 24x24, these icons do look small and sometimes unclear on most screen available these days. I personally love the gnome tango icons at 32x32 or 48x48 at my screen resolution (1440x900), but the 24x24 icons look blurry due to the gradients on the stroke and glossy effect found on the character based icons.
Comment 14 Tin Man 2014-11-02 10:15:20 UTC
(In reply to Jay Philips from comment #13)
> (In reply to Mirek2 from comment #12)
> > > So you mean that gnome is using it as a floppy icon, so we shouldnt use the
> > > same one as a save and save as icon. I dont see the problem in this as most
> > > of libreoffice's users are not gnome users and most computers these days
> > > dont have floppy drives, so most people wouldnt see a floppy icon in gnome
> > > as well.
> > 
> > Gnome icons are used well beyond Gnome, so not just Gnome users would be
> > affected.
> 
> Please enlighten me, as i dont see Gnome icons used on Windows, OSX or
> Ubuntu. :D
> 

Well, Ubuntu's icon theme is based on elementary, and neither has the same amount of icons as Gnome and both seem to use Gnome as a "fallback", so some Gnome icons seep through. For example: http://blogs.gnome.org/jnelson/files/2012/05/geary-screenshot-2.png (the font and paragraph icons are Gnome's).

And there are various pieces of software that use Gnome's icons on other platforms -- https://documenteditor.codeplex.com/ , for example.

> > Even if floppy disks aren't generally used, it's simply good practice to not
> > reuse the same icon for different meanings. You never know where the floppy
> > icon might pop up -- e.g. it could be used as part of a generic "removable
> > devices" icon, and there it really should be clear that it's meant to
> > represent a floppy, that it's not an icon meaning "save to a device".
> 
> Yes it would be more practical to use all unique icons, but see the
> likelihood of the floppy icon appearing on a user's OS and LO's toolbar
> being very slim, that wouldnt warrant us having to change the icon. I see
> that as long as LO doesnt use the same icon twice to mean two different
> things, we use the icon to represent what we want in the app.

No -- it's a slippery slope, really, I don't ever want to use the same icon to mean two completely different things.

> > > I think the blue fits in better than the purple if you see the icons in the
> > > standard and formatting toolbars. You have blue in quite a number of icons,
> > > while you have no purple in any.
> > 
> > We could make it blue.
> 
> Look forward to seeing what Alex whips up.
> 
> > The overuse of blue was why I chose purple, though. If we're going to have
> > colored icons, it's useful to associate those colors with something -- that
> > speeds the user up! Right now, black stands for text or lines, blue for
> > selection, highlight, or shape, orange for transformations (moving,
> > resizing, rotating, etc.), red for help or error, yellow for comments and
> > highlighting, etc. Purple is underused, and it could be associated with
> > saving.
> 
> Yes i can see how the unique purple color could be associated exclusively
> with saving, but as no purple floppy disks were created, having an object in
> a color it is never know to be colored in doesnt work that well.

Why? To me, it works well precisely because of that -- since there is no physical object of that color, a floppy disk of this color always means saving and never means the device. The save icon is recognized by shape, not by color.

Incidentally, Word 2007 and 2010 have purple save icons: http://i.stack.imgur.com/tPbpM.jpg . (This may have subconsciously inspired me, as I have used Office 2007.)

> > > About it looking outdated, with icons at
> > > 16x16 and 24x24, users can barely see the level of detail being put into
> > > these svg icons which result in them looking blurry and unclear, so the
> > > simpler the design, the easier it is for users to see. This is one of the
> > > problems i see plaguing the gnome tango icons at such small icon sizes.
> > >
> > > https://redmine.documentfoundation.org/attachments/download/325/
> > > tango%20formatting.png
> > > 
> > 
> > These icons were designed for these icon sizes, and by people who had years
> > of experience designing icons. (In fact, some of the very people who worked
> > on the original base Tango set.) The level of detail is just right as far as
> > Tango icons go -- that is, these icons have to work on both dark and light
> > backgrounds, have the prescribed lighting and shadows, and so on, and that
> > makes them a bit complex. That's why there's symbolic/Sifr.
> 
> They had designed these icons at 5 different icon sizes knowing that users
> would be having various screen resolutions that these icons can be shown.
> But as LO only has 16x16 and 24x24, these icons do look small and sometimes
> unclear on most screen available these days. I personally love the gnome
> tango icons at 32x32 or 48x48 at my screen resolution (1440x900), but the
> 24x24 icons look blurry due to the gradients on the stroke and glossy effect
> found on the character based icons.

These icons were designed specifically for 16x16 and 22x22 (we add a 1px margin), and all versions were designed for the same screen resolution. The other sizes are there for applications that use extra large icons in their toolbars or for use outside toolbars (dialogs, for example).
Comment 15 Yousuf Philips (jay) (retired) 2014-11-02 16:10:41 UTC
(In reply to Mirek2 from comment #14)
> > Please enlighten me, as i dont see Gnome icons used on Windows, OSX or
> > Ubuntu. :D
> > 
> 
> Well, Ubuntu's icon theme is based on elementary, and neither has the same
> amount of icons as Gnome and both seem to use Gnome as a "fallback", so some
> Gnome icons seep through. For example:
> http://blogs.gnome.org/jnelson/files/2012/05/geary-screenshot-2.png (the
> font and paragraph icons are Gnome's).

Yes i'm aware that Ubuntu's human icon theme is based on tango/gnome icons, so i guess some of gnomes those icons would appear to ubuntu users.

> And there are various pieces of software that use Gnome's icons on other
> platforms -- https://documenteditor.codeplex.com/ , for example.

Well gnome icons appearing in software will always happen, as the icons are open source. Document editor seems interesting with their 40x40 icons as well as modifying a number of the default gnome icons like numbering list.

> > Yes it would be more practical to use all unique icons, but see the
> > likelihood of the floppy icon appearing on a user's OS and LO's toolbar
> > being very slim, that wouldnt warrant us having to change the icon. I see
> > that as long as LO doesnt use the same icon twice to mean two different
> > things, we use the icon to represent what we want in the app.
> 
> No -- it's a slippery slope, really, I don't ever want to use the same icon
> to mean two completely different things.

Well lets see what Alex can come up with then.

> > Yes i can see how the unique purple color could be associated exclusively
> > with saving, but as no purple floppy disks were created, having an object in
> > a color it is never know to be colored in doesnt work that well.
> 
> Why? To me, it works well precisely because of that -- since there is no
> physical object of that color, a floppy disk of this color always means
> saving and never means the device. The save icon is recognized by shape, not
> by color.

Seems i was mistaken about there never being purple floppies, as my friend said he had some growing up ( http://us.123rf.com/400wm/400/400/fberti/fberti1104/fberti110400153/9320845-two-floppy-disk-3d-illustration.jpg ) and see through ones ( http://science.opposingviews.com/DM-Resize/photos.demandstudios.com/getty/article/176/133/AA039252.jpg?w=600&h=600&keep_ratio=1 ). Yes the save icon as a floppy is primarily known by the shape.

> Incidentally, Word 2007 and 2010 have purple save icons:
> http://i.stack.imgur.com/tPbpM.jpg . (This may have subconsciously inspired
> me, as I have used Office 2007.)

Though i have Word 2007, i add the save icon to the top bar, i never click on the office icon to have seen the purple there, but do use the MS snipping tool and see they are using the purple floppy icon there ( http://www.computerperformance.co.uk/images/Vista/snipping_tool.jpg ).

> > They had designed these icons at 5 different icon sizes knowing that users
> > would be having various screen resolutions that these icons can be shown.
> > But as LO only has 16x16 and 24x24, these icons do look small and sometimes
> > unclear on most screen available these days. I personally love the gnome
> > tango icons at 32x32 or 48x48 at my screen resolution (1440x900), but the
> > 24x24 icons look blurry due to the gradients on the stroke and glossy effect
> > found on the character based icons.
> 
> These icons were designed specifically for 16x16 and 22x22 (we add a 1px
> margin), and all versions were designed for the same screen resolution. The
> other sizes are there for applications that use extra large icons in their
> toolbars or for use outside toolbars (dialogs, for example).

Though designed at the same screen resolution, users see the icons at different screen resolutions. So when a user sees the 24x24 icons at 800x900, it is quite different from a user seeing the same icons at 1920x1080.

Well i think if we want to stick with the purple, we try to make it clearer, similar to ( http://www.jeffs-icons.com/System_Icons.html ) and the ones in ms office or ms snipping tool. Alternatively we could possibly go the save arrow on a folder approach like ( http://www.ulpanor.com/eton/include/images/download_icon.png ) and ( http://edwardevers.com/javascript/html5/common/images/save_icon.png ).
Comment 16 Tin Man 2014-11-02 19:41:07 UTC
(In reply to Jay Philips from comment #15)
> (In reply to Mirek2 from comment #14)
> > > Please enlighten me, as i dont see Gnome icons used on Windows, OSX or
> > > Ubuntu. :D
> > > 
> > 
> > Well, Ubuntu's icon theme is based on elementary, and neither has the same
> > amount of icons as Gnome and both seem to use Gnome as a "fallback", so some
> > Gnome icons seep through. For example:
> > http://blogs.gnome.org/jnelson/files/2012/05/geary-screenshot-2.png (the
> > font and paragraph icons are Gnome's).
> 
> Yes i'm aware that Ubuntu's human icon theme is based on tango/gnome icons,
> so i guess some of gnomes those icons would appear to ubuntu users.
> 
> > And there are various pieces of software that use Gnome's icons on other
> > platforms -- https://documenteditor.codeplex.com/ , for example.
> 
> Well gnome icons appearing in software will always happen, as the icons are
> open source. Document editor seems interesting with their 40x40 icons as
> well as modifying a number of the default gnome icons like numbering list.

The large icons are there because of the nature of the ribbon -- not really applicable in our case.

Gnome doesn't have its own ordered list icon -- the LibreOffice one was designed by me.

BTW, it'd be great to share our icons with projects like these. I'll ask someone from the Gnome team if they'd link to icon sets that extend theirs from their git repository.

> > > Yes it would be more practical to use all unique icons, but see the
> > > likelihood of the floppy icon appearing on a user's OS and LO's toolbar
> > > being very slim, that wouldnt warrant us having to change the icon. I see
> > > that as long as LO doesnt use the same icon twice to mean two different
> > > things, we use the icon to represent what we want in the app.
> > 
> > No -- it's a slippery slope, really, I don't ever want to use the same icon
> > to mean two completely different things.
> 
> Well lets see what Alex can come up with then.

Sounds good. :)

> > > Yes i can see how the unique purple color could be associated exclusively
> > > with saving, but as no purple floppy disks were created, having an object in
> > > a color it is never know to be colored in doesnt work that well.
> > 
> > Why? To me, it works well precisely because of that -- since there is no
> > physical object of that color, a floppy disk of this color always means
> > saving and never means the device. The save icon is recognized by shape, not
> > by color.
> 
> Seems i was mistaken about there never being purple floppies, as my friend
> said he had some growing up (
> http://us.123rf.com/400wm/400/400/fberti/fberti1104/fberti110400153/9320845-
> two-floppy-disk-3d-illustration.jpg ) and see through ones (
> http://science.opposingviews.com/DM-Resize/photos.demandstudios.com/getty/
> article/176/133/AA039252.jpg?w=600&h=600&keep_ratio=1 ). Yes the save icon
> as a floppy is primarily known by the shape.

OK, cool. :)

> > Incidentally, Word 2007 and 2010 have purple save icons:
> > http://i.stack.imgur.com/tPbpM.jpg . (This may have subconsciously inspired
> > me, as I have used Office 2007.)
> 
> Though i have Word 2007, i add the save icon to the top bar, i never click
> on the office icon to have seen the purple there, but do use the MS snipping
> tool and see they are using the purple floppy icon there (
> http://www.computerperformance.co.uk/images/Vista/snipping_tool.jpg ).

OK.
Would you be okay with purple, then? Its wide use could help with recognition.

> > > They had designed these icons at 5 different icon sizes knowing that users
> > > would be having various screen resolutions that these icons can be shown.
> > > But as LO only has 16x16 and 24x24, these icons do look small and sometimes
> > > unclear on most screen available these days. I personally love the gnome
> > > tango icons at 32x32 or 48x48 at my screen resolution (1440x900), but the
> > > 24x24 icons look blurry due to the gradients on the stroke and glossy effect
> > > found on the character based icons.
> > 
> > These icons were designed specifically for 16x16 and 22x22 (we add a 1px
> > margin), and all versions were designed for the same screen resolution. The
> > other sizes are there for applications that use extra large icons in their
> > toolbars or for use outside toolbars (dialogs, for example).
> 
> Though designed at the same screen resolution, users see the icons at
> different screen resolutions. So when a user sees the 24x24 icons at
> 800x900, it is quite different from a user seeing the same icons at
> 1920x1080.
> 
> Well i think if we want to stick with the purple, we try to make it clearer,
> similar to ( http://www.jeffs-icons.com/System_Icons.html ) and the ones in
> ms office or ms snipping tool. Alternatively we could possibly go the save
> arrow on a folder approach like (
> http://www.ulpanor.com/eton/include/images/download_icon.png ) and (
> http://edwardevers.com/javascript/html5/common/images/save_icon.png ).

OK, clearer sounds good, though I don't like the first example you pointed to. Microsoft's icons are great, though. :)

The actual Gnome save icon uses a green arrow symbol over a file cabinet, but it was rejected by the team after Bjorn Balazs's research showed it wasn't easily recognizable.
Comment 17 Yousuf Philips (jay) (retired) 2014-11-03 22:37:26 UTC
(In reply to Mirek2 from comment #16)
> > Well gnome icons appearing in software will always happen, as the icons are
> > open source. Document editor seems interesting with their 40x40 icons as
> > well as modifying a number of the default gnome icons like numbering list.
> 
> The large icons are there because of the nature of the ribbon -- not really
> applicable in our case.

Well i believe the ribbon could have been created with smaller icons, but microsoft chose to use 32x32 icons and above for icons which need more emphasis.

> Gnome doesn't have its own ordered list icon -- the LibreOffice one was
> designed by me.

Thanks for designing them. I'm currently modifying them and will have Alex create the svgs.

> BTW, it'd be great to share our icons with projects like these. I'll ask
> someone from the Gnome team if they'd link to icon sets that extend theirs
> from their git repository.

Yes it would be great to contribute something back to them in they are interested in having it, though i think they would also want larger sizes as well. :D

> > Though i have Word 2007, i add the save icon to the top bar, i never click
> > on the office icon to have seen the purple there, but do use the MS snipping
> > tool and see they are using the purple floppy icon there (
> > http://www.computerperformance.co.uk/images/Vista/snipping_tool.jpg ).
> 
> OK.
> Would you be okay with purple, then? Its wide use could help with
> recognition.

I'm fine with the purple as long as it clear. The funny thing is that microsoft used a black floppy in MS Office for Mac. :D

> > Well i think if we want to stick with the purple, we try to make it clearer,
> > similar to ( http://www.jeffs-icons.com/System_Icons.html ) and the ones in
> > ms office or ms snipping tool. Alternatively we could possibly go the save
> > arrow on a folder approach like (
> > http://www.ulpanor.com/eton/include/images/download_icon.png ) and (
> > http://edwardevers.com/javascript/html5/common/images/save_icon.png ).
> 
> OK, clearer sounds good, though I don't like the first example you pointed
> to. Microsoft's icons are great, though. :)

I liked the solid gray metal part as it stands out well against the purple. :D

> The actual Gnome save icon uses a green arrow symbol over a file cabinet,
> but it was rejected by the team after Bjorn Balazs's research showed it
> wasn't easily recognizable.

Yes i've seen the gnome save icons of the arrow in the cabinet and didnt think it was very understandable. Atleast original tango was using a hard disk. :D

Well about the save as icon, i think we should stick with the pencil, as that is what is used pretty much everywhere and we can pull the pencil from the find & replace icon and add it to the purple floppy.
Comment 18 Tin Man 2014-11-09 22:12:06 UTC
(In reply to Jay Philips from comment #17)
> (In reply to Mirek2 from comment #16)
> > > Well gnome icons appearing in software will always happen, as the icons are
> > > open source. Document editor seems interesting with their 40x40 icons as
> > > well as modifying a number of the default gnome icons like numbering list.
> > 
> > The large icons are there because of the nature of the ribbon -- not really
> > applicable in our case.
> 
> Well i believe the ribbon could have been created with smaller icons, but
> microsoft chose to use 32x32 icons and above for icons which need more
> emphasis.

Yes, size is used as a way to highlight more common functions.

Another reason for large icons is that the ribbon was also designed to scale. Large icons can become small ones with a small window, and a whole category of icons can collapse into one large icon (large, because there's one column per category and a small one wouldn't cover the height).
> 
> > Gnome doesn't have its own ordered list icon -- the LibreOffice one was
> > designed by me.
> 
> Thanks for designing them. I'm currently modifying them and will have Alex
> create the svgs.

OK. Be sure to test them on dark as well as bright backgrounds.
Out of all the icons I've worked on, I'm pretty happy with these, so... please be careful. :)

> 
> > BTW, it'd be great to share our icons with projects like these. I'll ask
> > someone from the Gnome team if they'd link to icon sets that extend theirs
> > from their git repository.
> 
> Yes it would be great to contribute something back to them in they are
> interested in having it, though i think they would also want larger sizes as
> well. :D

I didn't mean contributing back (the basic theme is just the right size now, IMHO, and covers the fdo specification well) -- I really meant just having a link inside a text file in their git repo, so people would have a place to look for additional icons. Our icon scheme doesn't use the same naming as Gnome's, it has a number of LibreOffice-specific icons, it'd be useless to create larger versions of many of those icons, and maintaining both the Gnome repo and our icons up-to-date and consistent would be unfeasible.

> > The actual Gnome save icon uses a green arrow symbol over a file cabinet,
> > but it was rejected by the team after Bjorn Balazs's research showed it
> > wasn't easily recognizable.
> 
> Yes i've seen the gnome save icons of the arrow in the cabinet and didnt
> think it was very understandable. Atleast original tango was using a hard
> disk. :D
> 
> Well about the save as icon, i think we should stick with the pencil, as
> that is what is used pretty much everywhere and we can pull the pencil from
> the find & replace icon and add it to the purple floppy.

OK, pencil sounds good.
Comment 19 Yousuf Philips (jay) (retired) 2014-11-15 19:55:15 UTC
(In reply to Mirek2 from comment #18)
> > Well i believe the ribbon could have been created with smaller icons, but
> > microsoft chose to use 32x32 icons and above for icons which need more
> > emphasis.
> 
> Yes, size is used as a way to highlight more common functions.
> 
> Another reason for large icons is that the ribbon was also designed to
> scale. Large icons can become small ones with a small window, and a whole
> category of icons can collapse into one large icon (large, because there's
> one column per category and a small one wouldn't cover the height).

Yes i had noticed the interesting behaviour before when i took a screenshot at both 1024x768 and 1280x800 and saw that they hid the cut, copy and format painter labels. I think this might be an interesting idea to try and implement in our toolbars, by temporarily hiding some of the lesser used buttons when the size is shrunk.

> > Thanks for designing them. I'm currently modifying them and will have Alex
> > create the svgs.
> 
> OK. Be sure to test them on dark as well as bright backgrounds.
> Out of all the icons I've worked on, I'm pretty happy with these, so...
> please be careful. :)

Well i primarily just stretched the lines part and enlarged the bullet character and changed the roman numeral numbering to digits. I hope you are okay with these changes.

> > Yes it would be great to contribute something back to them in they are
> > interested in having it, though i think they would also want larger sizes as
> > well. :D
> 
> I didn't mean contributing back (the basic theme is just the right size now,
> IMHO, and covers the fdo specification well) -- I really meant just having a
> link inside a text file in their git repo, so people would have a place to
> look for additional icons. Our icon scheme doesn't use the same naming as
> Gnome's, it has a number of LibreOffice-specific icons, it'd be useless to
> create larger versions of many of those icons, and maintaining both the
> Gnome repo and our icons up-to-date and consistent would be unfeasible.

Well that would do as well. :D

> > Well about the save as icon, i think we should stick with the pencil, as
> > that is what is used pretty much everywhere and we can pull the pencil from
> > the find & replace icon and add it to the purple floppy.
> 
> OK, pencil sounds good.

Glad to hear it.

Any update on Alex's progress on the save icon, as it would be important to get this fixed before the feature freeze, or else we'd have to let this change for the 4.5 release.
Comment 20 QA Administrators 2015-12-20 16:07:34 UTC Comment hidden (obsolete)
Comment 21 Adolfo Jayme Barrientos 2016-04-28 04:27:50 UTC
This bug is now unworkable and probably irrelevant by now.