Bug Hunting Session
Bug 85701 - FILESAVE: copied conditional formatting lost
Summary: FILESAVE: copied conditional formatting lost
Status: RESOLVED DUPLICATE of bug 86253
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3 Daily
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-31 15:46 UTC by Patrick Smits
Modified: 2014-11-29 19:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
testdocument for conditional formatting (20.57 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-31 15:46 UTC, Patrick Smits
Details
Borders lost upon saving. (15.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-20 23:31 UTC, Randd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Smits 2014-10-31 15:46:40 UTC
Created attachment 108730 [details]
testdocument for conditional formatting

While working with conditional formatting I noticed that it sometimes gets lost if it is copied and then saved.

I attached a file to show what I mean. Copy cell F7 and paste it to cells F10 to F12. You'll notice that the contents of the cells change color since they're dependent of the contents of the values in columns H..J. So far so good.

Now save the document and reopen it. You'll notice that only the first cell copied to (F10) has the conditional formatting.

P.S. I copy cell F7 and paste it first to F10, then to F11 and then to F12 (in different paste actions) everything goes well.
Comment 1 A (Andy) 2014-10-31 21:25:54 UTC
For me not reproducible with LO 4.3.3.2 (Win 8.1).

Could you please inform us which LO version and Operating System you are using.
Comment 2 m.a.riosv 2014-11-01 00:59:51 UTC
Seems a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=82503

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 82503 ***
Comment 3 Patrick Smits 2014-11-01 09:50:41 UTC
I just downloaded the latest version from the homepage LO 4.3.3.2 for Windows. Bug is still present on both Windows Vista and 7.
Comment 4 Patrick Smits 2014-11-01 14:05:43 UTC
Just checked, but bug is also still present in master~2014-10-31_22.31.53_LibreOfficeDev_4.4.0.0.alpha1_Win_x86_en-US_de_ar_ja_qtz
Comment 5 Patrick Smits 2014-11-01 14:17:19 UTC
Hmm, I just noticed I made a typo in my bug report. the P.S. should start with "If I copy..." otherwise it might seem as if I used different copy actions.

The bug is that you need to copy F7 to cells F10..F12 in *one* action, then save the document and reopen it. On the machines I work with, a laptop with Vista, two desktop machines with Windows 7, only cell F10 has the new conditional formatting.
Comment 6 A (Andy) 2014-11-01 15:20:29 UTC
Thanks for your reply and important remark.

First, I tried to copy cell F7 with copying/inserting it in each three cells F10 - F12 one by one and then it was not reproducible.
But if I copy/insert it in one "action" to the cells F10 - F12 then it is reproducible.

Steps done:
1. Open the attachment in CALC
2. Select cell F7
3. Press CTRL + C to copy the cell F7
4. Select the cells F10 - F12 as one selection
5. Press CTRL + V to insert the copied cell F7 in all three cells F10 - F12

Interim Result: All the three cells F10 - F12 have the conditional formatting.

6. Now save this file
7. Close the file
8. Reopen the saved file

Result: Only cell F10 has still the conditional formatting.


Reproducible with LO 4.3.3.2 (Win 8.1)
Comment 7 Randd 2014-11-20 23:31:53 UTC
Created attachment 109784 [details]
Borders lost upon saving.

Cells A4:E8 had an outside border of double lines .75 pt. File was saved as *.ods; The outside borders are lost when opened. Borders remain if the file saved as *.xlsx
Comment 8 Markus Mohrhard 2014-11-29 19:48:55 UTC

*** This bug has been marked as a duplicate of bug 86253 ***