Bug Hunting Session
Bug 85703 - Pages created by pressing Tab in a Table are not deletable
Summary: Pages created by pressing Tab in a Table are not deletable
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All Linux (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2014-10-31 16:00 UTC by (OPTIONAL) Real Name:
Modified: 2019-02-02 14:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description (OPTIONAL) Real Name: 2014-10-31 16:00:00 UTC
If you press Tab in a table it jumps to the next section of the table, or creates a new one if this was the last section in a table.

If you create a page in this way, then you cannot delete it in any possible way

Edit: it is possible with ctrl+tab+delete, but microsoft office has the same bug and there it is not possibility to delete tables there, atleast not the ones created with tab, dafuq 30 years of office products and pressing tab f***s your document and there is no bug tracker for microsoft :D
Comment 1 (OPTIONAL) Real Name: 2014-10-31 16:03:57 UTC
but this solution is unpractical for a lot of table rows (eg. you press tab for 1-3 second and have to select rows for 1 hour)
Comment 2 (OPTIONAL) Real Name: 2014-10-31 16:10:37 UTC
OK, zooming out with the mouse wheel you can select multiple pages with shift-click (select first to delete and then the last)

and then with ctrl+shift+delete get rid of them

but wth ? how can those bugs go unnoticed and unsolved ?

whenever I use software I feel like the first person to ever use it
Comment 3 Urmas 2014-11-01 00:31:03 UTC
When I delete rows, the extra pages are removed automatically.
It would help if you stop ranting and explained your issue in well-formed paragraphs.
Comment 4 Julien Nabet 2014-11-01 10:39:24 UTC
If you click "Non printing character icon", you'll see there's one after your table.
So you must delete an extra row so the page is removed.
Comment 5 (OPTIONAL) Real Name: 2014-11-03 19:02:43 UTC
hmm, sorry I was assuming the other ticket I wrote when writting this

unfortunately your solution does not work julien, I have the unprintable characters enabeled all the time but they are undeleteable in this case as well as in others

Urmas, my only rant was that you can destroy your document with pressing tab one times to often (or even enter) or pressing it for a second out of fun, I previously reported undeletable pages where the unprintable characters could not be deleted in the last line but did create a new page for no particular reason

the workaround was to make the last line in fontsize 1 so that the newline was so small that it did not create a new page


as tab and enter are pretty standard keys I cannot see how bugs like those go unnoticed / unfixed across different distributors (including microsoft) and all operating systems
Comment 6 Julien Nabet 2014-11-03 19:31:37 UTC
Real Name: I didn't write "delete the unprintable character" but delete an extra line (so a row) of the table. To do it, right click on a cell, then select "Row" then "Delete".
Also, you can undo last action with Ctrl-Z

BTW: Urmas isn't in cc of the tracker, he just let a comment here.
Comment 7 Tim Lloyd 2014-11-04 00:46:07 UTC
I can see this under Fedora (4.4.0.0) and XP (4.2.0.4) and it is a bit inconvenient.

Tab through a table so that you create a new page
Delete the offending row
The row is deleted but the extra, blank, page is still there

Julien's workaround does solve the problem but I see this as an irritating problem!
Comment 8 Tim Lloyd 2014-11-06 02:48:33 UTC
As both (optional) and I can see this I have changed to NEW with low priority
Comment 9 QA Administrators 2015-12-20 16:18:40 UTC Comment hidden (obsolete)
Comment 10 Tim Lloyd 2015-12-20 20:01:25 UTC
the problem is still present in Fedora 23

Version: 5.0.4.2
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: en-AU (en_AU.UTF-8)
Comment 11 QA Administrators 2017-01-03 19:55:40 UTC Comment hidden (obsolete)
Comment 12 Mike Kaganski 2019-02-02 14:15:03 UTC
If one makes content to not fit current (last) page, a new page is naturally created to accommodate the rest of content. This is not a bug.

Any page is only removed when there's no more content left on it. This is not a bug.

In Writer, there is a hard requirement, that tables cannot be the last element of a document; at least one (empty) paragraph must follow the last table. This is not a bug, and this brings a need for room for that last paragraph (so if table occupies the whole page, that empty paragraph would flow to the next page).

*Possibly* a detail in comment 7:

> Delete the offending row
> The row is deleted but the extra, blank, page is still there

means something different than what I described above; if so, please provide clear steps (currently I cannot repro, unless there's an empty paragraph in that last page).

Closing NOTABUG.