Bug 85779 - EPS file vertically squished upon inserting or opening
Summary: EPS file vertically squished upon inserting or opening
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-EPS
  Show dependency treegraph
 
Reported: 2014-11-02 22:24 UTC by retired
Modified: 2022-07-12 14:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
broken odt testfile | eps file | screenshot (84.71 KB, application/zip)
2014-11-02 22:24 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description retired 2014-11-02 22:24:31 UTC
Created attachment 108818 [details]
broken odt testfile | eps file | screenshot

attached:

1. original EPS file
2. odt test file which displays EPS in a very mangled way
3. screenshot of broken EPS file in LO writer

LO Version: 4.4.0.0.alpha1+
Build ID: 1a178bd5a2249b49d61ccd8c5643aa6cb501f25b
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-11-02_04:37:25
OSX 10.10.

Reproduce:

This is annoying to reproduce. You might have to wait 5 mins, add some text around the eps, move it around, scroll up and down. So far I've not found the exact step which magles the EPS file. So if it shows fine at first, please test some more. If it still shows fine after 10 minutes, it might be fine.

Current: EPS gets mangled (see test file with screenshot and odt file and original EPS to reproduce).

Expected: display EPS correctly.
Comment 1 Buovjaga 2014-11-09 20:03:57 UTC
I reproduced by inserting to blank writer document and it was immediately mangled.
The EPS contains empty music notation lines with a clef in the beginning.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: 9229170920ab770624415c4330da57af5b1b5398
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-09_03:16:43
Comment 2 steve 2016-02-09 10:48:46 UTC
retested, persisting

Version: 5.2.0.0.alpha0+
Build ID: e07ffae5046e9c91ef96026435cab84c3bcb4534
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-08_23:39:45
Locale: de-DE (de.UTF-8)
Comment 3 QA Administrators 2017-03-06 15:02:58 UTC Comment hidden (obsolete)
Comment 4 steve 2017-03-06 15:46:17 UTC
persisting
Version: 5.4.0.0.alpha0+
Build ID: c328c26a67a865d965cb8bde1b248eeae92f4e75
CPU threads: 4; OS: Mac OS X 10.12.3; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-03-04_00:50:09
Locale: de-DE (de_DE.UTF-8); Calc: group

Thought it was fixed at first, but adding text and moving image around for ~1min resulted in the broken image.
Comment 5 QA Administrators 2018-03-07 03:42:04 UTC Comment hidden (obsolete)
Comment 6 steve 2018-05-12 10:37:55 UTC
I think (TM) this is fixed.

Tried reproducing but could not. Let's set to WORKSFORME

Version: 6.1.0.0.alpha1+
Build ID: 95d5fc76defa9cba9e69b9eac4e732c60c516eb0
CPU threads: 4; OS: Mac OS X 10.13.4; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-05-11_19:42:53
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 7 Buovjaga 2018-05-12 11:45:39 UTC
It's still not right, but this time it is squished in the vertical direction.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 21b11273ae91f0cf7fd5f3f9fd2168e4349852c4
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on May 11th 2018
Comment 8 QA Administrators 2019-05-13 02:50:30 UTC Comment hidden (obsolete)
Comment 9 steve 2020-07-06 20:07:20 UTC
Bit worried on closing this preemptively but so far unable to reproduce in LO 7.0.0.1RC1
Comment 10 Buovjaga 2020-07-07 07:58:48 UTC
Still squished vertically for me. I wonder how you tested that you didn't see it? Surely it can't be OK with macOS, but broken with Win and Linux?

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 777f9cec0985f99451ecb804d5ae139a0be32253
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 4 July 2020

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 9af38b4504ccda57a0c32eb8bdd03e5a8ca29ddc
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 11 V Stuart Foote 2020-07-07 14:12:32 UTC
(In reply to Buovjaga from comment #10)
> Still squished vertically for me. I wonder how you tested that you didn't
> see it? Surely it can't be OK with macOS, but broken with Win and Linux?
> 

There are three conversion functions defined in ieps.cxx [1], they depend on the helper programs being installed and on PATH, so no surprise differing results.

RenderAsEMF -- requires pstoedit & ghostscript
RenderAsBMPThroughConvert -- requires Imagemagick & ghostscript
RenderAsBMPThroughGS -- requires ghostscript


On master/7.1.0, inserting the image onto Writer canvas, I get the same squished result on Windows where I have Imagemagick IM (convert.exe) ahead of ghostscript (gswin64c.exe) on PATH. But I get similar results using either BMP conversion, when I suppress convert.

I don't currently have the pstoedit helper loaded--as its vector output of a parsed EPS is poor.

But IM identify.exe shows the image as 8.5x11 and 612 x 792px at 72dpi, so clearly the resulting filter imported BMP is not scaled correctly in the y-dimension.

We have bug 67464 open to implement our own EPS parser--but it is not likely to advance.

=-ref-=
[1] https://opengrok.libreoffice.org/xref/core/filter/source/graphicfilter/ieps/ieps.cxx?r=835bced2
Comment 12 QA Administrators 2022-07-08 03:37:05 UTC Comment hidden (obsolete)
Comment 13 steve 2022-07-09 09:08:59 UTC
No longer able to reproduce in

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 41139aa86ecbb4c34e9996eb0f95a194b8eb0771
CPU threads: 8; OS: Mac OS X 12.4; UI render: default; VCL: osx
Locale: de-DE (en_DE.UTF-8); UI: en-US
Calc: threaded

worksforme
Comment 14 Timur 2022-07-12 14:50:08 UTC
Fixed in 7.4.